You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@logging.apache.org by "Matt Sicker (Jira)" <ji...@apache.org> on 2019/08/26 20:39:00 UTC
[jira] [Work started] (LOG4J2-2683) Rename PluginVisitor to more
appropriate name
[ https://issues.apache.org/jira/browse/LOG4J2-2683?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Work on LOG4J2-2683 started by Matt Sicker.
-------------------------------------------
> Rename PluginVisitor to more appropriate name
> ---------------------------------------------
>
> Key: LOG4J2-2683
> URL: https://issues.apache.org/jira/browse/LOG4J2-2683
> Project: Log4j 2
> Issue Type: Improvement
> Components: Core, Plugins
> Affects Versions: 3.0.0
> Reporter: Matt Sicker
> Assignee: Matt Sicker
> Priority: Major
>
> Given a few more years of experience, after taking a look at {{PluginVisitor}} again, I've finally decided it's time to name it more appropriately. This class is following a builder pattern, not a visitor, and it's for injection strategies. Thus, this class can be renamed to something like {{PluginInjectionBuilder}} along with some cleanups to make the rest of the parameters that were previously passed to {{visit()}} to instead be added as builder properties. The 2.x implementation shims should be updated to use this renamed class as well.
--
This message was sent by Atlassian Jira
(v8.3.2#803003)