You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@openjpa.apache.org by Patrick Linskey <pl...@gmail.com> on 2007/06/16 05:35:55 UTC

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Hi,

Is this change necessary?

-Patrick

On 6/15/07, wisneskid@apache.org <wi...@apache.org> wrote:
> Author: wisneskid
> Date: Fri Jun 15 16:45:14 2007
> New Revision: 547833
>
> URL: http://svn.apache.org/viewvc?view=rev&rev=547833
> Log:
> OPENJPA-240 Feature:Persistent field mapping support for XML column type.
>
> Modified:
>     openjpa/trunk/openjpa-kernel/pom.xml
>
> Modified: openjpa/trunk/openjpa-kernel/pom.xml
> URL: http://svn.apache.org/viewvc/openjpa/trunk/openjpa-kernel/pom.xml?view=diff&rev=547833&r1=547832&r2=547833
> ==============================================================================
> --- openjpa/trunk/openjpa-kernel/pom.xml (original)
> +++ openjpa/trunk/openjpa-kernel/pom.xml Fri Jun 15 16:45:14 2007
> @@ -59,6 +59,11 @@
>              <version>${pom.version}</version>
>              <scope>compile</scope>
>          </dependency>
> +           <dependency>
> +                   <groupId>javax.xml.bind</groupId>
> +                   <artifactId>jaxb-api</artifactId>
> +                   <version>2.1</version>
> +           </dependency>
>          <dependency>
>              <groupId>org.apache.geronimo.specs</groupId>
>              <artifactId>geronimo-jms_1.1_spec</artifactId>
>
>
>


-- 
Patrick Linskey
202 669 5907

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by catalina wei <ca...@gmail.com>.
This problem just fixed under r548860.
Catalina

On 6/19/07, Pinaki Poddar <pp...@bea.com> wrote:
>
> On svn revision #548858,
> $ mvn install or $ mvn compile
>
> Fails with compilation error
> D:\project\openjpa\openjpa-jdbc\src\main\java\org\apache\openjpa\jdbc\me
> ta\strats\XMLValueHandler.java:[93,14] cannot fi
> nd symbol
> symbol  : class JAXBException
> location: class org.apache.openjpa.jdbc.meta.strats.XMLValueHandler
>
> Active java version is 1.5.0_12
>
>
>
>
>
> Pinaki Poddar
> 972.834.2865
>
>
> Notice:  This email message, together with any attachments, may contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
> entities,  that may be confidential,  proprietary,  copyrighted  and/or
> legally privileged, and is intended solely for the use of the individual or
> entity named in this message. If you are not the intended recipient, and
> have received this message in error, please immediately return this by email
> and then delete it.
>

RE: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by Pinaki Poddar <pp...@bea.com>.
On svn revision #548858, 
$ mvn install or $ mvn compile

Fails with compilation error 
D:\project\openjpa\openjpa-jdbc\src\main\java\org\apache\openjpa\jdbc\me
ta\strats\XMLValueHandler.java:[93,14] cannot fi
nd symbol
symbol  : class JAXBException
location: class org.apache.openjpa.jdbc.meta.strats.XMLValueHandler 

Active java version is 1.5.0_12





Pinaki Poddar
972.834.2865


Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by catalina wei <ca...@gmail.com>.
Abe, see my comment.

On 6/19/07, Abe White <aw...@bea.com> wrote:
>
> > It is a matter of having user to specify on @Strategy with a long
> > name   "
> > org.apache.openjpa.jdbc.meta.strats.XMLValueHandler" vs. a shorter
> > name.
> > "org.apache.openjpa.jdbc.xmlmapping.XMLValueHandler"
>
> Why do they have to specify an explicit strategy at all?  Why not
> have built-in support for recognizing when to map to an XML column?
> This could be by defaulting to XML when we find a relation to a JAXB
> type that isn't annotated with any standard relationship type, or by
> introducing a new annotation, or...


Abe,

This is the first stage of introducing xmlmapping support, next stepis to
make it the  built-in strategy for XML column if there is enough
interests...
Anyway, I will use the long name "
org.apache.openjpa.jdbc.meta.strats.XMLValueHandler" for now.

Catalina

Notice:  This email message, together with any attachments, may contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
> entities,  that may be confidential,  proprietary,  copyrighted  and/or
> legally privileged, and is intended solely for the use of the individual or
> entity named in this message. If you are not the intended recipient, and
> have received this message in error, please immediately return this by email
> and then delete it.
>

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by Abe White <aw...@bea.com>.
> It is a matter of having user to specify on @Strategy with a long  
> name   "
> org.apache.openjpa.jdbc.meta.strats.XMLValueHandler" vs. a shorter  
> name.
> "org.apache.openjpa.jdbc.xmlmapping.XMLValueHandler"

Why do they have to specify an explicit strategy at all?  Why not  
have built-in support for recognizing when to map to an XML column?   
This could be by defaulting to XML when we find a relation to a JAXB  
type that isn't annotated with any standard relationship type, or by  
introducing a new annotation, or...

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by catalina wei <ca...@gmail.com>.
On 6/19/07, Michael Dick <mi...@gmail.com> wrote:
>
> Hi Catalina,
>
> Comments below.
>
> On 6/19/07, catalina wei <ca...@gmail.com> wrote:
> >
> > Dave Wisneski and I propose to do packaging cleanup for OPENJPA-240 as
> the
> > following:
> > 1. remove openjpa-xmlmapping-5
>
>
> +1
>
> 2. rename package org.apache.openjpa.xmlmapping to
> > org.apache.openjpa.jdbc.xmlmapping
>
>
> If it were me I would move the XMLValueHandler class to package
> org.apache.openjpa.jdbc.meta.strats with the rest of the ValueHandlers.
> The
> main reason is to keep similar classes grouped together, but I think it
> would also help to avoid confusion between the package and the
> openjpa-xmlmapping module.


It is a matter of having user to specify on @Strategy with a long name   "
org.apache.openjpa.jdbc.meta.strats.XMLValueHandler" vs. a shorter name.
 "org.apache.openjpa.jdbc.xmlmapping.XMLValueHandler"

I believe the strategies under org.apache.openjpa.jdbc.meta.strats are
openjpa's
default strategies, i.e.,  jpa entities need not explicitly specify
using @Strategy annotation.

Catalina

   and place it under openjpa-jdbc source directory
> > 3. rename XmlValueHandler as XMLValueHandler.
>
>
> +1
>
> Is this acceptable ?
> > Catalina
>
>
> Other than the issue noted above I think this looks good.
>
> -Mike
>
> On 6/19/07, Abe White <aw...@bea.com> wrote:
> > >
> > > I haven't looked at your code at all, but as an aside, we
> > > consistently use all caps for acronyms in our internal code: JDBC not
> > > Jdbc, URL not Url, and XML not Xml.
> > >
> > >
> > > Notice:  This email message, together with any attachments, may
> contain
> > > information  of  BEA Systems,  Inc.,  its
> subsidiaries  and  affiliated
> > > entities,  that may be
> confidential,  proprietary,  copyrighted  and/or
> > > legally privileged, and is intended solely for the use of the
> individual
> > or
> > > entity named in this message. If you are not the intended recipient,
> and
> > > have received this message in error, please immediately return this by
> > email
> > > and then delete it.
> > >
> >
>

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by Michael Dick <mi...@gmail.com>.
Hi Catalina,

Comments below.

On 6/19/07, catalina wei <ca...@gmail.com> wrote:
>
> Dave Wisneski and I propose to do packaging cleanup for OPENJPA-240 as the
> following:
> 1. remove openjpa-xmlmapping-5


+1

2. rename package org.apache.openjpa.xmlmapping to
> org.apache.openjpa.jdbc.xmlmapping


If it were me I would move the XMLValueHandler class to package
org.apache.openjpa.jdbc.meta.strats with the rest of the ValueHandlers. The
main reason is to keep similar classes grouped together, but I think it
would also help to avoid confusion between the package and the
openjpa-xmlmapping module.

    and place it under openjpa-jdbc source directory
> 3. rename XmlValueHandler as XMLValueHandler.


+1

Is this acceptable ?
> Catalina


Other than the issue noted above I think this looks good.

-Mike

On 6/19/07, Abe White <aw...@bea.com> wrote:
> >
> > I haven't looked at your code at all, but as an aside, we
> > consistently use all caps for acronyms in our internal code: JDBC not
> > Jdbc, URL not Url, and XML not Xml.
> >
> >
> > Notice:  This email message, together with any attachments, may contain
> > information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
> > entities,  that may be confidential,  proprietary,  copyrighted  and/or
> > legally privileged, and is intended solely for the use of the individual
> or
> > entity named in this message. If you are not the intended recipient, and
> > have received this message in error, please immediately return this by
> email
> > and then delete it.
> >
>

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by catalina wei <ca...@gmail.com>.
Dave Wisneski and I propose to do packaging cleanup for OPENJPA-240 as the
following:
1. remove openjpa-xmlmapping-5
2. rename package org.apache.openjpa.xmlmapping to
org.apache.openjpa.jdbc.xmlmapping
    and place it under openjpa-jdbc source directory
3. rename XmlValueHandler as XMLValueHandler.

Is this acceptable ?
Catalina

On 6/19/07, Abe White <aw...@bea.com> wrote:
>
> I haven't looked at your code at all, but as an aside, we
> consistently use all caps for acronyms in our internal code: JDBC not
> Jdbc, URL not Url, and XML not Xml.
>
>
> Notice:  This email message, together with any attachments, may contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
> entities,  that may be confidential,  proprietary,  copyrighted  and/or
> legally privileged, and is intended solely for the use of the individual or
> entity named in this message. If you are not the intended recipient, and
> have received this message in error, please immediately return this by email
> and then delete it.
>

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by Abe White <aw...@bea.com>.
I haven't looked at your code at all, but as an aside, we  
consistently use all caps for acronyms in our internal code: JDBC not  
Jdbc, URL not Url, and XML not Xml. 
  

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by Abe White <aw...@bea.com>.
> The changes in AnnotationPersistenceMappingParser.parseColumns()  
> method
> requires JAXB dependency.

Gotcha.

> I can rename openjpa-xmlmapping-5 to openjpa-xmlmapping-jdbc.
> Is this naming acceptable ?
> The org.apache.openjpa.xmlmapping package is also having dependency  
> on JAXB.

I agree with Patrick: if this is just an extension of the JDBC back  
end to support XML data, I think it should go under the existing jdbc  
module.

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by catalina wei <ca...@gmail.com>.
Abe,
The changes in AnnotationPersistenceMappingParser.parseColumns() method
requires JAXB dependency.
I can rename openjpa-xmlmapping-5 to openjpa-xmlmapping-jdbc.
Is this naming acceptable ?
The org.apache.openjpa.xmlmapping package is also having dependency on JAXB.

Catalina
On 6/18/07, Abe White <aw...@bea.com> wrote:
>
>
> > Mike & Patrick,
> > I will move the jaxb dependency from kernel to persistence-jdbc.
>
> This doesn't make any sense to me.  We have a top-level module for
> xml mapping, but it somehow created a JAXB dependency in persistence-
> jdbc?  How did that happen?
>
> And I agree with Michael Dick's latest comment: if this new module
> depends on JDBC, it either needs to go under the JDBC back-end module
> or needs some way to indicate it's a JDBC thing (like having "jdbc"
> in its name).
>
> Maybe it would help if you sent out a more detailed description of
> what depends on what.
>
> Notice:  This email message, together with any attachments, may contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
> entities,  that may be confidential,  proprietary,  copyrighted  and/or
> legally privileged, and is intended solely for the use of the individual or
> entity named in this message. If you are not the intended recipient, and
> have received this message in error, please immediately return this by email
> and then delete it.
>

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by Abe White <aw...@bea.com>.
> Mike & Patrick,
> I will move the jaxb dependency from kernel to persistence-jdbc.

This doesn't make any sense to me.  We have a top-level module for  
xml mapping, but it somehow created a JAXB dependency in persistence- 
jdbc?  How did that happen?

And I agree with Michael Dick's latest comment: if this new module  
depends on JDBC, it either needs to go under the JDBC back-end module  
or needs some way to indicate it's a JDBC thing (like having "jdbc"  
in its name).

Maybe it would help if you sent out a more detailed description of  
what depends on what.

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by catalina wei <ca...@gmail.com>.
Mike & Patrick,
I will move the jaxb dependency from kernel to persistence-jdbc.

Catalina

On 6/15/07, Michael Dick <mi...@gmail.com> wrote:
>
> Looks like it should be in openjpa-persistence-jdbc instead of
> openjpa-kernel. Unless Dave's planning on adding something else that needs
> it in kernel.
>
> -Mike
>
> On 6/15/07, Patrick Linskey <pl...@gmail.com> wrote:
> >
> > Hi,
> >
> > Is this change necessary?
> >
> > -Patrick
> >
> > On 6/15/07, wisneskid@apache.org <wi...@apache.org> wrote:
> > > Author: wisneskid
> > > Date: Fri Jun 15 16:45:14 2007
> > > New Revision: 547833
> > >
> > > URL: http://svn.apache.org/viewvc?view=rev&rev=547833
> > > Log:
> > > OPENJPA-240 Feature:Persistent field mapping support for XML column
> > type.
> > >
> > > Modified:
> > >     openjpa/trunk/openjpa-kernel/pom.xml
> > >
> > > Modified: openjpa/trunk/openjpa-kernel/pom.xml
> > > URL:
> >
> http://svn.apache.org/viewvc/openjpa/trunk/openjpa-kernel/pom.xml?view=diff&rev=547833&r1=547832&r2=547833
> > >
> >
> ==============================================================================
> > > --- openjpa/trunk/openjpa-kernel/pom.xml (original)
> > > +++ openjpa/trunk/openjpa-kernel/pom.xml Fri Jun 15 16:45:14 2007
> > > @@ -59,6 +59,11 @@
> > >              <version>${pom.version}</version>
> > >              <scope>compile</scope>
> > >          </dependency>
> > > +           <dependency>
> > > +                   <groupId>javax.xml.bind</groupId>
> > > +                   <artifactId>jaxb-api</artifactId>
> > > +                   <version>2.1</version>
> > > +           </dependency>
> > >          <dependency>
> > >              <groupId>org.apache.geronimo.specs</groupId>
> > >              <artifactId>geronimo-jms_1.1_spec</artifactId>
> > >
> > >
> > >
> >
> >
> > --
> > Patrick Linskey
> > 202 669 5907
> >
>

Re: svn commit: r547833 - /openjpa/trunk/openjpa-kernel/pom.xml

Posted by Michael Dick <mi...@gmail.com>.
Looks like it should be in openjpa-persistence-jdbc instead of
openjpa-kernel. Unless Dave's planning on adding something else that needs
it in kernel.

-Mike

On 6/15/07, Patrick Linskey <pl...@gmail.com> wrote:
>
> Hi,
>
> Is this change necessary?
>
> -Patrick
>
> On 6/15/07, wisneskid@apache.org <wi...@apache.org> wrote:
> > Author: wisneskid
> > Date: Fri Jun 15 16:45:14 2007
> > New Revision: 547833
> >
> > URL: http://svn.apache.org/viewvc?view=rev&rev=547833
> > Log:
> > OPENJPA-240 Feature:Persistent field mapping support for XML column
> type.
> >
> > Modified:
> >     openjpa/trunk/openjpa-kernel/pom.xml
> >
> > Modified: openjpa/trunk/openjpa-kernel/pom.xml
> > URL:
> http://svn.apache.org/viewvc/openjpa/trunk/openjpa-kernel/pom.xml?view=diff&rev=547833&r1=547832&r2=547833
> >
> ==============================================================================
> > --- openjpa/trunk/openjpa-kernel/pom.xml (original)
> > +++ openjpa/trunk/openjpa-kernel/pom.xml Fri Jun 15 16:45:14 2007
> > @@ -59,6 +59,11 @@
> >              <version>${pom.version}</version>
> >              <scope>compile</scope>
> >          </dependency>
> > +           <dependency>
> > +                   <groupId>javax.xml.bind</groupId>
> > +                   <artifactId>jaxb-api</artifactId>
> > +                   <version>2.1</version>
> > +           </dependency>
> >          <dependency>
> >              <groupId>org.apache.geronimo.specs</groupId>
> >              <artifactId>geronimo-jms_1.1_spec</artifactId>
> >
> >
> >
>
>
> --
> Patrick Linskey
> 202 669 5907
>