You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Matteo Bertozzi (JIRA)" <ji...@apache.org> on 2016/08/04 23:31:20 UTC

[jira] [Created] (HBASE-16360) TableMapReduceUtil addHBaseDependencyJars has the wrong class name for PrefixTreeCodec

Matteo Bertozzi created HBASE-16360:
---------------------------------------

             Summary: TableMapReduceUtil addHBaseDependencyJars has the wrong class name for PrefixTreeCodec
                 Key: HBASE-16360
                 URL: https://issues.apache.org/jira/browse/HBASE-16360
             Project: HBase
          Issue Type: Bug
          Components: mapreduce
    Affects Versions: 1.2.2, 1.0.3, 2.0.0, 1.3.0, 1.4.0
            Reporter: Matteo Bertozzi


HBASE-15152 included the prefix tree module as dependency to TableMapReduceUtil. but the hardcoded string of the class name is wrong. 

{code}
Class.forName("org.apache.hadoop.hbase.code.prefixtree.PrefixTreeCodec");
{code}

should be ".codec." instead of ".code."
{code}
Class.forName("org.apache.hadoop.hbase.codec.prefixtree.PrefixTreeCodec");
{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)