You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Karthik Kambatla (JIRA)" <ji...@apache.org> on 2015/12/29 21:23:49 UTC
[jira] [Commented] (YARN-4524) Cleanup AppSchedulingInfo
[ https://issues.apache.org/jira/browse/YARN-4524?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15074236#comment-15074236 ]
Karthik Kambatla commented on YARN-4524:
----------------------------------------
I am taking a stab at it, and it appears some of the methods can be broken up to make it more readable.
> Cleanup AppSchedulingInfo
> -------------------------
>
> Key: YARN-4524
> URL: https://issues.apache.org/jira/browse/YARN-4524
> Project: Hadoop YARN
> Issue Type: Bug
> Components: scheduler
> Affects Versions: 2.8.0
> Reporter: Karthik Kambatla
> Assignee: Karthik Kambatla
>
> The AppSchedulingInfo class has become very hard to grok with some pretty long methods. It needs some cleaning up.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)