You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Tsz-wo Sze (Jira)" <ji...@apache.org> on 2025/05/06 00:42:00 UTC
[jira] [Created] (HDDS-12972) Use DatanodeID in ContainerReplica
Tsz-wo Sze created HDDS-12972:
---------------------------------
Summary: Use DatanodeID in ContainerReplica
Key: HDDS-12972
URL: https://issues.apache.org/jira/browse/HDDS-12972
Project: Apache Ozone
Issue Type: Sub-task
Components: SCM
Reporter: Tsz-wo Sze
Assignee: Tsz-wo Sze
In ContainerReplica, the type of placeOfBirth is UUID. It is better to use DatanodeID.
We also rename placeOfBirth to originDatanodeId to match the getOriginDatanodeId() method.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org