You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Ayush Saxena (JIRA)" <ji...@apache.org> on 2019/08/07 19:13:00 UTC

[jira] [Commented] (HDFS-14608) DataNode#DataTransfer should be named

    [ https://issues.apache.org/jira/browse/HDFS-14608?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16902407#comment-16902407 ] 

Ayush Saxena commented on HDFS-14608:
-------------------------------------

HDFS-14708 is tracking {{TestLargeBlockReport}}, Got broken recently. {{TestDFSZKFailoverController}} is known flaky test.
Committed to trunk.
Thanx [~elgoiri] for the contribution!!!


> DataNode#DataTransfer should be named
> -------------------------------------
>
>                 Key: HDFS-14608
>                 URL: https://issues.apache.org/jira/browse/HDFS-14608
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Íñigo Goiri
>            Assignee: Íñigo Goiri
>            Priority: Minor
>             Fix For: 3.3.0
>
>         Attachments: HDFS-14608.000.patch, HDFS-14608.001.patch
>
>
> Currently, the {{DataTransfer}} thread has no name and it just outputs the default {{toString()}}.
> This shows in the logs in jstack as something like:
> {code}
> 2019-06-25 11:01:01,211 INFO [org.apache.hadoop.hdfs.server.datanode.DataNode$DataTransfer@609ed67a] org.apache.hadoop.hdfs.server.datanode.DataNode: DataTransfer, at CO4AEAP0000C1AF:10010: Transmitted BP-1191059133-10.1.2.3-1458888702348:blk_1113379522_69745835 (numBytes=485214) to 10.1.2.3/10.1.2.3:10010
> {code}
> As this uses the {{Daemon}} class, the name is set based on:
> {code}
>   public Daemon(Runnable runnable) {
>     super(runnable);
>     this.runnable = runnable;
>     this.setName(((Object)runnable).toString());
>   }
> {code}
> We should implement toString to at least have the name of the block being transfferred or something similar to what DataXceiver does (e.g., HDFS-3375).



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org