You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by Benjamin Mahler <bm...@apache.org> on 2018/09/17 02:24:16 UTC

Review Request 68730: Reserve sort output vector in the DRF sorter.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/68730/
-----------------------------------------------------------

Review request for mesos, Gastón Kleiman and Meng Zhu.


Repository: mesos


Description
-------

See summary.


Diffs
-----

  src/master/allocator/sorter/drf/sorter.cpp 07e5482f37da8585d0313e9f70bd8105efa19533 


Diff: https://reviews.apache.org/r/68730/diff/1/


Testing
-------

make check


Thanks,

Benjamin Mahler


Re: Review Request 68730: Reserve sort output vector in the DRF sorter.

Posted by Benjamin Mahler <bm...@apache.org>.

> On Sept. 18, 2018, 5:33 p.m., Meng Zhu wrote:
> > src/master/allocator/sorter/drf/sorter.cpp
> > Lines 553 (patched)
> > <https://reviews.apache.org/r/68730/diff/1/?file=2089826#file2089826line553>
> >
> >     This is assuming all clients are active? What if many clients are deactivated (suppressed)? Then this may make things worse?
> >     
> >     Can we keep tracking of the number of active/inactive nodes?
> >     
> >     Also, I find `clients.size()` to be more readable.

Hm.. yeah I will replace this with a TODO to reserve the number of active leaves instead.


- Benjamin


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/68730/#review208713
-----------------------------------------------------------


On Sept. 17, 2018, 2:24 a.m., Benjamin Mahler wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/68730/
> -----------------------------------------------------------
> 
> (Updated Sept. 17, 2018, 2:24 a.m.)
> 
> 
> Review request for mesos, Gastón Kleiman and Meng Zhu.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   src/master/allocator/sorter/drf/sorter.cpp 07e5482f37da8585d0313e9f70bd8105efa19533 
> 
> 
> Diff: https://reviews.apache.org/r/68730/diff/1/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Mahler
> 
>


Re: Review Request 68730: Reserve sort output vector in the DRF sorter.

Posted by Meng Zhu <mz...@mesosphere.io>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/68730/#review208713
-----------------------------------------------------------




src/master/allocator/sorter/drf/sorter.cpp
Lines 553 (patched)
<https://reviews.apache.org/r/68730/#comment292870>

    This is assuming all clients are active? What if many clients are deactivated (suppressed)? Then this may make things worse?
    
    Can we keep tracking of the number of active/inactive nodes?
    
    Also, I find `clients.size()` to be more readable.


- Meng Zhu


On Sept. 16, 2018, 7:24 p.m., Benjamin Mahler wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/68730/
> -----------------------------------------------------------
> 
> (Updated Sept. 16, 2018, 7:24 p.m.)
> 
> 
> Review request for mesos, Gastón Kleiman and Meng Zhu.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   src/master/allocator/sorter/drf/sorter.cpp 07e5482f37da8585d0313e9f70bd8105efa19533 
> 
> 
> Diff: https://reviews.apache.org/r/68730/diff/1/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Mahler
> 
>


Re: Review Request 68730: Reserve sort output vector in the sorters.

Posted by Meng Zhu <mz...@mesosphere.io>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/68730/#review208737
-----------------------------------------------------------


Ship it!




Ship It!

- Meng Zhu


On Sept. 18, 2018, 2:20 p.m., Benjamin Mahler wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/68730/
> -----------------------------------------------------------
> 
> (Updated Sept. 18, 2018, 2:20 p.m.)
> 
> 
> Review request for mesos, Gastón Kleiman and Meng Zhu.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This reserves the sort output vector consistently based on
> the number of clients, in both the DRF and random sorters.
> 
> 
> Diffs
> -----
> 
>   src/master/allocator/sorter/drf/sorter.cpp 07e5482f37da8585d0313e9f70bd8105efa19533 
>   src/master/allocator/sorter/random/sorter.cpp d17f8afa96b66e63f56ccaa472ad398f8f517b65 
> 
> 
> Diff: https://reviews.apache.org/r/68730/diff/2/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Mahler
> 
>


Re: Review Request 68730: Reserve sort output vector in the sorters.

Posted by Benjamin Mahler <bm...@apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/68730/
-----------------------------------------------------------

(Updated Sept. 18, 2018, 9:20 p.m.)


Review request for mesos, Gastón Kleiman and Meng Zhu.


Changes
-------

Updated the random sorter as well.


Summary (updated)
-----------------

Reserve sort output vector in the sorters.


Repository: mesos


Description (updated)
-------

This reserves the sort output vector consistently based on
the number of clients, in both the DRF and random sorters.


Diffs (updated)
-----

  src/master/allocator/sorter/drf/sorter.cpp 07e5482f37da8585d0313e9f70bd8105efa19533 
  src/master/allocator/sorter/random/sorter.cpp d17f8afa96b66e63f56ccaa472ad398f8f517b65 


Diff: https://reviews.apache.org/r/68730/diff/2/

Changes: https://reviews.apache.org/r/68730/diff/1-2/


Testing
-------

make check


Thanks,

Benjamin Mahler