You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Shilun Fan (Jira)" <ji...@apache.org> on 2024/01/04 07:24:00 UTC

[jira] [Commented] (HDFS-11825) Make dfshealth datanode information more readable

    [ https://issues.apache.org/jira/browse/HDFS-11825?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17802491#comment-17802491 ] 

Shilun Fan commented on HDFS-11825:
-----------------------------------

Bulk update: moved all 3.4.0 non-blocker issues, please move back if it is a blocker. Retarget 3.5.0.

> Make dfshealth datanode information more readable
> -------------------------------------------------
>
>                 Key: HDFS-11825
>                 URL: https://issues.apache.org/jira/browse/HDFS-11825
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: hdfs
>    Affects Versions: 3.0.0-alpha2
>            Reporter: Sarah Victor
>            Assignee: Sarah Victor
>            Priority: Trivial
>         Attachments: HADOOP-11825.1.patch
>
>
> On the dfshealth.html#tab-datanode web page to monitor health of Hadoop nodes (hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html)
> (1) The Capacity column reports the node capacity but is sorted by another value that is not reported (ie) the % Capacity Used. It will be good to name the column heading as "Capacity Used [%]" and report both the Capacity Used and the Capacity Used %
> (2) The Block Pool Used column reports the block pools used but is sorted by the % Block Pool Used, It will be good to name the column heading as Block Pool Used [%]
> (3) The "Last contact" column is more easily understood if we call it "Last Heartbeat". Adding the measurement unit [secs] to the header makes it more easily understood.
> (3) Adding the measurement unit [mins] to the "Last Block Report" header makes it more easily understood.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org