You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@logging.apache.org by "Matt Sicker (JIRA)" <ji...@apache.org> on 2017/07/16 16:13:01 UTC

[jira] [Commented] (LOG4J2-1431) Simplify log4j system property naming scheme

    [ https://issues.apache.org/jira/browse/LOG4J2-1431?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16088985#comment-16088985 ] 

Matt Sicker commented on LOG4J2-1431:
-------------------------------------

[~garydgregory] this is the ticket I mentioned the other day.

> Simplify log4j system property naming scheme
> --------------------------------------------
>
>                 Key: LOG4J2-1431
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-1431
>             Project: Log4j 2
>          Issue Type: Improvement
>            Reporter: Matt Sicker
>            Assignee: Matt Sicker
>
> As I wonder how to prefix yet another configurable system property, I noticed we have five families of configuration name prefixes:
> log4j.*
> log4j2.*
> Log4j*
> org.apache.logging.log4j.*
> <no prefix>
> What I'd like to do is strip out all those prefixes and allow any of them, but change the documentation to use only a single consistent prefix. This would also make it simpler when writing the properties into a log4j2.component.properties file as you could omit all the prefixes as they won't clash with other libraries.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)