You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@beam.apache.org by "Eugene Kirpichov (JIRA)" <ji...@apache.org> on 2017/02/07 22:04:42 UTC

[jira] [Created] (BEAM-1424) ToString should comply with PTransform style guide

Eugene Kirpichov created BEAM-1424:
--------------------------------------

             Summary: ToString should comply with PTransform style guide
                 Key: BEAM-1424
                 URL: https://issues.apache.org/jira/browse/BEAM-1424
             Project: Beam
          Issue Type: Bug
          Components: sdk-java-core
            Reporter: Eugene Kirpichov
            Assignee: Davor Bonaci


Suggested changes:

- Rename of() to elements(), kv() to kvs(), iterable() to iterables() for consistency between each other and with other Beam similar transforms e.g. Flatten.Iterables
- These methods should return respectively named transforms: ToString.Elements, ToString.KVs, ToString.Iterables



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)