You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mina.apache.org by "Niklas Gustavsson (JIRA)" <ji...@apache.org> on 2008/10/14 20:49:44 UTC

[jira] Closed: (FTPSERVER-195) Some boolean properties of FtpFile are not accessibile with the JavaBean isFoo()

     [ https://issues.apache.org/jira/browse/FTPSERVER-195?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Niklas Gustavsson closed FTPSERVER-195.
---------------------------------------

       Resolution: Fixed
    Fix Version/s: 1.0-M4
         Assignee: Niklas Gustavsson

Too late Emmanuel, I fixed it now in rev 704607. But, patches are of course welcome for all bugs. Thanks for reporting this one.

> Some boolean properties of FtpFile are not accessibile with the JavaBean isFoo()
> --------------------------------------------------------------------------------
>
>                 Key: FTPSERVER-195
>                 URL: https://issues.apache.org/jira/browse/FTPSERVER-195
>             Project: FtpServer
>          Issue Type: Bug
>            Reporter: Andrea Francia
>            Assignee: Niklas Gustavsson
>             Fix For: 1.0-M4
>
>
> We have three properties that do not follow the JavaBean convention:
> public interface FtpFile {
>     boolean hasReadPermission();
>     boolean hasWritePermission();
>     boolean hasDeletePermission();
>     ...
> }
> They could be renamed as 
> public interface FtpFile {
>     boolean isReadable();
>     boolean isWritable();
>     boolean isRemovable();
>     ...
> }
> Using the JavaBean convetion for properties allow interoperability with code that uses bean introspection to access to object classes.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.