You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cayenne.apache.org by "Andrus Adamchik (JIRA)" <ji...@apache.org> on 2014/11/15 09:17:33 UTC
[jira] [Closed] (CAY-1968) SQLSelect cleanup and omissions
[ https://issues.apache.org/jira/browse/CAY-1968?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Andrus Adamchik closed CAY-1968.
--------------------------------
Resolution: Fixed
Fix Version/s: 4.0.M2
> SQLSelect cleanup and omissions
> -------------------------------
>
> Key: CAY-1968
> URL: https://issues.apache.org/jira/browse/CAY-1968
> Project: Cayenne
> Issue Type: Improvement
> Reporter: Andrus Adamchik
> Assignee: Andrus Adamchik
> Fix For: 4.0.M2
>
>
> Will clean up and refactor SQLSelect API:
> Shorter style of chainable API :
> 1. rename 'useLocalCache' to 'localCache'
> 2. rename 'sharedCache' to 'sharedCache'
> Misc:
> 3. useLocalCache is void. Must return SQLSelect<T>
> 4. 'cacheStrategy' should take cache groups vararg
> 5. 'cacheGroups' should have a collection variant
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)