You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ofbiz.apache.org by "BJ Freeman (JIRA)" <ji...@apache.org> on 2009/05/31 23:01:07 UTC
[jira] Commented: (OFBIZ-2556) createUpdateEmailAddress service
should be renamed to createUpdatePartyEmailAddress remove the effort of
updating contactMech infoString
[ https://issues.apache.org/jira/browse/OFBIZ-2556?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12714928#action_12714928 ]
BJ Freeman commented on OFBIZ-2556:
-----------------------------------
I am wondering if we should not follow the same process of depreciating a service as we do with methods.
> createUpdateEmailAddress service should be renamed to createUpdatePartyEmailAddress remove the effort of updating contactMech infoString
> ----------------------------------------------------------------------------------------------------------------------------------------
>
> Key: OFBIZ-2556
> URL: https://issues.apache.org/jira/browse/OFBIZ-2556
> Project: OFBiz
> Issue Type: Improvement
> Components: party
> Reporter: Anil K Patel
> Assignee: Anil K Patel
> Priority: Minor
>
> createUpdateEmilAddress service located in PartyServices.xml file has various issues.
> 1) Services with similar goals are located in PartyContactMechService.xml file. Move this service to PartyContactMechServices.xml file as well.
> 2) Service associates contact mech with party as well so this service should be renamed to createUpdatePartyEmailAddress.
> 3) This service duplicates effort of setting emailAddress in infoString field. Remove it.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.