You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hbase.apache.org by Ted Yu <yu...@gmail.com> on 2011/03/15 15:04:52 UTC

distinguish read and write request count in region

I am thinking of distinguishing read and write request count, on top of
HBASE-3507.
For load balancer, the action for balancing read vs. write load should be
different. For read load, region movement should be low (to keep scanner
happy). For write load, region movement is allowed.

Please comment.

Re: distinguish read and write request count in region

Posted by Stack <st...@duboce.net>.
On Tue, Mar 15, 2011 at 9:58 AM, Ted Yu <yu...@gmail.com> wrote:
> Currently the single counter wouldn't be incremented because of this
> diversion.
> Should we keep the behavior same ?
>

We can keep current behavior for now.
St.Ack

Re: distinguish read and write request count in region

Posted by Ted Yu <yu...@gmail.com>.
Currently the single counter wouldn't be incremented because of this
diversion.
Should we keep the behavior same ?

Thanks

On Tue, Mar 15, 2011 at 9:55 AM, Stack <st...@duboce.net> wrote:

> On Tue, Mar 15, 2011 at 9:51 AM, Ted Yu <yu...@gmail.com> wrote:
> > How should we deal with early return by coprocessor ?
> >      if (coprocessorHost.preGetClosestRowBefore(row, family, result)) {
> >        return result;
> >      }
> > I would assume that the above wouldn't increase read request count.
> >
>
> It would be odd if the above request did not increment counters I'd
> say.  We did work to get to this point.  I'd think it should be
> reflected in counters somehow.  I'd call it a read.
>
> St.Ack
>

Re: distinguish read and write request count in region

Posted by Stack <st...@duboce.net>.
On Tue, Mar 15, 2011 at 9:51 AM, Ted Yu <yu...@gmail.com> wrote:
> How should we deal with early return by coprocessor ?
>      if (coprocessorHost.preGetClosestRowBefore(row, family, result)) {
>        return result;
>      }
> I would assume that the above wouldn't increase read request count.
>

It would be odd if the above request did not increment counters I'd
say.  We did work to get to this point.  I'd think it should be
reflected in counters somehow.  I'd call it a read.

St.Ack

Re: distinguish read and write request count in region

Posted by Ted Yu <yu...@gmail.com>.
How should we deal with early return by coprocessor ?
      if (coprocessorHost.preGetClosestRowBefore(row, family, result)) {
        return result;
      }
I would assume that the above wouldn't increase read request count.

On Tue, Mar 15, 2011 at 9:07 AM, Stack <st...@duboce.net> wrote:

> That would be useful and now we have cheap(er) counters, it should not
> be too burdensome keeping up the extra count.
> St.Ack
>
> On Tue, Mar 15, 2011 at 7:04 AM, Ted Yu <yu...@gmail.com> wrote:
> > I am thinking of distinguishing read and write request count, on top of
> > HBASE-3507.
> > For load balancer, the action for balancing read vs. write load should be
> > different. For read load, region movement should be low (to keep scanner
> > happy). For write load, region movement is allowed.
> >
> > Please comment.
> >
>

Re: distinguish read and write request count in region

Posted by Stack <st...@duboce.net>.
That would be useful and now we have cheap(er) counters, it should not
be too burdensome keeping up the extra count.
St.Ack

On Tue, Mar 15, 2011 at 7:04 AM, Ted Yu <yu...@gmail.com> wrote:
> I am thinking of distinguishing read and write request count, on top of
> HBASE-3507.
> For load balancer, the action for balancing read vs. write load should be
> different. For read load, region movement should be low (to keep scanner
> happy). For write load, region movement is allowed.
>
> Please comment.
>