You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by James Peach <jp...@apache.org> on 2017/07/21 23:48:30 UTC

Re: Review Request 59960: Add data structures and stats/control helpers for the Blkio cgroup subsystem

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/59960/#review181157
-----------------------------------------------------------




src/linux/cgroups.hpp
Lines 419 (patched)
<https://reviews.apache.org/r/59960/#comment256616>

    `major` and `minor` are [macros](https://www.freebsd.org/cgi/man.cgi?query=major()) on many platforms, so you can't safely use these function names or the scope operator here.



src/linux/cgroups.hpp
Lines 442 (patched)
<https://reviews.apache.org/r/59960/#comment256618>

    Can we come up with a better name than `Entry`? I think that this is a per-device sample, so `DeviceValue`?
    
    Similar for `StatEntry`.



src/linux/cgroups.cpp
Lines 1954 (patched)
<https://reviews.apache.org/r/59960/#comment256617>

    `makedev` might also be a macro.


- James Peach


On June 9, 2017, 11:24 p.m., Jason Lai wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/59960/
> -----------------------------------------------------------
> 
> (Updated June 9, 2017, 11:24 p.m.)
> 
> 
> Review request for mesos, Eric Chung, Xiaojian Huang, Gilbert Song, haosdent huang, Jie Yu, and Zhitao Li.
> 
> 
> Bugs: MESOS-6162
>     https://issues.apache.org/jira/browse/MESOS-6162
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> * Data structure for Blkio entities 
> * Stats helpers for `blkio.throttle.io*` (generic blkio stats)
> * Stats helpers for `blkio.io*` (CFQ related stats)
> * Comments from the kernel blkio doc for helper functions
> 
> 
> Diffs
> -----
> 
>   src/linux/cgroups.hpp eaf0dcad0ed38c507564624f1647e0c731b8b433 
>   src/linux/cgroups.cpp 334005abfc4ec9b20b7dc0212d852ba1f505dbb5 
> 
> 
> Diff: https://reviews.apache.org/r/59960/diff/1/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Jason Lai
> 
>


Re: Review Request 59960: Add data structures and stats/control helpers for the Blkio cgroup subsystem

Posted by Gilbert Song <so...@gmail.com>.

> On July 21, 2017, 4:48 p.m., James Peach wrote:
> > src/linux/cgroups.hpp
> > Lines 442 (patched)
> > <https://reviews.apache.org/r/59960/diff/1/?file=1747443#file1747443line442>
> >
> >     Can we come up with a better name than `Entry`? I think that this is a per-device sample, so `DeviceValue`?
> >     
> >     Similar for `StatEntry`.

this may not be device specific. e.g., it can be `weight` or `leaf_weight`, or some `Total` values. Here is the possible fomats in cgroup blkio files:
```
// 1. <value>
// 2. <dev> <value>
// 3. <dev> <op> <value>
// 4. <op> <value>
```


- Gilbert


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/59960/#review181157
-----------------------------------------------------------


On June 9, 2017, 4:24 p.m., Jason Lai wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/59960/
> -----------------------------------------------------------
> 
> (Updated June 9, 2017, 4:24 p.m.)
> 
> 
> Review request for mesos, Eric Chung, Xiaojian Huang, Gilbert Song, haosdent huang, Jie Yu, and Zhitao Li.
> 
> 
> Bugs: MESOS-6162
>     https://issues.apache.org/jira/browse/MESOS-6162
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> * Data structure for Blkio entities 
> * Stats helpers for `blkio.throttle.io*` (generic blkio stats)
> * Stats helpers for `blkio.io*` (CFQ related stats)
> * Comments from the kernel blkio doc for helper functions
> 
> 
> Diffs
> -----
> 
>   src/linux/cgroups.hpp eaf0dcad0ed38c507564624f1647e0c731b8b433 
>   src/linux/cgroups.cpp 334005abfc4ec9b20b7dc0212d852ba1f505dbb5 
> 
> 
> Diff: https://reviews.apache.org/r/59960/diff/1/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Jason Lai
> 
>