You are viewing a plain text version of this content. The canonical link for it is here.
Posted to adffaces-issues@incubator.apache.org by Pi...@dmr.ca on 2006/08/02 13:48:28 UTC

RE [jira] Commented: (ADFFACES-68) remove frameset border in afh:frameBorderLayout

Hiya,

After reading the comments, I agree that integers should be put instead of 
booleans.
But about the "faces-major" renderer, I am not quite sure I understand 
what is required. Could you elaborate a wee more about the requirements 
and modifications needed to modify it to a "faces-major" renderer ?

thanks,
Pierre-Luc Archambault
Fujitsu Consulting

"Adam Winer (JIRA)" <ad...@incubator.apache.org> a écrit sur 
2006-08-01 17:11:14 :

>     [ http://issues.apache.org/jira/browse/ADFFACES-68?
> page=comments#action_12425018 ] 
> 
> Adam Winer commented on ADFFACES-68:
> ------------------------------------
> 
> The attributes should be named borderWidth, frameBorderWidth, and 
> frameSpacing, and be integers, not booleans.  Also, instead of 
> patching FrameBorderLayoutRenderer, there should be a new "faces-
> major" renderer...  So, -1 on applying this patch as is.
> 
> > remove frameset border in afh:frameBorderLayout
> > -----------------------------------------------
> >
> >                 Key: ADFFACES-68
> >                 URL: http://issues.apache.org/jira/browse/ADFFACES-68
> >             Project: MyFaces ADF-Faces
> >          Issue Type: Improvement
> >            Reporter: Arnaud MERGEY
> >            Priority: Minor
> >         Attachments: FrameBorderLayoutRenderer.java, 
> FrameBorderLayoutRenderer.java, FrameBorderLayoutRenderer.patch, 
> HtmlFrameBorderLayout.patch, HtmlFrameBorderLayout.xml, patch.zip, 
> withBorder.JPG, withoutBorder.JPG
> >
> >
> > In pages I need to remove frameset border with framespacing and 
> border parameter (ex:<frameset framespacing="0" border="0" 
frameborder="0">).
> > I have hard coded in FrameBorderLayoutRenderer.java 
> >       //XXX AM:disable frameset border
> >       writer.writeAttribute("framespacing", "0", null);
> >       writer.writeAttribute("border", "0", null);
> >       writer.writeAttribute("frameborder", "0", null);
> > It would be fine to add a parameter in afh:frameBorderLayout to 
> allow conditional removing of frameset border
> 
> -- 
> This message is automatically generated by JIRA.
> -
> If you think it was sent incorrectly contact one of the administrators: 
> http://issues.apache.org/jira/secure/Administrators.jspa
> -
> For more information on JIRA, see: 
http://www.atlassian.com/software/jira
> 
> 

Re: RE [jira] Commented: (ADFFACES-68) remove frameset border in afh:frameBorderLayout

Posted by Adam Winer <aw...@gmail.com>.
The renderers in trinidadinternal.ui.laf are "UIX-major" renderers.
They're based on the wrapping up code in the old UIX framework.
This is complicated code, not inheriting at all from real JSF
Renderers.

The renderers in renderkit.core.xhtml are "Faces-major";  they're
based entirely around JSF concepts.  These are much faster
(usually 2x faster).

A major goal of Trinidad is entirely eliminating all of the code
in trinidadinternal.ui and trinidadinternal.uinode.

-- Adam

On 8/2/06, Pierre-Luc_Archambault@dmr.ca <Pi...@dmr.ca> wrote:
> Hiya,
>
> After reading the comments, I agree that integers should be put instead of
> booleans.
> But about the "faces-major" renderer, I am not quite sure I understand
> what is required. Could you elaborate a wee more about the requirements
> and modifications needed to modify it to a "faces-major" renderer ?
>
> thanks,
> Pierre-Luc Archambault
> Fujitsu Consulting
>
> "Adam Winer (JIRA)" <ad...@incubator.apache.org> a écrit sur
> 2006-08-01 17:11:14 :
>
> >     [ http://issues.apache.org/jira/browse/ADFFACES-68?
> > page=comments#action_12425018 ]
> >
> > Adam Winer commented on ADFFACES-68:
> > ------------------------------------
> >
> > The attributes should be named borderWidth, frameBorderWidth, and
> > frameSpacing, and be integers, not booleans.  Also, instead of
> > patching FrameBorderLayoutRenderer, there should be a new "faces-
> > major" renderer...  So, -1 on applying this patch as is.
> >
> > > remove frameset border in afh:frameBorderLayout
> > > -----------------------------------------------
> > >
> > >                 Key: ADFFACES-68
> > >                 URL: http://issues.apache.org/jira/browse/ADFFACES-68
> > >             Project: MyFaces ADF-Faces
> > >          Issue Type: Improvement
> > >            Reporter: Arnaud MERGEY
> > >            Priority: Minor
> > >         Attachments: FrameBorderLayoutRenderer.java,
> > FrameBorderLayoutRenderer.java, FrameBorderLayoutRenderer.patch,
> > HtmlFrameBorderLayout.patch, HtmlFrameBorderLayout.xml, patch.zip,
> > withBorder.JPG, withoutBorder.JPG
> > >
> > >
> > > In pages I need to remove frameset border with framespacing and
> > border parameter (ex:<frameset framespacing="0" border="0"
> frameborder="0">).
> > > I have hard coded in FrameBorderLayoutRenderer.java
> > >       //XXX AM:disable frameset border
> > >       writer.writeAttribute("framespacing", "0", null);
> > >       writer.writeAttribute("border", "0", null);
> > >       writer.writeAttribute("frameborder", "0", null);
> > > It would be fine to add a parameter in afh:frameBorderLayout to
> > allow conditional removing of frameset border
> >
> > --
> > This message is automatically generated by JIRA.
> > -
> > If you think it was sent incorrectly contact one of the administrators:
> > http://issues.apache.org/jira/secure/Administrators.jspa
> > -
> > For more information on JIRA, see:
> http://www.atlassian.com/software/jira
> >
> >
>
>