You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by ol...@apache.org on 2022/11/06 19:02:25 UTC
svn commit: r1905103 [8/9] - in /httpcomponents/site: ./ httpcomponents-asyncclient-4.1.x/ httpcomponents-client-4.5.x/ httpcomponents-client-5.1.x/ httpcomponents-client-5.1.x/migration-guide/ httpcomponents-client-5.2.x/ httpcomponents-core-4.4.x/ ht...
Modified: httpcomponents/site/news.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/news.html?rev=1905103&r1=1905102&r2=1905103&view=diff
==============================================================================
--- httpcomponents/site/news.html (original)
+++ httpcomponents/site/news.html Sun Nov 6 19:02:24 2022
@@ -1,13 +1,13 @@
<!DOCTYPE html>
<!--
- | Generated by Apache Maven Doxia Site Renderer 1.9.2 from src/site/markdown/news.md
+ | Generated by Apache Maven Doxia Site Renderer 1.11.1 from src/site/markdown/news.md
| Rendered using Apache Maven Fluido Skin 1.9
-->
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
- <meta name="generator" content="Apache Maven Doxia Site Renderer 1.9.2" />
+ <meta name="generator" content="Apache Maven Doxia Site Renderer 1.11.1" />
<title>Apache HttpComponents – HttpComponents Project News</title>
<link rel="stylesheet" href="./css/apache-maven-fluido-1.9.min.css" />
<link rel="stylesheet" href="./css/site.css" />
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2022-10-31<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2022-11-06<span class="divider">|</span>
</li>
<li class=""><a href="http://hc.apache.org/index.html" class="externalLink" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpComponents Project News <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/news.md"><img src="./images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li class="nav-header">Components</li>
<li><a href="httpcomponents-client-5.2.x/index.html" title="HttpClient 5.2 BETA"><span class="icon-chevron-right"></span>HttpClient 5.2 BETA</a></li>
<li><a href="httpcomponents-client-5.1.x/index.html" title="HttpClient 5.1"><span class="icon-chevron-right"></span>HttpClient 5.1</a></li>
- <li><a href="httpcomponents-core-5.2.x/index.html" title="HttpCore 5.2 BETA"><span class="icon-chevron-right"></span>HttpCore 5.2 BETA</a></li>
- <li><a href="httpcomponents-core-5.1.x/index.html" title="HttpCore 5.1"><span class="icon-chevron-right"></span>HttpCore 5.1</a></li>
+ <li><a href="httpcomponents-core-5.2.x/index.html" title="HttpCore 5.2"><span class="icon-chevron-right"></span>HttpCore 5.2</a></li>
<li><a href="httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li><a href="httpcomponents-core-4.4.x/index.html" title="HttpCore 4.4"><span class="icon-chevron-right"></span>HttpCore 4.4</a></li>
<li><a href="httpcomponents-asyncclient-4.1.x/index.html" title="HttpAsyncClient 4.1"><span class="icon-chevron-right"></span>HttpAsyncClient 4.1</a></li>
@@ -101,10 +100,25 @@
under the License.
-->
<h1>HttpComponents Project News</h1><section><section><section><section><section>
+<h6><a name="a7_November_2022_-_HttpComponents_Core_5.2_.28GA.29_released"></a>7 November 2022 - HttpComponents Core 5.2 (GA) released</h6>
+<p>This is the first GA release in the 5.2 release series. This release finalizes the 5.2 APIs and also corrects
+a number of defects discovered since the previous release.</p>
+<p>Notable changes and features included in the 5.2 series:</p>
+<ul>
+
+<li>Upgrade to Java 8.</li>
+<li>Improved support for TLS upgrade and HTTP protocol upgrade (async).</li>
+<li>Improved HTTP protocol negotiation.</li>
+<li>Improved customization of HTTP listeners (async).</li>
+<li>Improved parsing and formatting of URI components.</li>
+<li>Use of Java 1.8 date / time APIs</li>
+</ul></section><section>
<h6><a name="a12_July_2022_-_HttpComponents_Core_5.1.4_.28GA.29_released"></a>12 July 2022 - HttpComponents Core 5.1.4 (GA) released</h6>
-<p>This is a maintenance release that corrects a number of defects discovered since release 5.1.3, mostly in H2 protocol handling.</p></section><section>
+<p>This is a maintenance release that corrects a number of defects discovered since release 5.1.3, mostly in H2 protocol
+handling.</p></section><section>
<h6><a name="a8_June_2022_-_HttpComponents_Client_5.2-beta1_released"></a>8 June 2022 - HttpComponents Client 5.2-beta1 released</h6>
-<p>This is the first BETA release in the 5.2 release series that upgrades minimal JRE level to version 8 (8u251 is required) and includes several protocol level and API improvements. It also includes all bug fixes from the 5.1 branch.</p>
+<p>This is the first BETA release in the 5.2 release series that upgrades minimal JRE level to version 8 (8u251 is
+required) and includes several protocol level and API improvements. It also includes all bug fixes from the 5.1 branch.</p>
<p>Notable changes and features included in the 5.2 series:</p>
<ul>
@@ -117,35 +131,32 @@
<li>Optional support for BR (Brotli) decompression.</li>
</ul></section><section>
<h6><a name="a2_June_2022_-_HttpComponents_Core_5.2-beta2_released"></a>2 June 2022 - HttpComponents Core 5.2-beta2 released</h6>
-<p>This BETA release corrects a major regression in the TLS handshake handling code introduced in the previous BETA release.</p>
-<p>Notable changes and features included in the 5.2 series:</p>
-<ul>
-
-<li>Upgrade to Java 8.</li>
-<li>Improved support for TLS upgrade and HTTP protocol upgrade (async).</li>
-<li>Improved HTTP protocol negotiation.</li>
-<li>Improved customization of HTTP listeners (async).</li>
-<li>Improved parsing and formatting of URI components.</li>
-<li>Use of Java 1.8 date / time APIs</li>
-</ul></section><section>
+<p>This BETA release corrects a major regression in the TLS handshake handling code introduced in the previous BETA
+release.</p></section><section>
<h6><a name="a17_March_2022_-_HttpComponents_Core_5.2-beta1_released"></a>17 March 2022 - HttpComponents Core 5.2-beta1 released</h6>
-<p>This is the first BETA release in the 5.2 release series that marks the completion of major API changes and starts the transition toward a GA phase.</p></section><section>
+<p>This is the first BETA release in the 5.2 release series that marks the completion of major API changes and starts the
+transition toward a GA phase.</p></section><section>
<h6><a name="a1_February_2022_-_HttpComponents_Client_5.1.3_.28GA.29_released"></a>1 February 2022 - HttpComponents Client 5.1.3 (GA) released</h6>
<p>This release upgrades HttpCore to the latest 5.1 version and fixes a number of issues found since release 5.1.2.</p></section><section>
<h6><a name="a23_December_2021_-_HttpComponents_Core_5.1.3_.28GA.29_released"></a>23 December 2021 - HttpComponents Core 5.1.3 (GA) released</h6>
-<p>This is a maintenance release that corrects a number of defects discovered since release 5.1.2 including a regression in treating HTTP/1.0 connections as persistent by default.</p></section><section>
+<p>This is a maintenance release that corrects a number of defects discovered since release 5.1.2 including a regression in
+treating HTTP/1.0 connections as persistent by default.</p></section><section>
<h6><a name="a13_December_2021_-_HttpComponents_AsyncClient_4.1.5_.28GA.29_released"></a>13 December 2021 - HttpComponents AsyncClient 4.1.5 (GA) released</h6>
<p>This is a maintenance release that fixes a number of issues discovered since 4.1.4.</p></section><section>
<h6><a name="a8_December_2021_-_HttpComponents_Core_4.4.15_.28GA.29_released"></a>8 December 2021 - HttpComponents Core 4.4.15 (GA) released</h6>
<p>This is a maintenance release that corrects a number of defects discovered since release 4.4.14.</p></section><section>
<h6><a name="a17_November_2021_-_HttpComponents_Client_5.1.2_.28GA.29_released"></a>17 November 2021 - HttpComponents Client 5.1.2 (GA) released</h6>
-<p>This is an emergency release that fixes a regression introduced in the previous release that can lead to a connection leak when executing requests with a non-repeatable streaming entity with the classic (blocking) HttpClient. Async and minimal HttpClient implementations are not affected by the regression.</p></section><section>
+<p>This is an emergency release that fixes a regression introduced in the previous release that can lead to a connection
+leak when executing requests with a non-repeatable streaming entity with the classic (blocking) HttpClient. Async and
+minimal HttpClient implementations are not affected by the regression.</p></section><section>
<h6><a name="a3_November_2021_-_HttpComponents_Client_5.2-alpha1_released"></a>3 November 2021 - HttpComponents Client 5.2-alpha1 released</h6>
-<p>This is the first ALPHA release in the 5.2 release series that upgrades minimal JRE level to version 1.8 (8u251 is required) and includes several protocol level and API improvements. It also includes all bug fixes from the 5.1 branch.</p></section><section>
+<p>This is the first ALPHA release in the 5.2 release series that upgrades minimal JRE level to version 1.8 (8u251 is
+required) and includes several protocol level and API improvements. It also includes all bug fixes from the 5.1 branch.</p></section><section>
<h6><a name="a26_October_2021_-_HttpComponents_Client_5.1.1_.28GA.29_released"></a>26 October 2021 - HttpComponents Client 5.1.1 (GA) released</h6>
<p>This release upgrades HttpCore to the latest 5.1 version and fixes a number of issues found since release 5.1.</p></section><section>
<h6><a name="a20_September_2021_-_HttpComponents_Core_5.2-alpha2_released"></a>20 September 2021 - HttpComponents Core 5.2-alpha2 released</h6>
-<p>This is the second ALPHA release in the 5.2 release series that fixes a regression in the TLS layer introduced by the previous ALPHA and adds a number of incremental improvements.</p>
+<p>This is the second ALPHA release in the 5.2 release series that fixes a regression in the TLS layer introduced by the
+previous ALPHA and adds a number of incremental improvements.</p>
<p>Notable changes and features included in the 5.2 series:</p>
<ul>
@@ -155,9 +166,11 @@
<li>Improved parsing and formatting of URI components.</li>
</ul></section><section>
<h6><a name="a30_September_2021_-_HttpComponents_Core_5.1.2_.28GA.29_released"></a>30 September 2021 - HttpComponents Core 5.1.2 (GA) released</h6>
-<p>This is a maintenance release that corrects a number of defects discovered since release 5.1.1 including defects in handling of identity transfer encoded HTTP/1.1 response messages.</p></section><section>
+<p>This is a maintenance release that corrects a number of defects discovered since release 5.1.1 including defects in
+handling of identity transfer encoded HTTP/1.1 response messages.</p></section><section>
<h6><a name="a13_September_2021_-_HttpComponents_Core_5.2-alpha1_released"></a>13 September 2021 - HttpComponents Core 5.2-alpha1 released</h6>
-<p>This is the first ALPHA release in the 5.2 release series that upgrades minimal JRE level to version 1.8 (8u251 is required) and includes several protocol level and API improvements. It also includes all bug fixes from the 5.1 branch.</p></section><section>
+<p>This is the first ALPHA release in the 5.2 release series that upgrades minimal JRE level to version 1.8 (8u251 is
+required) and includes several protocol level and API improvements. It also includes all bug fixes from the 5.1 branch.</p></section><section>
<h6><a name="a12_May_2021_-_HttpComponents_Client_5.1_.28GA.29_released"></a>12 May 2021 - HttpComponents Client 5.1 (GA) released</h6>
<p>This is the first GA release in the 5.1 release series.</p>
<p>Notable changes and features included in the 5.1 series:</p>
@@ -167,24 +180,30 @@
<li>Improved support for out of sequence response message handing by the classic (blocking) HTTP transport.</li>
<li>Improved message builders.</li>
</ul>
-<p>Please note that 5.1 is going to be the last release series compatible with Java 1.7. HttpClient will require Java 1.8 as of 5.2.</p></section><section>
+<p>Please note that 5.1 is going to be the last release series compatible with Java 1.7. HttpClient will require Java 1.8
+as of 5.2.</p></section><section>
<h6><a name="a12_May_2021_-_HttpComponents_Client_5.0.4_.28GA.29_released"></a>12 May 2021 - HttpComponents Client 5.0.4 (GA) released</h6>
-<p>This is a maintenance release that corrects a number of defects discovered since release 5.0.3 and upgrades HttpCore to version 5.0.4 and Common Codec to version 1.15.</p></section><section>
+<p>This is a maintenance release that corrects a number of defects discovered since release 5.0.3 and upgrades HttpCore to
+version 5.0.4 and Common Codec to version 1.15.</p></section><section>
<h6><a name="a6_May_2021_-_HttpComponents_Core_5.1.1_.28GA.29_released"></a>6 May 2021 - HttpComponents Core 5.1.1 (GA) released</h6>
-<p>This is a maintenance release that corrects a number of defects discovered since release 5.1 including a major defect that can cause a connection pool resource leak.</p></section><section>
+<p>This is a maintenance release that corrects a number of defects discovered since release 5.1 including a major defect
+that can cause a connection pool resource leak.</p></section><section>
<h6><a name="a6_May_2021_-_HttpComponents_Core_5.0.4_.28GA.29_released"></a>6 May 2021 - HttpComponents Core 5.0.4 (GA) released</h6>
-<p>This is a maintenance release that corrects a number of defects discovered since release 5.0.3 including a major defect that can cause a connection pool resource leak.</p></section><section>
+<p>This is a maintenance release that corrects a number of defects discovered since release 5.0.3 including a major defect
+that can cause a connection pool resource leak.</p></section><section>
<h6><a name="a15_March_2021_-_HttpComponents_Core_5.1_.28GA.29_released"></a>15 March 2021 - HttpComponents Core 5.1 (GA) released</h6>
<p>This is the first GA release in the 5.1 release series.</p>
<p>Notable changes and features included in the 5.1 series:</p>
<ul>
<li>Conditional conformance with RFC 3986 (Uniform Resource Identifier (URI): Generic Syntax).</li>
-<li>Improved support for out of sequence response message handing by the the classic (blocking) HTTP transport.</li>
+<li>Improved support for out of sequence response message handing by the the classic (blocking)
+HTTP transport.</li>
<li>Improved message builders.</li>
</ul></section><section>
<h6><a name="a12_February_2021_-_HttpComponents_Client_5.1-beta1_released"></a>12 February 2021 - HttpComponents Client 5.1-beta1 released</h6>
-<p>This is the first BETA release in the 5.1 release series that includes a number of new features as well performance optimizations in the classic HTTP transport.</p>
+<p>This is the first BETA release in the 5.1 release series that includes a number of new features as well performance
+optimizations in the classic HTTP transport.</p>
<p>Notable changes and features included in the 5.1 series:</p>
<ul>
@@ -192,62 +211,114 @@
<li>Improved support for out of sequence response message handing by the classic (blocking) HTTP transport.</li>
</ul></section><section>
<h6><a name="a8_February_2021_-_HttpComponents_Core_5.1-beta3_released"></a>8 February 2021 - HttpComponents Core 5.1-beta3 released</h6>
-<p>This is likely the last BETA release in the 5.1 release series. The next release is expected to be 5.1 GA. This beta includes a number of new features as well as bug fixes from the stable 5.0.x branch.</p></section><section>
+<p>This is likely the last BETA release in the 5.1 release series. The next release is expected to be 5.1 GA. This beta
+includes a number of new features as well as bug fixes from the stable 5.0.x branch.</p></section><section>
<h6><a name="a3_December_2020_-_HttpComponents_Core_5.1-beta2_released"></a>3 December 2020 - HttpComponents Core 5.1-beta2 released</h6>
-<p>This is the second BETA release in the 5.1 release series that includes a number of new features as well as bug fixes from the stable 5.0.x branch.</p></section><section>
+<p>This is the second BETA release in the 5.1 release series that includes a number of new features as well as bug fixes
+from the stable 5.0.x branch.</p></section><section>
<h6><a name="a3_December_2020_-_HttpComponents_Core_5.0.3_.28GA.29_released"></a>3 December 2020 - HttpComponents Core 5.0.3 (GA) released</h6>
-<p>This is a maintenance release that corrects a number of defects discovered since release 5.0.2 including a defect in the async (non-blocking) transport potentially causing an infinite event loop and and excessive CPU utilization.</p></section><section>
+<p>This is a maintenance release that corrects a number of defects discovered since release 5.0.2 including a defect in the
+async (non-blocking) transport potentially causing an infinite event loop and and excessive CPU utilization.</p></section><section>
<h6><a name="a1_December_2020_-_HttpComponents_Core_4.4.14_.28GA.29_released"></a>1 December 2020 - HttpComponents Core 4.4.14 (GA) released</h6>
-<p>This is a maintenance release that corrects a number of defects discovered since release 4.4.13 including two defects in the async (non-blocking) transport potentially causing an infinite event loop and and excessive CPU utilization.</p></section><section>
+<p>This is a maintenance release that corrects a number of defects discovered since release 4.4.13 including two defects in
+the async (non-blocking) transport potentially causing an infinite event loop and and excessive CPU utilization.</p></section><section>
<h6><a name="a8_October_2020_-_HttpComponents_Client_5.0.3_.28GA.29_released"></a>8 October 2020 - HttpComponents Client 5.0.3 (GA) released</h6>
<p>This is a maintenance release that fixes incorrect handling of malformed authority component in request URIs.</p></section><section>
<h6><a name="a8_October_2020_-_HttpComponents_Client_4.5.13_.28GA.29_released"></a>8 October 2020 - HttpComponents Client 4.5.13 (GA) released</h6>
<p>This is a maintenance release that fixes incorrect handling of malformed authority component in request URIs.</p></section><section>
<h6><a name="a28_September_2020_-_HttpComponents_Client_5.0.2_.28GA.29_released"></a>28 September 2020 - HttpComponents Client 5.0.2 (GA) released</h6>
-<p>This is a maintenance release that upgrades HttpCore to the latest version and addresses a number of issues found since 5.0.1 release.</p></section><section>
+<p>This is a maintenance release that upgrades HttpCore to the latest version and addresses a number of issues found since
+5.0.1 release.</p></section><section>
<h6><a name="a21_September_2020_-_HttpComponents_Core_5.1-beta1_released"></a>21 September 2020 - HttpComponents Core 5.1-beta1 released</h6>
-<p>This is the first BETA release in the 5.1 release series that includes a number of new features as well performance optimizations in the classic HTTP transport.</p></section><section>
+<p>This is the first BETA release in the 5.1 release series that includes a number of new features as well performance
+optimizations in the classic HTTP transport.</p></section><section>
<h6><a name="a13_September_2020_-_HttpComponents_Core_5.0.2_.28GA.29_released"></a>13 September 2020 - HttpComponents Core 5.0.2 (GA) released</h6>
-<p>This release reverts changes to early response handling logic introduced in 5.0.1 and fixes a number of minor defects. Improvement of the early response handling by the classic client protocol handler has been moved to 5.1.</p></section><section>
+<p>This release reverts changes to early response handling logic introduced in 5.0.1 and fixes a number of minor defects.
+Improvement of the early response handling by the classic client protocol handler has been moved to 5.1.</p></section><section>
<h6><a name="a15_June_2020_-_HttpComponents_Client_5.0.1_.28GA.29_released"></a>15 June 2020 - HttpComponents Client 5.0.1 (GA) released</h6>
-<p>This is a maintenance release that upgrades HttpCore to the latest version and addresses a number of issues found since 5.0 release.</p></section><section>
+<p>This is a maintenance release that upgrades HttpCore to the latest version and addresses a number of issues found since
+5.0 release.</p></section><section>
<h6><a name="a10_June_2020_-_HttpComponents_Core_5.0.1_.28GA.29_released"></a>10 June 2020 - HttpComponents Core 5.0.1 (GA) released</h6>
-<p>This is a maintenance release that improves handling of early response messages by the classic client protocol handler and fixes a number of minor defects.</p></section><section>
+<p>This is a maintenance release that improves handling of early response messages by the classic client protocol handler
+and fixes a number of minor defects.</p></section><section>
<h6><a name="a9_March_2020_-_HttpComponents_Client_4.5.12_.28GA.29_released"></a>9 March 2020 - HttpComponents Client 4.5.12 (GA) released</h6>
-<p>This is a maintenance release that fixes a regression introduced by the previous release that caused rejection of certificates with non-standard domains.</p></section><section>
+<p>This is a maintenance release that fixes a regression introduced by the previous release that caused rejection of
+certificates with non-standard domains.</p></section><section>
<h6><a name="a24_February_2020_-_HttpComponents_Client_5.0_.28GA.29_released"></a>24 February 2020 - HttpComponents Client 5.0 (GA) released</h6>
<p>This is the first stable (GA) release of HttpClient 5.0.</p>
<p>Notable changes and features included in the 5.0 series are:</p>
<ul>
-<li>Support for the HTTP/2 protocol and conformance to requirements and recommendations of the latest HTTP/2 protocol specification documents (RFC 7540, RFC 7541.)</li>
-</ul>
-<p>Supported features: - HPACK header compression - Stream multiplexing (client and server) - Flow control - Response push - Message trailers - Expect-continue handshake - Connection validation (ping) - Application-layer protocol negotiation (ALPN) - TLS 1.2 security features</p>
+<li>
+
+<p>Support for the HTTP/2 protocol and conformance to requirements and recommendations of the latest HTTP/2 protocol
+specification documents
+(RFC 7540, RFC 7541.)</p>
+<p>Supported features:</p>
<ul>
-<li>Improved conformance to requirements and recommendations of the latest HTTP/1.1 protocol specification documents ( RFC 7230, RFC 7231.)</li>
-<li>New connection pool implementation with lax connection limit guarantees and better performance under higher concurrency due to absence of a global pool lock.</li>
-<li>Support for Reactive Streams API <a class="externalLink" href="http://www.reactive-streams.org/">http://www.reactive-streams.org/</a></li>
-<li>Package name space changed to ‘org.apache.hc.client5’.</li>
-<li>Maven group id changed to ‘org.apache.httpcomponents.client5’.</li>
+<li>HPACK header compression</li>
+<li>Stream multiplexing (client and server)</li>
+<li>Flow control</li>
+<li>Response push</li>
+<li>Message trailers</li>
+<li>Expect-continue handshake</li>
+<li>Connection validation (ping)</li>
+<li>Application-layer protocol negotiation (ALPN)</li>
+<li>TLS 1.2 security features</li>
</ul>
-<p>HttpClient 5.0 releases can be co-located with earlier major versions on the same classpath due to the change in package names and Maven module coordinates.</p></section><section>
+</li>
+<li>
+
+<p>Improved conformance to requirements and recommendations of the latest HTTP/1.1 protocol specification documents (
+RFC 7230, RFC 7231.)</p>
+</li>
+<li>
+
+<p>New connection pool implementation with lax connection limit guarantees and better performance under higher
+concurrency due to absence of a global pool lock.</p>
+</li>
+<li>
+
+<p>Support for Reactive Streams API <a class="externalLink" href="http://www.reactive-streams.org/">http://www.reactive-streams.org/</a></p>
+</li>
+<li>
+
+<p>Package name space changed to ‘org.apache.hc.client5’.</p>
+</li>
+<li>
+
+<p>Maven group id changed to ‘org.apache.httpcomponents.client5’.</p>
+</li>
+</ul>
+<p>HttpClient 5.0 releases can be co-located with earlier major versions on the same classpath due to the change in package
+names and Maven module coordinates.</p></section><section>
<h6><a name="a18_February_2020_-_HttpComponents_Core_5.0_.28GA.29_released"></a>18 February 2020 - HttpComponents Core 5.0 (GA) released</h6>
<p>This is the first stable (GA) release of HttpCore 5.0.</p>
<p>Notable changes and features included in the 5.0 series:</p>
<ul>
-<li>Support for HTTP/2 protocol and conformance to requirements and recommendations of the latest HTTP/2 protocol specification (RFC 7540, RFC 7541)</li>
-</ul>
-<p>Supported features: - HPACK header compression - stream multiplexing (client and server) - flow control - response push (client and server) - message trailers - expect-continue handshake - connection validation (ping) - application-layer protocol negotiation (ALPN) on Java 9+ - TLS 1.2 security features</p>
-<p>Features out of scope for 5.0 release:</p>
-<ul>
-
<li>
-<p>padding of outgoing frames</p>
+<p>Support for HTTP/2 protocol and conformance to requirements and recommendations of the latest HTTP/2 protocol
+specification (RFC 7540, RFC 7541)</p>
+<p>Supported features:</p>
<ul>
+<li>HPACK header compression</li>
+<li>stream multiplexing (client and server)</li>
+<li>flow control</li>
+<li>response push (client and server)</li>
+<li>message trailers</li>
+<li>expect-continue handshake</li>
+<li>connection validation (ping)</li>
+<li>application-layer protocol negotiation (ALPN) on Java 9+</li>
+<li>TLS 1.2 security features</li>
+</ul>
+<p>Features out of scope for 5.0 release:</p>
+<ul>
+
+<li>padding of outgoing frames</li>
<li>stream priority</li>
<li>plain connection HTTP/1.1 upgrade</li>
<li>CONNECT method</li>
@@ -255,42 +326,76 @@
</li>
<li>
-<p>Improved conformance to requirements and recommendations of the latest HTTP/1.1 protocol specification (RFC 7230, RFC 7231)</p>
+<p>Improved conformance to requirements and recommendations of the latest HTTP/1.1 protocol specification (RFC 7230, RFC
+7231)</p>
+</li>
+<li>
+
+<p>New asynchronous HTTP transport APIs consistent for both HTTP/1.1 and HTTP/2 transport.</p>
+</li>
+<li>
+
+<p>Redesigned I/O reactor APIs and improved NIO based reactor implementation for a greater performance and scalability.</p>
+</li>
+<li>
+
+<p>Support for server-side request filters for classic and asynchronous server implementations. Request filters could be
+used to implement cross-cutting protocol aspects such as the ‘expect-continue’ handshaking and user authentication /
+authorization.</p>
+</li>
+<li>
+
+<p>Support for Reactive Streams API <a class="externalLink" href="http://www.reactive-streams.org/">http://www.reactive-streams.org/</a></p>
+</li>
+<li>
+
+<p>Redesigned connection pool implementation with strict connection limit guarantees. The connection pool is expected to
+have a better performance under higher concurrency due to reduced global pool lock contention.</p>
+</li>
+<li>
+
+<p>New connection pool implementation with lax connection limit guarantees and better performance under higher
+concurrency due to absence of a global pool lock.</p>
+</li>
+<li>
+
+<p>Package name space changed to ‘org.apache.hc.core5’</p>
</li>
-<li>New asynchronous HTTP transport APIs consistent for both HTTP/1.1 and HTTP/2 transport.</li>
-<li>Redesigned I/O reactor APIs and improved NIO based reactor implementation for a greater performance and scalability.</li>
-<li>Support for server-side request filters for classic and asynchronous server implementations. Request filters could be used to implement cross-cutting protocol aspects such as the ‘expect-continue’ handshaking and user authentication / authorization.</li>
-<li>Support for Reactive Streams API <a class="externalLink" href="http://www.reactive-streams.org/">http://www.reactive-streams.org/</a></li>
-<li>Redesigned connection pool implementation with strict connection limit guarantees. The connection pool is expected to have a better performance under higher concurrency due to reduced global pool lock contention.</li>
-<li>New connection pool implementation with lax connection limit guarantees and better performance under higher concurrency due to absence of a global pool lock.</li>
-<li>Package name space changed to ‘org.apache.hc.core5’</li>
<li>
<p>Maven group id changed to ‘org.apache.httpcomponents.core5’</p>
</li>
</ul></section><section>
<h6><a name="a27_January_2020_-_HttpComponents_Client_5.0-beta7_released"></a>27 January 2020 - HttpComponents Client 5.0-beta7 released</h6>
-<p>This BETA release upgrades HttpCore to the latest version and addresses a number of issues found since the previous BETA release.</p></section><section>
+<p>This BETA release upgrades HttpCore to the latest version and addresses a number of issues found since the previous BETA
+release.</p></section><section>
<h6><a name="a20_January_2020_-_HttpComponents_Client_4.5.11_.28GA.29_released"></a>20 January 2020 - HttpComponents Client 4.5.11 (GA) released</h6>
-<p>This is a maintenance release that fixes a number defects discovered since 4.5.10 and upgrades HttpCore dependency to version 4.4.13.</p></section><section>
+<p>This is a maintenance release that fixes a number defects discovered since 4.5.10 and upgrades HttpCore dependency to
+version 4.4.13.</p></section><section>
<h6><a name="a14_January_2020_-_HttpComponents_Core_4.4.13_.28GA.29_released"></a>14 January 2020 - HttpComponents Core 4.4.13 (GA) released</h6>
<p>This is a maintenance release that corrects a number of defects discovered since release 4.4.12.</p></section><section>
<h6><a name="a8_January_2019_-_HttpComponents_HttpCore_5.0-beta11_released"></a>8 January 2019 - HttpComponents HttpCore 5.0-beta11 released</h6>
-<p>This BETA fixes HTTP/2 SETTINGS_HEADER_TABLE_SIZE negotiation and HTTP/2 connection window management logic as well as fixes a number of other defects found since the last release.</p></section><section>
+<p>This BETA fixes HTTP/2 SETTINGS_HEADER_TABLE_SIZE negotiation and HTTP/2 connection window management logic as well as
+fixes a number of other defects found since the last release.</p></section><section>
<h6><a name="a31_October_2019_-_HttpComponents_HttpCore_5.0-beta10_released"></a>31 October 2019 - HttpComponents HttpCore 5.0-beta10 released</h6>
-<p>This BETA fixes a bug in the HTTP/2 setting handshake implementation and a performance regression in HTTP/1.1 protocol handler.</p></section><section>
+<p>This BETA fixes a bug in the HTTP/2 setting handshake implementation and a performance regression in HTTP/1.1 protocol
+handler.</p></section><section>
<h6><a name="a10_October_2019_-_HttpComponents_HttpClient_5.0-beta6_released"></a>10 October 2019 - HttpComponents HttpClient 5.0-beta6 released</h6>
-<p>This BETA release picks up the latest fixes and performance improvements from HttpCore and addresses a number of issues found since the previous BETA release.</p></section><section>
+<p>This BETA release picks up the latest fixes and performance improvements from HttpCore and addresses a number of issues
+found since the previous BETA release.</p></section><section>
<h6><a name="a7_October_2019_-_HttpComponents_HttpCore_5.0-beta9_released"></a>7 October 2019 - HttpComponents HttpCore 5.0-beta9 released</h6>
-<p>This BETA fixes a number of defects found since the last release, improves behavior of the lax (concurrent) connection pools, simplifies and improves input event handling of SSL/TLS sessions and the HTTP/1.1 protocol event handler.</p></section><section>
+<p>This BETA fixes a number of defects found since the last release, improves behavior of the lax (concurrent) connection
+pools, simplifies and improves input event handling of SSL/TLS sessions and the HTTP/1.1 protocol event handler.</p></section><section>
<h6><a name="a10_Sept_2019_-_HttpComponents_Client_4.5.10_.28GA.29_released"></a>10 Sept 2019 - HttpComponents Client 4.5.10 (GA) released</h6>
<p>This is a maintenance release that corrects a number of defects discovered since release 4.5.9.</p></section><section>
<h6><a name="a5_Sept_2019_-_HttpComponents_Core_4.4.12_.28GA.29_released"></a>5 Sept 2019 - HttpComponents Core 4.4.12 (GA) released</h6>
<p>This is a maintenance release that corrects a number of defects discovered since release 4.4.11.</p></section><section>
<h6><a name="a22_July_2019_-_HttpComponents_HttpClient_5.0-beta5_released"></a>22 July 2019 - HttpComponents HttpClient 5.0-beta5 released</h6>
-<p>This BETA release picks up the latest fixes and performance improvements from HttpCore and addresses a number of issues found since the previous BETA release.</p></section><section>
+<p>This BETA release picks up the latest fixes and performance improvements from HttpCore and addresses a number of issues
+found since the previous BETA release.</p></section><section>
<h6><a name="a15_July_2019_-_HttpComponents_HttpCore_5.0-beta8_released"></a>15 July 2019 - HttpComponents HttpCore 5.0-beta8 released</h6>
-<p>This BETA fixes a number of defects found since the last release and adds several convenience factory and builder classes, mainly for TLS configuration and HTTP message construction.</p>
+<p>This BETA fixes a number of defects found since the last release and adds several convenience factory and builder
+classes, mainly for TLS configuration and HTTP message construction.</p>
<p>Notable new features in this release:</p>
<ul>
@@ -299,7 +404,8 @@
<h6><a name="a12_June_2019_-_HttpComponents_HttpClient_4.5.9_.28GA.29_released"></a>12 June 2019 - HttpComponents HttpClient 4.5.9 (GA) released</h6>
<p>This is a maintenance release that fixes a number defects discovered since 4.5.8.</p></section><section>
<h6><a name="a8_April_2019_-_HttpComponents_HttpClient_5.0-beta4_released"></a>8 April 2019 - HttpComponents HttpClient 5.0-beta4 released</h6>
-<p>This BETA release picks up the latest fixes and performance improvements from HttpCore and addresses a number of issues found since the previous BETA release.</p>
+<p>This BETA release picks up the latest fixes and performance improvements from HttpCore and addresses a number of issues
+found since the previous BETA release.</p>
<p>Notable features in this release:</p>
<ul>
@@ -307,9 +413,11 @@
<li>URI handling improvements.</li>
</ul></section><section>
<h6><a name="a31_March_2019_-_HttpComponents_HttpClient_4.5.8_.28GA.29_released"></a>31 March 2019 - HttpComponents HttpClient 4.5.8 (GA) released</h6>
-<p>This is a maintenance release that makes request URI normalization configurable on per request basis and also ports several improvements in URI handling from HttpCore master.</p></section><section>
+<p>This is a maintenance release that makes request URI normalization configurable on per request basis and also ports
+several improvements in URI handling from HttpCore master.</p></section><section>
<h6><a name="a4_March_2019_-_HttpComponents_HttpCore_5.0-beta7_released"></a>4 March 2019 - HttpComponents HttpCore 5.0-beta7 released</h6>
-<p>This BETA release adds support for SOCKS version 5, improves support for TLS handshake timeout configuration, improves URI builder, and fixes various defects.</p>
+<p>This BETA release adds support for SOCKS version 5, improves support for TLS handshake timeout configuration, improves
+URI builder, and fixes various defects.</p>
<p>Notable new features in this release:</p>
<ul>
@@ -317,25 +425,31 @@
<li>Improved TLS handshake timeout configuration</li>
</ul></section><section>
<h6><a name="a24_January_2019_-_HttpComponents_HttpClient_4.5.7_.28GA.29_released"></a>24 January 2019 - HttpComponents HttpClient 4.5.7 (GA) released</h6>
-<p>This is a maintenance release that corrects Automatic-Module-Name definitions added in the previous release and fixes a number of minor defects discovered since 4.5.6.</p></section><section>
+<p>This is a maintenance release that corrects Automatic-Module-Name definitions added in the previous release and fixes a
+number of minor defects discovered since 4.5.6.</p></section><section>
<h6><a name="a21_January_2019_-_HttpComponents_HttpCore_4.4.11_.28GA.29_released"></a>21 January 2019 - HttpComponents HttpCore 4.4.11 (GA) released</h6>
-<p>This is a maintenance release that corrects a number of defects in non-blocking SSL session code that caused compatibility issues with TLSv1.3 protocol implementation shipped with Java 11.</p></section><section>
+<p>This is a maintenance release that corrects a number of defects in non-blocking SSL session code that caused
+compatibility issues with TLSv1.3 protocol implementation shipped with Java 11.</p></section><section>
<h6><a name="a17_December_2018_-_HttpComponents_HttpClient_5.0-beta3_released"></a>17 December 2018 - HttpComponents HttpClient 5.0-beta3 released</h6>
-<p>This BETA release adds support for advanced TLS functions (such as ALPN protocol negotiation) on Java 1.7 and Java 1.8 through Conscrypt TLS library and picks up the latest fixes and performance improvements from HttpCore.</p>
+<p>This BETA release adds support for advanced TLS functions (such as ALPN protocol negotiation)
+on Java 1.7 and Java 1.8 through Conscrypt TLS library and picks up the latest fixes and performance improvements from
+HttpCore.</p>
<p>Notable new features in this release:</p>
<ul>
<li>TLS ALPN protocol negotiation support on older JREs through Conscrypt TLS library.</li>
</ul></section><section>
<h6><a name="a6_December_2018_-_HttpComponents_HttpCore_5.0-beta6_released"></a>6 December 2018 - HttpComponents HttpCore 5.0-beta6 released</h6>
-<p>This BETA release adds support for advanced TLS functions (such as ALPN protocol negotiation) on Java 1.7 and Java 1.8 through Conscrypt TLS library, and fixes a number of defects found since the previous release.</p>
+<p>This BETA release adds support for advanced TLS functions (such as ALPN protocol negotiation)
+on Java 1.7 and Java 1.8 through Conscrypt TLS library, and fixes a number of defects found since the previous release.</p>
<p>Notable new features in this release:</p>
<ul>
<li>TLS ALPN protocol negotiation on Java 1.7 and Java 1.8 through Conscrypt TLS library</li>
</ul></section><section>
<h6><a name="a29_October_2018_-_HttpComponents_HttpClient_5.0-beta2_released"></a>29 October 2018 - HttpComponents HttpClient 5.0-beta2 released</h6>
-<p>This BETA release resolves compatibility issues with Java 11 new TLS engine as well as a number of defects found since the previous release.</p>
+<p>This BETA release resolves compatibility issues with Java 11 new TLS engine as well as a number of defects found since
+the previous release.</p>
<p>Notable new features in this release:</p>
<ul>
@@ -344,25 +458,36 @@
<li>Support for Reactive Streams API <a class="externalLink" href="http://www.reactive-streams.org/">http://www.reactive-streams.org/</a></li>
</ul></section><section>
<h6><a name="a22_October_2018_-_HttpComponents_HttpCore_5.0-beta5_released"></a>22 October 2018 - HttpComponents HttpCore 5.0-beta5 released</h6>
-<p>This BETA release adds support for Reactive Streams API [http://www.reactive-streams.org/] and fixes compatibility issues with Java 11 new TLS engine as well as a number of defects found since the previous release.</p>
-<p>This release also includes a redesigned HTTP stress test tool loosely based on Apache Benchmark (AB) command interface with support for HTTP/2.</p></section><section>
+<p>This BETA release adds support for Reactive Streams API [http://www.reactive-streams.org/]
+and fixes compatibility issues with Java 11 new TLS engine as well as a number of defects found since the previous
+release.</p>
+<p>This release also includes a redesigned HTTP stress test tool loosely based on Apache Benchmark (AB) command interface
+with support for HTTP/2.</p></section><section>
<h6><a name="a29_August_2018_-_HttpComponents_HttpCore_5.0-beta3_released"></a>29 August 2018 - HttpComponents HttpCore 5.0-beta3 released</h6>
-<p>This BETA release fixes a number of defects found since the previous release, adds several incremental improvements and improves javadoc documentation.</p></section><section>
+<p>This BETA release fixes a number of defects found since the previous release, adds several incremental improvements and
+improves javadoc documentation.</p></section><section>
<h6><a name="a23_July_2018_-_HttpComponents_HttpAsyncClient_4.1.4_.28GA.29_released"></a>23 July 2018 - HttpComponents HttpAsyncClient 4.1.4 (GA) released</h6>
-<p>This is a maintenance release that adds Automatic-Module-Name to the manifest for compatibility with Java 9 Platform Module System and fixes a number of issues discovered since 4.1.3.</p></section><section>
+<p>This is a maintenance release that adds Automatic-Module-Name to the manifest for compatibility with Java 9 Platform
+Module System and fixes a number of issues discovered since 4.1.3.</p></section><section>
<h6><a name="a9_July_2018_-_HttpComponents_HttpClient_4.5.6_.28GA.29_released"></a>9 July 2018 - HttpComponents HttpClient 4.5.6 (GA) released</h6>
-<p>This is a maintenance release that adds Automatic-Module-Name to the manifest for compatibility with Java 9 Platform Module System and fixes a number of issues discovered since 4.5.5.</p></section><section>
+<p>This is a maintenance release that adds Automatic-Module-Name to the manifest for compatibility with Java 9 Platform
+Module System and fixes a number of issues discovered since 4.5.5.</p></section><section>
<h6><a name="a3_July_2018_-_HttpComponents_HttpCore_4.4.10_.28GA.29_released"></a>3 July 2018 - HttpComponents HttpCore 4.4.10 (GA) released</h6>
-<p>This is a maintenance release that adds Automatic-Module-Name to the manifest for compatibility with Java 9 Platform Module System and fixes a number of issues discovered since 4.4.9.</p></section><section>
+<p>This is a maintenance release that adds Automatic-Module-Name to the manifest for compatibility with Java 9 Platform
+Module System and fixes a number of issues discovered since 4.4.9.</p></section><section>
<h6><a name="a22_January_2018_-_HttpComponents_HttpClient_4.5.5_GA_released"></a>22 January 2018 - HttpComponents HttpClient 4.5.5 GA released</h6>
-<p>This is a maintenance release that fixes a regression introduced by the previous release causing a NPE in SystemDefaultCredentialsProvider.</p></section><section>
+<p>This is a maintenance release that fixes a regression introduced by the previous release causing a NPE in
+SystemDefaultCredentialsProvider.</p></section><section>
<h6><a name="a18_January_2018_-_HttpComponents_HttpClient_5.0-beta1_released"></a>18 January 2018 - HttpComponents HttpClient 5.0-beta1 released</h6>
-<p>This is the first BETA release of HttpClient 5.0. The 5.0 release serices introduces support for the HTTP/2 protocol and event driven messaging APIs consistent for all supported HTTP protocol versions.</p>
+<p>This is the first BETA release of HttpClient 5.0. The 5.0 release serices introduces support for the HTTP/2 protocol and
+event driven messaging APIs consistent for all supported HTTP protocol versions.</p>
<p>HttpClient ships with two client implementations:</p>
<ul>
-<li>HttpClient Classic is based on the classic (blocking) I/O model; largely compatible with the 4.x APIs; supports HTTP/1.1 only.</li>
-<li>HttpClient Async is based on NIO model; new event driven APIs consistent for all supported HTTP protocol versions; supports both HTTP/1.1 and HTTP/2.</li>
+<li>HttpClient Classic is based on the classic (blocking) I/O model; largely compatible with the 4.x APIs; supports
+HTTP/1.1 only.</li>
+<li>HttpClient Async is based on NIO model; new event driven APIs consistent for all supported HTTP protocol versions;
+supports both HTTP/1.1 and HTTP/2.</li>
</ul>
<p>Notable new features in this release:</p>
<ul>
@@ -378,7 +503,8 @@
<h6><a name="a4_December_2017_-_HttpComponents_HttpClient_4.5.4_.28GA.29_released"></a>4 December 2017 - HttpComponents HttpClient 4.5.4 (GA) released</h6>
<p>This is a maintenance release that fixes a number of issues discovered since release 4.5.3.</p></section><section>
<h6><a name="a27_November_2017_-_HttpComponents_HttpClient_5.0-alpha3_released"></a>27 November 2017 - HttpComponents HttpClient 5.0-alpha3 released</h6>
-<p>This is a major release that introduces support for the HTTP/2 protocol and event driven messaging APIs consistent for all supported HTTP protocol versions.</p>
+<p>This is a major release that introduces support for the HTTP/2 protocol and event driven messaging APIs consistent for
+all supported HTTP protocol versions.</p>
<p>Notable new features in this release:</p>
<ul>
@@ -386,7 +512,8 @@
<li>Full support for HTTP caching by asynchronous HttpClient implementations including streaming message exchanages.</li>
</ul></section><section>
<h6><a name="a6_November_2017_-_HttpComponents_HttpCore_5.0-beta1_released"></a>6 November 2017 - HttpComponents HttpCore 5.0-beta1 released</h6>
-<p>This is a major release that renders HttpCore API incompatible with the stable 4.x branch and upgrades HTTP/1.1 and HTTP/2 protocol conformance to the requirements and recommendations of the latest protocol specification.</p>
+<p>This is a major release that renders HttpCore API incompatible with the stable 4.x branch and upgrades HTTP/1.1 and
+HTTP/2 protocol conformance to the requirements and recommendations of the latest protocol specification.</p>
<p>Notable new features in this release:</p>
<ul>
@@ -397,11 +524,14 @@
<h6><a name="a14_September_2017_-_HttpComponents_HttpCore_4.4.7_.28GA.29_released"></a>14 September 2017 - HttpComponents HttpCore 4.4.7 (GA) released</h6>
<p>This is a maintenance release that fixes a number of issues discovered since release 4.4.6.</p></section><section>
<h6><a name="a4_September_2017_-_HttpComponents_HttpCore_5.0-alpha4_released"></a>4 September 2017 - HttpComponents HttpCore 5.0-alpha4 released</h6>
-<p>This is a major release that renders HttpCore API incompatible with the stable 4.x branch and upgrades HTTP/1.1 and HTTP/2 protocol conformance to the requirements and recommendations of the latest protocol specification.</p></section><section>
+<p>This is a major release that renders HttpCore API incompatible with the stable 4.x branch and upgrades HTTP/1.1 and
+HTTP/2 protocol conformance to the requirements and recommendations of the latest protocol specification.</p></section><section>
<h6><a name="a11_May_2017_-_HttpComponents_HttpClient_5.0-alpha2_released"></a>11 May 2017 - HttpComponents HttpClient 5.0-alpha2 released</h6>
-<p>This is a major release that introduces support for HTTP/2 protocol and event driven messaging APIs consistent for all supported HTTP protocol versions.</p></section><section>
+<p>This is a major release that introduces support for HTTP/2 protocol and event driven messaging APIs consistent for all
+supported HTTP protocol versions.</p></section><section>
<h6><a name="a2_May_2017_-_HttpComponents_HttpCore_5.0-alpha3_released"></a>2 May 2017 - HttpComponents HttpCore 5.0-alpha3 released</h6>
-<p>This is a major release that renders HttpCore API incompatible with the stable 4.x branch and upgrades HTTP/1.1 and HTTP/2 protocol conformance to the requirements and recommendations of the latest protocol specification.</p></section><section>
+<p>This is a major release that renders HttpCore API incompatible with the stable 4.x branch and upgrades HTTP/1.1 and
+HTTP/2 protocol conformance to the requirements and recommendations of the latest protocol specification.</p></section><section>
<h6><a name="a10_February_2017_-_HttpComponents_HttpAsyncClient_4.1.3_.28GA.29_released"></a>10 February 2017 - HttpComponents HttpAsyncClient 4.1.3 (GA) released</h6>
<p>This is a maintenance release that fixes a number of issues discovered since release 4.1.2.</p></section><section>
<h6><a name="a27_January_2017_-_HttpComponents_HttpClient_4.5.3_.28GA.29_released"></a>27 January 2017 - HttpComponents HttpClient 4.5.3 (GA) released</h6>
@@ -409,7 +539,8 @@
<h6><a name="a12_January_2017_-_HttpComponents_HttpCore_4.4.6_.28GA.29_released"></a>12 January 2017 - HttpComponents HttpCore 4.4.6 (GA) released</h6>
<p>This is a maintenance release that fixes a number of issues discovered since release 4.4.5.</p></section><section>
<h6><a name="a27_December_2016_-_HttpComponents_HttpCore_5.0-alpha2_released"></a>27 December 2016 - HttpComponents HttpCore 5.0-alpha2 released</h6>
-<p>This is a major release that renders HttpCore API incompatible with the stable 4.x branch and upgrades HTTP/1.1 and HTTP/2 protocol conformance to the requirements and recommendations of the latest protocol specification.</p></section><section>
+<p>This is a major release that renders HttpCore API incompatible with the stable 4.x branch and upgrades HTTP/1.1 and
+HTTP/2 protocol conformance to the requirements and recommendations of the latest protocol specification.</p></section><section>
<h6><a name="a27_June_2016_-_HttpComponents_HttpAsyncClient_4.1.2_.28GA.29_released"></a>27 June 2016 - HttpComponents HttpAsyncClient 4.1.2 (GA) released</h6>
<p>This is a maintenance release that fixes a number of issues discovered since release 4.1.1.</p></section><section>
<h6><a name="a14_June_2016_-_HttpComponents_HttpCore_4.4.5_.28GA.29_released"></a>14 June 2016 - HttpComponents HttpCore 4.4.5 (GA) released</h6>
@@ -417,11 +548,16 @@
<h6><a name="a1_March_2016_-_HttpComponents_HttpClient_4.5.2_.28GA.29_released"></a>1 March 2016 - HttpComponents HttpClient 4.5.2 (GA) released</h6>
<p>This is a maintenance release that fixes a number of minor bugs reported since 4.5.1.</p></section><section>
<h6><a name="a28_January_2016_-_HttpComponents_HttpClient_5.0-alpha1_released"></a>28 January 2016 - HttpComponents HttpClient 5.0-alpha1 released</h6>
-<p>This is a major release that renders HttpClient API incompatible with the stable 4.x branch and upgrades HTTP/1.1 protocol conformance to the requirements and recommendations of the latest protocol specification. This release lays the foundation for transition to HTTP/2 as the primary transport protocol in the future releases.</p></section><section>
+<p>This is a major release that renders HttpClient API incompatible with the stable 4.x branch and upgrades HTTP/1.1
+protocol conformance to the requirements and recommendations of the latest protocol specification. This release lays the
+foundation for transition to HTTP/2 as the primary transport protocol in the future releases.</p></section><section>
<h6><a name="a3_January_2016_-_HttpComponents_HttpCore_5.0-alpha1_released"></a>3 January 2016 - HttpComponents HttpCore 5.0-alpha1 released</h6>
-<p>This is a major release that renders HttpCore API incompatible with the stable 4.x branch and upgrades HTTP/1.1 protocol conformance to the requirements and recommendations of the latest protocol specification. This release lays the foundation for transition to HTTP/2 as the primary transport protocol in the future releases.</p></section><section>
+<p>This is a major release that renders HttpCore API incompatible with the stable 4.x branch and upgrades HTTP/1.1 protocol
+conformance to the requirements and recommendations of the latest protocol specification. This release lays the
+foundation for transition to HTTP/2 as the primary transport protocol in the future releases.</p></section><section>
<h6><a name="a9_November_2015_-_HttpComponents_HttpAsyncClient_4.1.1_.28GA.29_released"></a>9 November 2015 - HttpComponents HttpAsyncClient 4.1.1 (GA) released</h6>
-<p>This is a maintenance release that fixes a number of issues discovered since release 4.1 and upgrades HttpCore and HttpClient dependencies.</p></section><section>
+<p>This is a maintenance release that fixes a number of issues discovered since release 4.1 and upgrades HttpCore and
+HttpClient dependencies.</p></section><section>
<h6><a name="a4_November_2015_-_HttpComponents_HttpCore_4.4.4_.28GA.29_released"></a>4 November 2015 - HttpComponents HttpCore 4.4.4 (GA) released</h6>
<p>This is a maintenance release that fixes a number of issues discovered since release 4.4.3.</p></section><section>
<h6><a name="a16_September_2015_-_HttpComponents_HttpClient_4.5.1_.28GA.29_released"></a>16 September 2015 - HttpComponents HttpClient 4.5.1 (GA) released</h6>
@@ -429,16 +565,26 @@
<h6><a name="a11_September_2015_-_HttpComponents_HttpCore_4.4.3_.28GA.29_released"></a>11 September 2015 - HttpComponents HttpCore 4.4.3 (GA) released</h6>
<p>This maintenance release fixes a bug in non-blocking HTTP request pipelining code discovered since 4.3.1.</p></section><section>
<h6><a name="a5_June_2015_-_HttpClient_4.5_.28GA.29_released"></a>5 June 2015 - HttpClient 4.5 (GA) released</h6>
-<p>HttpClient 4.5 (GA) is a minor feature release that includes several incremental enhancements to the exisitng functionality such as support for private domains in the Mozilla Public Suffix List.</p></section><section>
+<p>HttpClient 4.5 (GA) is a minor feature release that includes several incremental enhancements to the exisitng
+functionality such as support for private domains in the Mozilla Public Suffix List.</p></section><section>
<h6><a name="a23_April_2015_-_HttpAsyncClient_4.1_.28GA.29_released"></a>23 April 2015 - HttpAsyncClient 4.1 (GA) released</h6>
-<p>This is the first stable (GA) release of HttpAsyncClient 4.1. Notable features and enhancements included in 4.1 series are:</p>
+<p>This is the first stable (GA) release of HttpAsyncClient 4.1. Notable features and enhancements included in 4.1 series
+are:</p>
<ul>
<li>Support for pipelined request execution</li>
-<li>Support for the latest HTTP state management specification (RFC 6265). Please note that the old cookie policy is still used by default for compatibility reasons. RFC 6265 compliant cookie policies need to be explicitly configured by the user. Please also note that as of next feature release support for Netscape draft, RFC 2109 and RFC 2965 cookie policies will be deprecated and disabled by default. It is recommended to use RFC 6265 compliant policies for new applications unless compatibility with RFC 2109 and RFC 2965 is required and to migrate existing applications to the default cookie policy.</li>
+<li>Support for the latest HTTP state management specification (RFC 6265). Please note that the old cookie policy is still
+used by default for compatibility reasons. RFC 6265 compliant cookie policies need to be explicitly configured by the
+user. Please also note that as of next feature release support for Netscape draft, RFC 2109 and RFC 2965 cookie
+policies will be deprecated and disabled by default. It is recommended to use RFC 6265 compliant policies for new
+applications unless compatibility with RFC 2109 and RFC 2965 is required and to migrate existing applications to the
+default cookie policy.</li>
<li>Enhanced, redesigned and rewritten default SSL hostname verifier with improved RFC 2818 compliance</li>
-<li>Default SSL hostname verifier and default cookie policy now validate certificate identity and cookie domain of origin against the public suffix list maintained by Mozilla.org <a class="externalLink" href="https://publicsuffix.org/list">https://publicsuffix.org/list</a></li>
-<li>Authentication cache thread-safety: authentication cache used by HttpClient is now thread-safe and can be shared by multiple threads in order to re-use authentication state for subsequent requests</li>
+<li>Default SSL hostname verifier and default cookie policy now validate certificate identity and cookie domain of origin
+against the public suffix list maintained by Mozilla.org
+<a class="externalLink" href="https://publicsuffix.org/list">https://publicsuffix.org/list</a></li>
+<li>Authentication cache thread-safety: authentication cache used by HttpClient is now thread-safe and can be shared by
+multiple threads in order to re-use authentication state for subsequent requests</li>
</ul></section><section>
<h6><a name="a31_March_2015_-_HttpComponents_HttpClient_4.4.1_.28GA.29_released"></a>31 March 2015 - HttpComponents HttpClient 4.4.1 (GA) released</h6>
<p>This is a maintenance release that fixes a number of bugs reported since 4.4.</p></section><section>
@@ -448,12 +594,25 @@
<p>This is the first stable (GA) release of HttpClient 4.4. Notable features and enhancements included in 4.4 series are:</p>
<ul>
-<li>Support for the latest HTTP state management specification (RFC 6265). Please note that the old cookie policy is still used by default for compatibility reasons. RFC 6265 compliant cookie policies need to be explicitly configured by the user. Please also note that as of next feature release support for Netscape draft, RFC 2109 and RFC 2965 cookie policies will be deprecated and disabled by default. It is recommended to use RFC 6265 compliant policies for new applications unless compatibility with RFC 2109 and RFC 2965 is required and to migrate existing applications to the default cookie policy.</li>
+<li>Support for the latest HTTP state management specification (RFC 6265). Please note that the old cookie policy is still
+used by default for compatibility reasons. RFC 6265 compliant cookie policies need to be explicitly configured by the
+user. Please also note that as of next feature release support for Netscape draft, RFC 2109 and RFC 2965 cookie
+policies will be deprecated and disabled by default. It is recommended to use RFC 6265 compliant policies for new
+applications unless compatibility with RFC 2109 and RFC 2965 is required and to migrate existing applications to the
+default cookie policy.</li>
<li>Enhanced, redesigned and rewritten default SSL hostname verifier with improved RFC 2818 compliance</li>
-<li>Default SSL hostname verifier and default cookie policy now validate certificate identity and cookie domain of origin against the public suffix list maintained by Mozilla.org <a class="externalLink" href="https://publicsuffix.org/list">https://publicsuffix.org/list</a></li>
-<li>More efficient stale connection checking: indiscriminate connection checking which results in approximately 20 to 50 ms overhead per request has been deprecated in favor of conditional connection state validation (persistent connections are to be re-validated only if a specified period inactivity has elapsed)</li>
-<li>Authentication cache thread-safety: authentication cache used by HttpClient is now thread-safe and can be shared by multiple threads in order to re-use authentication state for subsequent requests</li>
-<li>Native Windows Negotiate and NTLM via SSPI through JNA: when running on Windows OS HttpClient configured to use native NTLM or SPNEGO authentication schemes can make use of platform specific functionality via JNA and current user credentials. This functionality is still considered experimental, known to have compatibility issues and subject to change without prior notice.</li>
+<li>Default SSL hostname verifier and default cookie policy now validate certificate identity and cookie domain of origin
+against the public suffix list maintained by Mozilla.org
+<a class="externalLink" href="https://publicsuffix.org/list">https://publicsuffix.org/list</a></li>
+<li>More efficient stale connection checking: indiscriminate connection checking which results in approximately 20 to 50
+ms overhead per request has been deprecated in favor of conditional connection state validation (persistent
+connections are to be re-validated only if a specified period inactivity has elapsed)</li>
+<li>Authentication cache thread-safety: authentication cache used by HttpClient is now thread-safe and can be shared by
+multiple threads in order to re-use authentication state for subsequent requests</li>
+<li>Native Windows Negotiate and NTLM via SSPI through JNA: when running on Windows OS HttpClient configured to use native
+NTLM or SPNEGO authentication schemes can make use of platform specific functionality via JNA and current user
+credentials. This functionality is still considered experimental, known to have compatibility issues and subject to
+change without prior notice.</li>
</ul></section><section>
<h6><a name="a17_December_2014_-_HttpComponents_HttpCore_4.4_released"></a>17 December 2014 - HttpComponents HttpCore 4.4 released</h6>
<p>This is the first stable (GA) release of HttpCore 4.4. The most notable features included in 4.4 series are:</p>
@@ -465,63 +624,102 @@
<li>Inclusion of SSL context initialization utilities from HttpClient</li>
</ul></section><section>
<h6><a name="a6_November_2014_-_HttpComponents_HttpClient_4.3.6_.28GA.29_released"></a>6 November 2014 - HttpComponents HttpClient 4.3.6 (GA) released</h6>
-<p>This is a maintenance release that fixes several problems with HttpClient OSGi bundle as well as some other issues reported since release 4.3.5.</p>
-<p>Please note that as of this release HttpClient disables all versions of SSL (including SSLv3) in favor of the TLS protocol by default. Those users who wish to continue using SSLv3 need to explicitly enable support for it.</p></section><section>
+<p>This is a maintenance release that fixes several problems with HttpClient OSGi bundle as well as some other issues
+reported since release 4.3.5.</p>
+<p>Please note that as of this release HttpClient disables all versions of SSL (including SSLv3)
+in favor of the TLS protocol by default. Those users who wish to continue using SSLv3 need to explicitly enable support
+for it.</p></section><section>
<h6><a name="a22_October_2014_-_HttpComponents_HttpCore_4.3.3_.28GA.29_released"></a>22 October 2014 - HttpComponents HttpCore 4.3.3 (GA) released</h6>
-<p>This maintenance release fixes a number of bugs found since 4.3.2, mostly in the NIO transport components. All users of HttpCore 4.3 are advised to upgrade.</p></section><section>
+<p>This maintenance release fixes a number of bugs found since 4.3.2, mostly in the NIO transport components. All users of
+HttpCore 4.3 are advised to upgrade.</p></section><section>
<h6><a name="a17_October_2014_-_HttpComponents_HttpAsyncClient_4.4-beta1_released"></a>17 October 2014 - HttpComponents HttpAsyncClient 4.4-beta1 released</h6>
<p>This is the first BETA release of HttpAsyncClient 4.1. Notable features and enhancements included in 4.1 series are:</p>
<ul>
<li>Support for pipelined request execution</li>
<li>Enhanced redesigned and rewritten default SSL hostname verifier with improved RFC 2818 compliance</li>
-<li>Default SSL hostname verifier and default cookie policy now validate certificate identity and cookie domain of origin against the public suffix list maintained by Mozilla.org <a class="externalLink" href="https://publicsuffix.org/list">https://publicsuffix.org/list</a></li>
-<li>Authentication cache thread-safety: authentication caches used by HttpAsyncClient is now thread-safe and can be shared by multiple contexts in order to re-use authentication state for subsequent requests</li>
+<li>Default SSL hostname verifier and default cookie policy now validate certificate identity and cookie domain of origin
+against the public suffix list maintained by Mozilla.org
+<a class="externalLink" href="https://publicsuffix.org/list">https://publicsuffix.org/list</a></li>
+<li>Authentication cache thread-safety: authentication caches used by HttpAsyncClient is now thread-safe and can be shared
+by multiple contexts in order to re-use authentication state for subsequent requests</li>
</ul></section><section>
<h6><a name="a28_September_2014_-_HttpComponents_HttpClient_4.4-beta1_released"></a>28 September 2014 - HttpComponents HttpClient 4.4-beta1 released</h6>
-<p>This is the first BETA release of HttpClient 4.4. Notable features and enhancements included in 4.4 series are: enhanced redesigned and rewritten default SSL hostname verifier with improved RFC 2818 compliance; default SSL hostname verifier and default cookie policy now validate certificate identity and cookie domain of origin against the public suffix list maintained by Mozilla.org; native windows Negotiate/NTLM via JNA; more efficient stale connection checking; authentication cache thread-safety</p></section><section>
+<p>This is the first BETA release of HttpClient 4.4. Notable features and enhancements included in 4.4 series are:
+enhanced redesigned and rewritten default SSL hostname verifier with improved RFC 2818 compliance; default SSL hostname
+verifier and default cookie policy now validate certificate identity and cookie domain of origin against the public
+suffix list maintained by Mozilla.org; native windows Negotiate/NTLM via JNA; more efficient stale connection checking;
+authentication cache thread-safety</p></section><section>
<h6><a name="a22_September_2014_-_HttpComponents_HttpCore_4.4-beta1_released"></a>22 September 2014 - HttpComponents HttpCore 4.4-beta1 released</h6>
-<p>This is the first BETA release from the 4.4.x development branch. The most notable features included in 4.4 series are: support for pipelined request processing on the server side; support for pipelined request execution on the client side; simplified bootstrapping of blocking and non-blocking (NIO) HTTP server implementations.</p></section><section>
+<p>This is the first BETA release from the 4.4.x development branch. The most notable features included in 4.4 series are:
+support for pipelined request processing on the server side; support for pipelined request execution on the client side;
+simplified bootstrapping of blocking and non-blocking (NIO) HTTP server implementations.</p></section><section>
<h6><a name="a10_Aug_2014_-_HttpComponents_HttpAsyncClient_4.0.2_.28GA.29_released"></a>10 Aug 2014 - HttpComponents HttpAsyncClient 4.0.2 (GA) released</h6>
<p>HttpAsyncClient 4.0.2 (GA) is a bug fix release that addresses several issues reported since release 4.0.1.</p></section><section>
<h6><a name="a10_Aug_2014_-_HttpComponents_HttpClient_4.3.5_.28GA.29_released"></a>10 Aug 2014 - HttpComponents HttpClient 4.3.5 (GA) released</h6>
<p>HttpClient 4.3.5 (GA) is a bug fix release that addresses several issues reported since release 4.3.4.</p></section><section>
<h6><a name="a30_June_2014_-_HttpComponents_HttpClient_4.4-alpha1_released"></a>30 June 2014 - HttpComponents HttpClient 4.4-alpha1 released</h6>
-<p>This is the first ALPHA release from the 4.4.x development branch. Notable features and enhancements included this release are: more efficient stale connection checking, native Windows Negotiate/NTLM via JNA, authentication cache thread-safety</p></section><section>
+<p>This is the first ALPHA release from the 4.4.x development branch. Notable features and enhancements included this
+release are: more efficient stale connection checking, native Windows Negotiate/NTLM via JNA, authentication cache
+thread-safety</p></section><section>
<h6><a name="a18_June_2014_-_HttpComponents_HttpCore_4.4-alpha1_released"></a>18 June 2014 - HttpComponents HttpCore 4.4-alpha1 released</h6>
-<p>This is the first release from the 4.4.x development branch. The most notable features included in this release are: support for pipelined request processing on the server side, support for pipelined request execution on the client sides, simplified bootstrapping of blocking and non-blocking (NIO) HTTP server implementations</p></section><section>
+<p>This is the first release from the 4.4.x development branch. The most notable features included in this release are:
+support for pipelined request processing on the server side, support for pipelined request execution on the client
+sides, simplified bootstrapping of blocking and non-blocking (NIO) HTTP server implementations</p></section><section>
<h6><a name="a6_June_2014_-_HttpComponents_HttpClient_4.3.4_.28GA.29_released"></a>6 June 2014 - HttpComponents HttpClient 4.3.4 (GA) released</h6>
-<p>HttpClient 4.3.4 (GA) is a maintenance release that improves performance in high concurrency scenarios. This version replaces dynamic proxies with custom proxy classes and eliminates thread contention in java.reflect.Proxy.newInstance() when leasing connections from the connection pool and processing response messages</p></section><section>
+<p>HttpClient 4.3.4 (GA) is a maintenance release that improves performance in high concurrency scenarios. This version
+replaces dynamic proxies with custom proxy classes and eliminates thread contention in java.reflect.Proxy.newInstance()
+when leasing connections from the connection pool and processing response messages</p></section><section>
<h6><a name="a26_February_2014_-_HttpComponents_HttpClient_4.3.3_.28GA.29_released"></a>26 February 2014 - HttpComponents HttpClient 4.3.3 (GA) released</h6>
-<p>HttpClient 4.3.3 (GA) is a bug fix release that fixes a regression introduced by the previous release causing a significant performance degradation in compressed content processing.</p>
+<p>HttpClient 4.3.3 (GA) is a bug fix release that fixes a regression introduced by the previous release causing a
+significant performance degradation in compressed content processing.</p>
<p>Users of HttpClient 4.3 are encouraged to upgrade.</p></section><section>
<h6><a name="a24_February_2014_-_HttpComponents_HttpAsyncClient_4.0.1_.28GA.29_released"></a>24 February 2014 - HttpComponents HttpAsyncClient 4.0.1 (GA) released</h6>
-<p>This maintenance release fixes a number of bugs including incorrect OSGi bundle metadata found since release 4.0. This release also upgrades HttpCore and HttpClient dependencies to the latest stable versions.</p>
+<p>This maintenance release fixes a number of bugs including incorrect OSGi bundle metadata found since release 4.0. This
+release also upgrades HttpCore and HttpClient dependencies to the latest stable versions.</p>
<p>Users of HttpAsyncClient 4.0 are advised to upgrade.</p></section><section>
<h6><a name="a17_February_2014_-_HttpComponents_HttpCore_4.3.2_.28GA.29_released"></a>17 February 2014 - HttpComponents HttpCore 4.3.2 (GA) released</h6>
-<p>This maintenance release fixes a number of bugs and regressions found since 4.3.1, mostly in the NIO transport components. All users of HttpCore 4.3 are advised to upgrade.</p></section><section>
+<p>This maintenance release fixes a number of bugs and regressions found since 4.3.1, mostly in the NIO transport
+components. All users of HttpCore 4.3 are advised to upgrade.</p></section><section>
<h6><a name="a19_January_2014_-_HttpComponents_HttpClient_4.3.2_.28GA.29_released"></a>19 January 2014 - HttpComponents HttpClient 4.3.2 (GA) released</h6>
-<p>HttpClient 4.3.2 (GA) is a maintenance release that delivers a number of improvements as well as bug fixes for issues reported since 4.3.1 release. SNI support for Oracle JRE 1.7+ is being among the most notable improvements.</p>
+<p>HttpClient 4.3.2 (GA) is a maintenance release that delivers a number of improvements as well as bug fixes for issues
+reported since 4.3.1 release. SNI support for Oracle JRE 1.7+ is being among the most notable improvements.</p>
<p>Users of HttpClient 4.3 are encouraged to upgrade.</p></section><section>
<h6><a name="a27_December_2013_-_HttpComponents_HttpCore_4.3.1_.28GA.29_released"></a>27 December 2013 - HttpComponents HttpCore 4.3.1 (GA) released</h6>
-<p>This maintenance release fixes a number of bugs and regressions found since 4.3, mostly in the NIO transport components. All users of HttpCore 4.3 are advised to upgrade.</p></section><section>
+<p>This maintenance release fixes a number of bugs and regressions found since 4.3, mostly in the NIO transport components.
+All users of HttpCore 4.3 are advised to upgrade.</p></section><section>
<h6><a name="a31_October_2013_-_HttpComponents_HttpAsyncClient_4.0_.28GA.29_released"></a>31 October 2013 - HttpComponents HttpAsyncClient 4.0 (GA) released</h6>
-<p>This is the first stable (GA) release of Apache HttpAsyncClient 4.0. HttpAsyncClient is a library for asynchronous client-side HTTP communication built on top of HttpCore NIO transport. It is a complementary library to Apache HttpClient intended and optimized for special cases whereby ability to scale to many thousands of concurrent connections is more important than performance in terms of raw data throughput.</p>
-<p>HttpAsyncClient 4.0 is designed to have similar APIs as Apache HttpClient 4.3 and a comparable feature set. In addition HttpAsyncClient provides full support for zero-copy file upload and download operations. It presently does not support transparent content decompression and automatic I/O error recovery. These features may be added in future releases.</p></section><section>
+<p>This is the first stable (GA) release of Apache HttpAsyncClient 4.0. HttpAsyncClient is a library for asynchronous
+client-side HTTP communication built on top of HttpCore NIO transport. It is a complementary library to Apache
+HttpClient intended and optimized for special cases whereby ability to scale to many thousands of concurrent connections
+is more important than performance in terms of raw data throughput.</p>
+<p>HttpAsyncClient 4.0 is designed to have similar APIs as Apache HttpClient 4.3 and a comparable feature set. In addition
+HttpAsyncClient provides full support for zero-copy file upload and download operations. It presently does not support
+transparent content decompression and automatic I/O error recovery. These features may be added in future releases.</p></section><section>
<h6><a name="a7_October_2013_-_HttpComponents_HttpClient_4.3.1_.28GA.29_released"></a>7 October 2013 - HttpComponents HttpClient 4.3.1 (GA) released</h6>
-<p>This is a maintenance release that addresses a number of issues reported since release 4.3, including one major security issue. Users of HttpClient 4.3 are strongly advised to upgrade.</p></section><section>
+<p>This is a maintenance release that addresses a number of issues reported since release 4.3, including one major security
+issue. Users of HttpClient 4.3 are strongly advised to upgrade.</p></section><section>
<h6><a name="a12_September_2013_-_HttpComponents_HttpClient_4.3_.28GA.29_released"></a>12 September 2013 - HttpComponents HttpClient 4.3 (GA) released</h6>
-<p>This is the first stable (GA) release of HttpClient 4.3. The 4.3 branch enhances HttpClient in several key areas and includes several notable features and improvements:</p>
+<p>This is the first stable (GA) release of HttpClient 4.3. The 4.3 branch enhances HttpClient in several key areas and
+includes several notable features and improvements:</p>
<ul>
<li>Support for Java 7 try-with-resources for resource management (connection release.)</li>
<li>Added fluent Builder classes for HttpEntity, HttpRequest, HttpClient and SSLContext instances.</li>
-<li>Deprecation of preference and configuration API based on HttpParams interface in favor of constructor injection and plain configuration objects.</li>
-<li>Reliance on object immutability instead of access synchronization for thread safety. Several old classes whose instances can be shared by multiple request exchanges have been replaced by immutable equivalents.</li>
-<li>DefaultHttpClient, DecompressingHttpClient, CachingHttpClient and similar classes are deprecated in favor of builder classes that produce immutable HttpClient instances.</li>
-<li>HttpClient builders now dynamically construct a request execution pipeline tailored specifically to the user configuration by physically excluding unnecessary protocol components.</li>
-<li>There is now an option to construct a minimal HttpClient implementation that can only execute basic HTTP message exchanges without redirects, authentication, state management or proxy support. This feature might be of particular use in web crawler development.</li>
-<li>There is now option to avoid strict URI syntax for request URIs by executing HTTP requests with an explicitly specified target host. HttpClient will no longer attempt to parse the request URI if it does not need to extract the target host from it.</li>
+<li>Deprecation of preference and configuration API based on HttpParams interface in favor of constructor injection and
+plain configuration objects.</li>
+<li>Reliance on object immutability instead of access synchronization for thread safety. Several old classes whose
+instances can be shared by multiple request exchanges have been replaced by immutable equivalents.</li>
+<li>DefaultHttpClient, DecompressingHttpClient, CachingHttpClient and similar classes are deprecated in favor of builder
+classes that produce immutable HttpClient instances.</li>
+<li>HttpClient builders now dynamically construct a request execution pipeline tailored specifically to the user
+configuration by physically excluding unnecessary protocol components.</li>
+<li>There is now an option to construct a minimal HttpClient implementation that can only execute basic HTTP message
+exchanges without redirects, authentication, state management or proxy support. This feature might be of particular
+use in web crawler development.</li>
+<li>There is now option to avoid strict URI syntax for request URIs by executing HTTP requests with an explicitly
+specified target host. HttpClient will no longer attempt to parse the request URI if it does not need to extract the
+target host from it.</li>
</ul>
<p>This release also includes all fixes from the stable 4.2.x release branch.</p></section><section>
<h6><a name="a12_September_2013_-_HttpComponents_HttpClient_4.2.6_.28GA.29_released"></a>12 September 2013 - HttpComponents HttpClient 4.2.6 (GA) released</h6>
@@ -530,137 +728,228 @@
<p>This is the first stable (GA) release of HttpCore 4.3. The most notable features in the 4.3 branch are:</p>
<ul>
-<li>Deprecation of preference and configuration API based on HttpParams interface in favor of constructor injection and plain configuration objects.</li>
-<li>Reliance on object immutability instead of access synchronization for thread safety. Several old classes whose instances can be shared by multiple request exchanges have been replaced by immutable equivalents.</li>
+<li>Deprecation of preference and configuration API based on HttpParams interface in favor of constructor injection and
+plain configuration objects.</li>
+<li>Reliance on object immutability instead of access synchronization for thread safety. Several old classes whose
+instances can be shared by multiple request exchanges have been replaced by immutable equivalents.</li>
</ul>
-<p>The 4.3 branch also contains performance optimizations such as reduced TCP packet fragmentation and more efficient lease / release operations for pools of persistent connections on the client side.</p>
+<p>The 4.3 branch also contains performance optimizations such as reduced TCP packet fragmentation and more efficient lease
+/ release operations for pools of persistent connections on the client side.</p>
<p>This release also includes all fixes from the 4.2.x release branch.</p></section><section>
<h6><a name="a5_August_2013_-_HttpComponents_HttpCore_4.2.5_released"></a>5 August 2013 - HttpComponents HttpCore 4.2.5 released</h6>
-<p>This is a maintenance release that fixes a number of bugs found in NIO components since 4.2.4. Users of earlier versions of HttpCore 4.2 are advised to upgrade.</p>
+<p>This is a maintenance release that fixes a number of bugs found in NIO components since 4.2.4. Users of earlier versions
+of HttpCore 4.2 are advised to upgrade.</p>
<p>This is likely to be the last release in the 4.2.x branch.</p></section><section>
<h6><a name="a12_June_2013_-_HttpComponents_HttpClient_4.3-beta2_released"></a>12 June 2013 - HttpComponents HttpClient 4.3-beta2 released</h6>
-<p>This is the second BETA release of HttpClient 4.3. The 4.3 branch enhances HttpClient in several key areas and includes several notable features and improvements: Support for Java 7 try-with-resources for resource management ( connection release); fluent Builder classes for HttpEntity, HttpRequest and HttpClient instances, deprecation of preference and configuration API based on HttpParams interface in favor of constructor injection and plain configuration objects, reliance on object immutability instead of access synchronization for thread safety.</p>
+<p>This is the second BETA release of HttpClient 4.3. The 4.3 branch enhances HttpClient in several key areas and includes
+several notable features and improvements: Support for Java 7 try-with-resources for resource management (
+connection release); fluent Builder classes for HttpEntity, HttpRequest and HttpClient instances, deprecation of
+preference and configuration API based on HttpParams interface in favor of constructor injection and plain configuration
+objects, reliance on object immutability instead of access synchronization for thread safety.</p>
<p>This release also includes all fixes from the stable 4.2.x release branch.</p></section><section>
<h6><a name="a16_May_-_HttpComponents_HttpAsyncClient_4.0-beta4_released"></a>16 May - HttpComponents HttpAsyncClient 4.0-beta4 released</h6>
-<p>The 4.0 BETA4 release delivers significant performance improvements in request execution, especially for short HTTP messages, and also re-aligns programming interfaces used by the library with HttpCore 4.3 and HttpClient 4.3 APIs. Configuration and preference APIs of HttpAsyncClient are now consistent with those used by HttpClient 4.3.</p></section><section>
+<p>The 4.0 BETA4 release delivers significant performance improvements in request execution, especially for short HTTP
+messages, and also re-aligns programming interfaces used by the library with HttpCore 4.3 and HttpClient 4.3 APIs.
+Configuration and preference APIs of HttpAsyncClient are now consistent with those used by HttpClient 4.3.</p></section><section>
<h6><a name="a8_May_-_HttpComponents_HttpCore_4.3-beta2_released"></a>8 May - HttpComponents HttpCore 4.3-beta2 released</h6>
-<p>This is the second BETA release from the 4.3.x release branch. This release addresses performance issues in the non-blocking connection pool implementation and also includes a number of performance improvements in the low level NIO based transport components.</p></section><section>
+<p>This is the second BETA release from the 4.3.x release branch. This release addresses performance issues in the
+non-blocking connection pool implementation and also includes a number of performance improvements in the low level NIO
+based transport components.</p></section><section>
<h6><a name="a24_April_2013_-_HttpComponents_HttpClient_4.2.5_.28GA.29_released"></a>24 April 2013 - HttpComponents HttpClient 4.2.5 (GA) released</h6>
-<p>This is a maintenance release that addresses a number of issues reported since release 4.2.4 including a major bug that can lead to re-use of persistent connections in a inconsistent state.</p></section><section>
+<p>This is a maintenance release that addresses a number of issues reported since release 4.2.4 including a major bug that
+can lead to re-use of persistent connections in a inconsistent state.</p></section><section>
<h6><a name="a11_April_2013_-_HttpComponents_HttpClient_4.3-beta1_released"></a>11 April 2013 - HttpComponents HttpClient 4.3-beta1 released</h6>
-<p>This is the first BETA release of HttpClient 4.3. The 4.3 branch enhances HttpClient in several key areas and includes several notable features and improvements: Support for Java 7 try-with-resources for resource management (connection release); fluent Builder classes for HttpEntity, HttpRequest and HttpClient instances, deprecation of preference and configuration API based on HttpParams interface in favor of constructor injection and plain configuration objects, reliance on object immutability instead of access synchronization for thread safety.</p>
+<p>This is the first BETA release of HttpClient 4.3. The 4.3 branch enhances HttpClient in several key areas and includes
+several notable features and improvements: Support for Java 7 try-with-resources for resource management (connection
+release); fluent Builder classes for HttpEntity, HttpRequest and HttpClient instances, deprecation of preference and
+configuration API based on HttpParams interface in favor of constructor injection and plain configuration objects,
+reliance on object immutability instead of access synchronization for thread safety.</p>
<p>This release also includes all fixes from the stable 4.2.x release branch.</p></section><section>
<h6><a name="a11_April_2013_-_HttpComponents_HttpClient_4.2.4_.28GA.29_released"></a>11 April 2013 - HttpComponents HttpClient 4.2.4 (GA) released</h6>
<p>This is a bug fix release that addresses a number of issues reported since release 4.2.3.</p></section><section>
<h6><a name="a25_March_2013_-_HttpComponents_HttpCore_4.3-beta1_released"></a>25 March 2013 - HttpComponents HttpCore 4.3-beta1 released</h6>
-<p>This is the first BETA release from the 4.3 release branch. The main theme of the 4.3 release series is streamlining of component configuration and deprecation of the old configuration API based on HttpParams in favor of constructor-based dependency injection and plain objects for configuration parameters.</p>
-<p>This release also includes performance optimizations intended to reduce TCP packet fragmentation when writing out HTTP messages both in blocking and non-blocking I/O modes, which should result in up to 20% higher throughput for short entity enclosing messages.</p></section><section>
+<p>This is the first BETA release from the 4.3 release branch. The main theme of the 4.3 release series is streamlining of
+component configuration and deprecation of the old configuration API based on HttpParams in favor of constructor-based
+dependency injection and plain objects for configuration parameters.</p>
+<p>This release also includes performance optimizations intended to reduce TCP packet fragmentation when writing out HTTP
+messages both in blocking and non-blocking I/O modes, which should result in up to 20% higher throughput for short
+entity enclosing messages.</p></section><section>
<h6><a name="a25_March_2013_-_HttpComponents_HttpCore_4.2.4_released"></a>25 March 2013 - HttpComponents HttpCore 4.2.4 released</h6>
-<p>This is a maintenance release that fixes a number of bugs found in NIO components since 4.2.3. We advise users of HttpCore NIO of all versions to upgrade.</p></section><section>
+<p>This is a maintenance release that fixes a number of bugs found in NIO components since 4.2.3. We advise users of
+HttpCore NIO of all versions to upgrade.</p></section><section>
<h6><a name="a21_January_2013_-_HttpComponents_HttpClient_4.3-alpha1_released"></a>21 January 2013 - HttpComponents HttpClient 4.3-alpha1 released</h6>
-<p>This is the first ALPHA release of HttpClient 4.3. The 4.3 branch enhances HttpClient in several key areas and includes several notable features and improvements: Support for Java 7 try-with-resources for resource management ( connection release); fluent Builder classes for HttpEntity, HttpRequest and HttpClient instances, deprecation of preference and configuration API based on HttpParams interface in favor of constructor injection and plain configuration objects, reliance on object immutability instead of access synchronization for thread safety.</p></section><section>
+<p>This is the first ALPHA release of HttpClient 4.3. The 4.3 branch enhances HttpClient in several key areas and includes
+several notable features and improvements: Support for Java 7 try-with-resources for resource management (
+connection release); fluent Builder classes for HttpEntity, HttpRequest and HttpClient instances, deprecation of
+preference and configuration API based on HttpParams interface in favor of constructor injection and plain configuration
+objects, reliance on object immutability instead of access synchronization for thread safety.</p></section><section>
<h6><a name="a15_January_2013_-_HttpComponents_HttpClient_4.2.3_.28GA.29_released"></a>15 January 2013 - HttpComponents HttpClient 4.2.3 (GA) released</h6>
-<p>This is a bug fix release that addresses a number of issues reported since release 4.2.2. This release also includes a thoroughly reworked NTLM authentication engine which should result in a better compatibility with the newest Microsoft products.</p></section><section>
+<p>This is a bug fix release that addresses a number of issues reported since release 4.2.2. This release also includes a
+thoroughly reworked NTLM authentication engine which should result in a better compatibility with the newest Microsoft
+products.</p></section><section>
<h6><a name="a08_Dec_2012_-_Welcome_new_HttpComponents_committer_Karl_Wright"></a>08 Dec 2012 - Welcome new HttpComponents committer Karl Wright</h6>
-<p>Karl Wright has been unanimously voted in as a new HttpComponents committer due to his invaluable help in supporting the internal NTLM engine and NTLM related authentication code.<br />
+<p>Karl Wright has been unanimously voted in as a new HttpComponents committer due to his invaluable help in supporting the
+internal NTLM engine and NTLM related authentication code.<br />
Karl is a committer on a number of ASF projects: Lucene, Lucene connectors, Incubator.</p>
<p>Welcome on board, Karl!</p></section><section>
<h6><a name="a30_November_2012_-_HttpComponents_HttpCore_4.3-alpha1_released"></a>30 November 2012 - HttpComponents HttpCore 4.3-alpha1 released</h6>
[... 377 lines stripped ...]