You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@mesos.apache.org by "haosdent (JIRA)" <ji...@apache.org> on 2015/04/01 08:02:55 UTC

[jira] [Commented] (MESOS-2576) Camel-case libprocess variable and method names

    [ https://issues.apache.org/jira/browse/MESOS-2576?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14390038#comment-14390038 ] 

haosdent commented on MESOS-2576:
---------------------------------

But libprocess is a third part library. Is it meaningful to change it here?

> Camel-case libprocess variable and method names
> -----------------------------------------------
>
>                 Key: MESOS-2576
>                 URL: https://issues.apache.org/jira/browse/MESOS-2576
>             Project: Mesos
>          Issue Type: Improvement
>          Components: technical debt
>            Reporter: Niklas Quarfot Nielsen
>            Priority: Trivial
>
> We should make naming consistent in libprocess and have it follow our style guide.
> For example:
> {code}
> void send_connect(
>     const Future<Nothing>& future,
>     Socket* socket,
>     Message* message)
> {
>   if (future.isDiscarded() || future.isFailed()) {
>     if (future.isFailed()) {
>       VLOG(1) << "Failed to send '" << message->name << "' to '"
>               << message->to.address << "', connect: " << future.failure();
>     }
>     socket_manager->close(*socket);
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)