You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@ofbiz.apache.org by "Divesh Dutta (JIRA)" <ji...@apache.org> on 2016/11/05 11:28:58 UTC

[jira] [Commented] (OFBIZ-8471) Remove uneccessary call of isNotEmpty() to validate not null generic value

    [ https://issues.apache.org/jira/browse/OFBIZ-8471?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15639381#comment-15639381 ] 

Divesh Dutta commented on OFBIZ-8471:
-------------------------------------

Patch is committed in revision 1768192 in trunk. 

> Remove uneccessary call of isNotEmpty() to validate not null generic value
> --------------------------------------------------------------------------
>
>                 Key: OFBIZ-8471
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-8471
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: ALL COMPONENTS
>    Affects Versions: Upcoming Branch
>            Reporter: Ratnesh Upadhyay
>            Assignee: Divesh Dutta
>         Attachments: OFBIZ-8471.patch
>
>
> There are lots of places in code where we have used UtilValidate.isNotEmpty() to validate GenericValue object. GenericValue will always be null or not null, they will never empty. So instead of using utility method to validate them we should be using native checks onwards.
> Example:
> Currently we are validating generic value in following ways 
> {code}
> if (UtilValidate.isNotEmpty(acctgTransEntry)) {
> {code}
> instead we will using it in this way: 
> {code}
> if (acctgTransEntry != null ) { 
> {code}
> Basically these validation methods should preferably be used on Strings or Lists and normal Maps.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)