You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@maven.apache.org by James Strachan <ja...@yahoo.co.uk> on 2002/12/19 12:19:33 UTC

adding core Jelly tags to the maven namespace.

Just a thought. Way back when Jelly was starting to be used in Maven, we
kept the default namespace for Ant tags and a few Maven/Werkz tags like
<goal>, <preGoal> etc.

All the core tags from Jelly like <if>, <set>, <forEach>, <while> <choose>.
<when>, <otherwise> and so forth, we've kept in a seperate XML namespace to
avoid collisions.

If someone has an Ant task out there somewhere that clashes with one of the
above tags, you can still use <taskdef> to rename it to something else to
avoid the clash. So I'm wondering how folks would feel if we added a bunch
of core tags (like those above) to the maven namespace. I'm just thinking
this would make the maven.xml and plugin.xml documents look a bit simpler &
easier to read.

Then for most docs there's no reason to add namespaces, we could just do...

<project>
    <goal name="foo">
        <if test="${a != 'xyz'}>
            <forEach var="foo" items="${pom.whatever}">
                ...

etc.

Thoughts?

James
-------
http://radio.weblogs.com/0112098/

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com

Re: adding core Jelly tags to the maven namespace.

Posted by di...@multitask.com.au.
That sounds like a useful thing to me.

As long as the existing way of explicitly specifying the namespaces will 
still work, I'm +1 on adding core to the maven 'default' namespace.
--
dIon Gillard, Multitask Consulting
Blog:      http://www.freeroller.net/page/dion/Weblog
Work:      http://www.multitask.com.au


"James Strachan" <ja...@yahoo.co.uk> wrote on 19/12/2002 10:19:33 
PM:

> Just a thought. Way back when Jelly was starting to be used in Maven, we
> kept the default namespace for Ant tags and a few Maven/Werkz tags like
> <goal>, <preGoal> etc.
> 
> All the core tags from Jelly like <if>, <set>, <forEach>, <while> 
<choose>.
> <when>, <otherwise> and so forth, we've kept in a seperate XML namespace 
to
> avoid collisions.
> 
> If someone has an Ant task out there somewhere that clashes with one of 
the
> above tags, you can still use <taskdef> to rename it to something else 
to
> avoid the clash. So I'm wondering how folks would feel if we added a 
bunch
> of core tags (like those above) to the maven namespace. I'm just 
thinking
> this would make the maven.xml and plugin.xml documents look a bit 
simpler &
> easier to read.
> 
> Then for most docs there's no reason to add namespaces, we could just 
do...
> 
> <project>
>     <goal name="foo">
>         <if test="${a != 'xyz'}>
>             <forEach var="foo" items="${pom.whatever}">
>                 ...
> 
> etc.
> 
> Thoughts?
> 
> James
> -------
> http://radio.weblogs.com/0112098/
> 
> __________________________________________________
> Do You Yahoo!?
> Everything you'll ever need on one web page
> from News and Sport to Email and Music Charts
> http://uk.my.yahoo.com
> 
> --
> To unsubscribe, e-mail:   <mailto:turbine-maven-dev-
> unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:turbine-maven-dev-
> help@jakarta.apache.org>
> 

> ForwardSourceID:NT0009B646