You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@nifi.apache.org by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2024/11/05 03:41:00 UTC

[jira] [Commented] (NIFI-13965) Reduce duplicate code in TestConvertRecord and make use of Java 21 features

    [ https://issues.apache.org/jira/browse/NIFI-13965?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17895492#comment-17895492 ] 

ASF subversion and git services commented on NIFI-13965:
--------------------------------------------------------

Commit b8c4cb081a0b85e2117b6a73a347a93f8c2b3769 in nifi's branch refs/heads/main from dan-s1
[ https://gitbox.apache.org/repos/asf?p=nifi.git;h=b8c4cb081a ]

NIFI-13965 Reduced duplicate code and optimized TestConvertRecord (#9488)

Signed-off-by: David Handermann <ex...@apache.org>

> Reduce duplicate code in TestConvertRecord and make use of Java 21 features
> ---------------------------------------------------------------------------
>
>                 Key: NIFI-13965
>                 URL: https://issues.apache.org/jira/browse/NIFI-13965
>             Project: Apache NiFi
>          Issue Type: Improvement
>            Reporter: Daniel Stieglitz
>            Assignee: Daniel Stieglitz
>            Priority: Minor
>          Time Spent: 20m
>  Remaining Estimate: 0h
>
> Intellij is indicating the loading of the same json and schemas are loaded multiple times. These should be done once. Also other Java 21 features Intellij suggested should be made (e.g use of getFirst instead of get(0), text block instead of concatenation etc).



--
This message was sent by Atlassian Jira
(v8.20.10#820010)