You are viewing a plain text version of this content. The canonical link for it is here.
Posted to announce@apache.org by Eric Covener <co...@apache.org> on 2026/06/08 12:50:26 UTC
CVE-2026-34356: Apache HTTP Server: ProxyPassReverseCookieMap buffer overflow
Severity: low
Affected versions:
- Apache HTTP Server 2.4.0 through 2.4.67
Description:
Heap-based Buffer Overflow vulnerability in Apache HTTP Server with malicious backend servers and ProxyPassReverseCookie*
This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.
Users are recommended to upgrade to version 2.4.68, which fixes the issue.
Credit:
Arkadi Vainbrand (finder)
depthfirst (depthfirst.com) (finder)
References:
https://httpd.apache.org/security/vulnerabilities_24.html
https://httpd.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-34356
Timeline:
2026-02-23: reported
2026-06-05: fixed in 2.4.x by r1935008
2026-06-08: 2.4.68 released