You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@ofbiz.apache.org by "Taher Alkhateeb (JIRA)" <ji...@apache.org> on 2017/01/11 10:50:58 UTC

[jira] [Commented] (OFBIZ-7972) Create a (PoC) plugin system for OFBiz based on Gradle

    [ https://issues.apache.org/jira/browse/OFBIZ-7972?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15817967#comment-15817967 ] 

Taher Alkhateeb commented on OFBIZ-7972:
----------------------------------------

In reference to the discussion thread in which we voted to rename /specialpurpose to /plugins found [here|http://markmail.org/message/hpyuxkmftiyn44w2] I have committed the change in r1778271

> Create a (PoC) plugin system for OFBiz based on Gradle
> ------------------------------------------------------
>
>                 Key: OFBIZ-7972
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-7972
>             Project: OFBiz
>          Issue Type: Improvement
>    Affects Versions: 16.11.01
>            Reporter: Taher Alkhateeb
>            Assignee: Taher Alkhateeb
>            Priority: Minor
>              Labels: plugin, proof-of-concept, system
>         Attachments: OFBIZ-7972.patch, OFBIZ-7972.patch, OFBIZ-7972.patch
>
>
> This JIRA houses the attempt to create a plugin system for OFBiz based on gradle. The plugin system should have the following features:
> - It is independent of the version control system, file system, operating system and any other environment tools surrounding OFBiz. Instead, it should be fully integrated with OFBiz.
> - It should unify the way OFBiz is extended, both for official supported plugins and for third party plugins
> - The plugin system takes advantage of the concept of a "component" in OFBiz and utilize it as the building block for plugins
> - The plugin system supports the concepts of "Repository" and "Dependency Management". If possible, the plugin system will utilize these concepts directly from Gradle instead of writing them from scratch.
> The initial API for the plugin system will be small and expands as needed. The API should include the following gradle tasks:
> - createPlugin: creates a new plugin based on templates and place it in the plugins directory
> - installPlugin: Activate a plugin and run Install. Plugin must exist in /specialpurpose
> - uninstallPlugin: Deactivate a plugin and run its uninstall script
> - publishPlugin: publish a plugin to local maven repository
> - pullPlugin: download a plugin with its dependencies (plugins) from a repository and install them



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)