You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@myfaces.apache.org by Matthias Wessendorf <ma...@apache.org> on 2008/08/09 13:35:43 UTC

[myfaces12] Compilation failure

Hi,

when trying to build myfaces 12, I get this:
[ERROR] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Compilation failure

D:\work\_MyFaces_12x\core\api\src\main\java\javax\faces\component\UIColumn.java:[41,4]
annotation org.apache.myfaces.buildtools.maven2.plugin.builder.annotation.JSFFacet
is missing desc

D:\work\_MyFaces_12x\core\api\src\main\java\javax\faces\component\UIColumn.java:[52,4]
annotation org.apache.myfaces.buildtools.maven2.plugin.builder.annotation.JSFFacet
is missing desc

the continuum build is fine, though.

Another question that comes up, is should we rename "desc" to description ?

Thx,
Matthias


-- 
Matthias Wessendorf

Need JSF and Web 2.0?
http://code.google.com/p/facesgoodies

further stuff:
blog: http://matthiaswessendorf.wordpress.com/
sessions: http://www.slideshare.net/mwessendorf
mail: matzew-at-apache-dot-org

Re: [myfaces12] Compilation failure

Posted by Leonardo Uribe <lu...@gmail.com>.
On Sat, Aug 9, 2008 at 6:35 AM, Matthias Wessendorf <ma...@apache.org>wrote:

> Hi,
>
> when trying to build myfaces 12, I get this:
> [ERROR] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Compilation failure
>
>
> D:\work\_MyFaces_12x\core\api\src\main\java\javax\faces\component\UIColumn.java:[41,4]
> annotation
> org.apache.myfaces.buildtools.maven2.plugin.builder.annotation.JSFFacet
> is missing desc
>
>
> D:\work\_MyFaces_12x\core\api\src\main\java\javax\faces\component\UIColumn.java:[52,4]
> annotation
> org.apache.myfaces.buildtools.maven2.plugin.builder.annotation.JSFFacet
> is missing desc
>
> the continuum build is fine, though.
>

The solution is change myfaces-builder-annotations from 1.0.1-SNAPSHOT to
1.0.1 (I only update myfaces-builder-plugin version) (committed).


>
> Another question that comes up, is should we rename "desc" to description ?
>

The field desc is filled from the first line of the comments. For example:


    /**
     * This text goes on desc property.
     *
     */
    @JSFFacet
     public UIComponent getFirst(){
           /*............*/
     }

So the user never see it.


> Thx,
> Matthias
>
>
> --
> Matthias Wessendorf
>
> Need JSF and Web 2.0?
> http://code.google.com/p/facesgoodies
>
> further stuff:
> blog: http://matthiaswessendorf.wordpress.com/
> sessions: http://www.slideshare.net/mwessendorf
> mail: matzew-at-apache-dot-org
>