You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Karthik Kambatla (JIRA)" <ji...@apache.org> on 2014/04/06 02:12:15 UTC

[jira] [Commented] (YARN-1757) Auxiliary service support for nodemanager recovery

    [ https://issues.apache.org/jira/browse/YARN-1757?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13961288#comment-13961288 ] 

Karthik Kambatla commented on YARN-1757:
----------------------------------------

Thanks Jason. Looks mostly good - minor comments and nits. Feel free to ignore nits you don't agree with. 

Comments:
# Nit: YarnConfiguration: We might want to add a NM_RECOVERY_PREFIX for all recovery related configs?
# The default recovery-dir should probably be something more specific to nm-recovery - {{/tmp/yarn-nm-recovery}}? 
# Nit: Should we add an NMUtils class for static helper methods like isRecoveryEnabled()?
# Nit: Rename variables to stateStore instead of stateStorage - that would go with the conventions used in RM better, and is shorter :)
{code}
    Path stateStorageRoot = null;
    FileSystem stateStorageFs = null;
{code}
# Nit: AuxServices#createStorageDir: May be add a comment to say control flow through FileNotFound is cheaper than explicitly checking if the file exists?
# NameNode should also use something similar, instead of directly creating the directory? May be, another candidate to move to NMUtils? 
# TestAuxServices: We should check if we have two directories created too?
{code}
      final AuxServices aux = new AuxServices();
      aux.init(conf);
      Assert.assertEquals(2, aux.getServices().size());
      aux.close();
{code}

> Auxiliary service support for nodemanager recovery
> --------------------------------------------------
>
>                 Key: YARN-1757
>                 URL: https://issues.apache.org/jira/browse/YARN-1757
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager
>    Affects Versions: 2.3.0
>            Reporter: Jason Lowe
>            Assignee: Jason Lowe
>         Attachments: YARN-1757.patch, YARN-1757.patch
>
>
> There needs to be a mechanism for communicating to auxiliary services whether nodemanager recovery is enabled and where they should store their state.



--
This message was sent by Atlassian JIRA
(v6.2#6252)