You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by ol...@apache.org on 2020/02/10 08:19:48 UTC

[httpcomponents-core] 01/01: Updated release notes for HttpCore 5.0 GA release

This is an automated email from the ASF dual-hosted git repository.

olegk pushed a commit to branch release-preparation
in repository https://gitbox.apache.org/repos/asf/httpcomponents-core.git

commit 9ac354c30e66a3af2bd92b8fde2b2f668f3cede1
Author: Oleg Kalnichevski <ol...@apache.org>
AuthorDate: Mon Feb 10 09:14:18 2020 +0100

    Updated release notes for HttpCore 5.0 GA release
---
 RELEASE_NOTES.txt | 56 +++++++++++++++++++++++++++++++++++++++++++++++++------
 1 file changed, 50 insertions(+), 6 deletions(-)

diff --git a/RELEASE_NOTES.txt b/RELEASE_NOTES.txt
index 9468b19..b169c5f 100644
--- a/RELEASE_NOTES.txt
+++ b/RELEASE_NOTES.txt
@@ -1,12 +1,56 @@
-Release 5.0-BETA12
+Release 5.0
 ------------------
 
-This BETA improves handling of illegal or invalid requests on the server side and fixes a number
-of defects in HTTP/2 protocol code found since the last release.
+This is the first stable (GA) release of HttpCore 5.0.
 
-IMPORTANT: This release is expected to be the last BETA version. If no major
-design flaws are found, the actual 5.0 API will be frozen and the next version will be
-promoted to GA.
+Notable changes and features included in the 5.0 series:
+
+* Support for HTTP/2 protocol and conformance to requirements and recommendations
+  of the latest HTTP/2 protocol specification (RFC 7540, RFC 7541)
+
+  Supported features:
+
+    ** HPACK header compression
+    ** stream multiplexing (client and server)
+    ** flow control
+    ** response push (client and server)
+    ** message trailers
+    ** expect-continue handshake
+    ** connection validation (ping)
+    ** application-layer protocol negotiation (ALPN) on Java 9+
+    ** TLS 1.2 security features
+
+   Features out of scope for 5.0 release:
+
+    ** padding of outgoing frames
+    ** stream priority
+    ** plain connection HTTP/1.1 upgrade
+    ** CONNECT method
+
+* Improved conformance to requirements and recommendations of the latest HTTP/1.1 protocol
+  specification (RFC 7230, RFC 7231)
+
+* New asynchronous HTTP transport APIs consistent for both HTTP/1.1 and HTTP/2 transport.
+
+* Redesigned I/O reactor APIs and improved NIO based reactor implementation for a greater
+  performance and scalability.
+
+* Support for server side request filters for classic and asynchronous server implementations.
+  Request filters could be used to implement cross-cutting protocol aspects such
+  as the 'expect-continue' handshaking and user authentication / authorization.
+
+* Redesigned connection pool implementation with strict connection limit guarantees.
+  The connection pool is expected to have a better performance under higher concurrency
+  due to reduced global pool lock contention.
+
+* New connection pool implementation with lax connection limit guarantees and better
+  performance under higher concurrency due to absence of a global pool lock.
+
+* Package name space changed to 'org.apache.hc.core5'
+
+* Maven group id changed to 'org.apache.httpcomponents.core5'
+
+HttpCore 5.0 releases can be co-located with earlier versions.
 
 
 Change Log