You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Jerry Chen (JIRA)" <ji...@apache.org> on 2016/04/28 07:20:12 UTC

[jira] [Comment Edited] (CRYPTO-33) SecureRandom shadows JVM class

    [ https://issues.apache.org/jira/browse/CRYPTO-33?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15261557#comment-15261557 ] 

Jerry Chen edited comment on CRYPTO-33 at 4/28/16 5:20 AM:
-----------------------------------------------------------

Thanks Sebb for suggesting. We will use the following naming convention to avoid shadowing java classes.

Cipher -> CryptoCipher
SecureRandom -> CryptoRandom
CipherInputStream -> CryptoInputStream
CipherOutputStream -> CryptoOutputStream
CTRCipherInputStream -> CTRCryptoInputStream 
CTRCipherOutputStream -> CTRCryptoOutputStream 
...



was (Author: jerrychenhf):
We will use the following naming convention to avoid shadowing java classes.

Cipher -> CryptoCipher
SecureRandom -> CryptoRandom
CipherInputStream -> CryptoInputStream
CipherOutputStream -> CryptoOutputStream
CTRCipherInputStream -> CTRCryptoInputStream 
CTRCipherOutputStream -> CTRCryptoOutputStream 
...


> SecureRandom shadows JVM class
> ------------------------------
>
>                 Key: CRYPTO-33
>                 URL: https://issues.apache.org/jira/browse/CRYPTO-33
>             Project: Commons Crypto
>          Issue Type: Bug
>            Reporter: Sebb
>
> The SecureRandom interface also exists  as a class in java.security.
> This makes it awkward to use, for example in JavaSecureRandom the fully qualified name has to be used for the java class.
> Ideally it should be renamed.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)