You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Jakob Homan (JIRA)" <ji...@apache.org> on 2010/09/21 23:11:35 UTC
[jira] Commented: (HDFS-1394) modify -format option for namenode to
generated new blockpool id and accept newcluster
[ https://issues.apache.org/jira/browse/HDFS-1394?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12913253#action_12913253 ]
Jakob Homan commented on HDFS-1394:
-----------------------------------
Review (line numbers from patch):
* Before Line 138: Is there anything that needs to be done for simulated storage?
* DataStorage.java's only change is whitespace. This can be removed.
* Nit: FsImage:guessClusterId seems like an odd name. determineClusterId?
* Reading through guessClusterId I was initially confused as to if it were ok to return a null to indicate failure. Javadoc on the method would help.
* Line 279: {{if(!(System.in.read() == 'Y'))}} could be simplified to {{if(System.in.read != 'Y')}}
* In the tests there are quite a few calls to {{NameNode.clusterIdStr = "TestClusterId";}} these should be refactored into a static method on {{GenericTestUtils.java}}.
* There are currently no tests that go over the {{-genclusterid}} paths. This could be tested in {{TestHDFSCLI}}
* This changes user-interaction with the Namenode, so the forrest docs need to be updated as well.
> modify -format option for namenode to generated new blockpool id and accept newcluster
> --------------------------------------------------------------------------------------
>
> Key: HDFS-1394
> URL: https://issues.apache.org/jira/browse/HDFS-1394
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Affects Versions: Federation Branch
> Reporter: Boris Shkolnik
> Assignee: Boris Shkolnik
> Attachments: HDFS-1394-5.patch, HDFS-1394-6.patch, HDFS-1394-7.patch, HDFS-1394-7.patch
>
>
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.