You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mesos.apache.org by Patrick Reilly <pa...@gmail.com> on 2014/08/29 19:21:06 UTC

Review Request 25193: Switch [mesos] to using compiler intrinsics for unreachable, exit, and abort

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/25193/
-----------------------------------------------------------

Review request for mesos and Benjamin Hindman.


Bugs: MESOS-1744
    https://issues.apache.org/jira/browse/MESOS-1744


Repository: mesos-git


Description
-------

Use compiler intrinsics for unreachable, exit, and abort
Makes the functions not need to pretend to return something while
still silencing the compiler warnings.


Diffs
-----

  src/log/leveldb.cpp 2967a1f 
  src/log/network.hpp fc85a57 
  src/slave/containerizer/mesos/launch.cpp 9819381 
  src/tests/routing_tests.cpp 10730ad 
  src/zookeeper/zookeeper.cpp 72c9fc3 

Diff: https://reviews.apache.org/r/25193/diff/


Testing
-------

This is currently a work in progress, (WIP)


Thanks,

Patrick Reilly


Re: Review Request 25193: Switch [mesos] to using compiler intrinsics for unreachable, exit, and abort

Posted by Mesos ReviewBot <de...@mesos.apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/25193/#review51942
-----------------------------------------------------------


Bad patch!

Reviews applied: [25192, 25191, 25193]

Failed command: ./support/mesos-style.py

Error:
 Checking 504 files using filter --filter=-,+build/class,+build/deprecated,+build/endif_comment,+readability/todo,+readability/namespace,+runtime/vlog,+whitespace/blank_line,+whitespace/comma,+whitespace/ending_newline,+whitespace/forcolon,+whitespace/indent,+whitespace/line_length,+whitespace/tab,+whitespace/todo
3rdparty/libprocess/3rdparty/stout/include/stout/abort.hpp:37:  Redundant blank line at the start of a code block should be deleted.  [whitespace/blank_line] [2]
Total errors found: 1

- Mesos ReviewBot


On Aug. 29, 2014, 5:54 p.m., Patrick Reilly wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/25193/
> -----------------------------------------------------------
> 
> (Updated Aug. 29, 2014, 5:54 p.m.)
> 
> 
> Review request for mesos, Benjamin Hindman and Dominic Hamon.
> 
> 
> Bugs: MESOS-1744
>     https://issues.apache.org/jira/browse/MESOS-1744
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> Use compiler intrinsics for unreachable, exit, and abort
> Makes the functions not need to pretend to return something while
> still silencing the compiler warnings.
> 
> 
> Diffs
> -----
> 
>   src/log/leveldb.cpp 2967a1f 
>   src/log/network.hpp fc85a57 
>   src/slave/containerizer/mesos/launch.cpp 9819381 
>   src/tests/routing_tests.cpp 10730ad 
>   src/zookeeper/zookeeper.cpp 72c9fc3 
> 
> Diff: https://reviews.apache.org/r/25193/diff/
> 
> 
> Testing
> -------
> 
> Make check runs.
> 
> 
> Thanks,
> 
> Patrick Reilly
> 
>


Re: Review Request 25193: Switch [mesos] to using compiler intrinsics for unreachable, exit, and abort

Posted by Dominic Hamon <dh...@twopensource.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/25193/#review52508
-----------------------------------------------------------

Ship it!


Ship It!

- Dominic Hamon


On Aug. 29, 2014, 10:54 a.m., Patrick Reilly wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/25193/
> -----------------------------------------------------------
> 
> (Updated Aug. 29, 2014, 10:54 a.m.)
> 
> 
> Review request for mesos, Benjamin Hindman and Dominic Hamon.
> 
> 
> Bugs: MESOS-1744
>     https://issues.apache.org/jira/browse/MESOS-1744
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> Use compiler intrinsics for unreachable, exit, and abort
> Makes the functions not need to pretend to return something while
> still silencing the compiler warnings.
> 
> 
> Diffs
> -----
> 
>   src/log/leveldb.cpp 2967a1f 
>   src/log/network.hpp fc85a57 
>   src/slave/containerizer/mesos/launch.cpp 9819381 
>   src/tests/routing_tests.cpp 10730ad 
>   src/zookeeper/zookeeper.cpp 72c9fc3 
> 
> Diff: https://reviews.apache.org/r/25193/diff/
> 
> 
> Testing
> -------
> 
> Make check runs.
> 
> 
> Thanks,
> 
> Patrick Reilly
> 
>


Re: Review Request 25193: Switch [mesos] to using compiler intrinsics for unreachable, exit, and abort

Posted by Patrick Reilly <pa...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/25193/
-----------------------------------------------------------

(Updated Aug. 29, 2014, 5:54 p.m.)


Review request for mesos, Benjamin Hindman and Dominic Hamon.


Changes
-------

Adding Dominic Hamon as reviewer.


Bugs: MESOS-1744
    https://issues.apache.org/jira/browse/MESOS-1744


Repository: mesos-git


Description
-------

Use compiler intrinsics for unreachable, exit, and abort
Makes the functions not need to pretend to return something while
still silencing the compiler warnings.


Diffs
-----

  src/log/leveldb.cpp 2967a1f 
  src/log/network.hpp fc85a57 
  src/slave/containerizer/mesos/launch.cpp 9819381 
  src/tests/routing_tests.cpp 10730ad 
  src/zookeeper/zookeeper.cpp 72c9fc3 

Diff: https://reviews.apache.org/r/25193/diff/


Testing
-------

Make check runs.


Thanks,

Patrick Reilly


Re: Review Request 25193: Switch [mesos] to using compiler intrinsics for unreachable, exit, and abort

Posted by Patrick Reilly <pa...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/25193/
-----------------------------------------------------------

(Updated Aug. 29, 2014, 5:52 p.m.)


Review request for mesos and Benjamin Hindman.


Changes
-------

Make check runs.


Bugs: MESOS-1744
    https://issues.apache.org/jira/browse/MESOS-1744


Repository: mesos-git


Description
-------

Use compiler intrinsics for unreachable, exit, and abort
Makes the functions not need to pretend to return something while
still silencing the compiler warnings.


Diffs
-----

  src/log/leveldb.cpp 2967a1f 
  src/log/network.hpp fc85a57 
  src/slave/containerizer/mesos/launch.cpp 9819381 
  src/tests/routing_tests.cpp 10730ad 
  src/zookeeper/zookeeper.cpp 72c9fc3 

Diff: https://reviews.apache.org/r/25193/diff/


Testing (updated)
-------

Make check runs.


Thanks,

Patrick Reilly


Re: Review Request 25193: Switch [mesos] to using compiler intrinsics for unreachable, exit, and abort

Posted by Patrick Reilly <pa...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/25193/
-----------------------------------------------------------

(Updated Aug. 29, 2014, 5:23 p.m.)


Review request for mesos and Benjamin Hindman.


Changes
-------

Split along stout, libprocess, and mesos boundaries


Bugs: MESOS-1744
    https://issues.apache.org/jira/browse/MESOS-1744


Repository: mesos-git


Description
-------

Use compiler intrinsics for unreachable, exit, and abort
Makes the functions not need to pretend to return something while
still silencing the compiler warnings.


Diffs
-----

  src/log/leveldb.cpp 2967a1f 
  src/log/network.hpp fc85a57 
  src/slave/containerizer/mesos/launch.cpp 9819381 
  src/tests/routing_tests.cpp 10730ad 
  src/zookeeper/zookeeper.cpp 72c9fc3 

Diff: https://reviews.apache.org/r/25193/diff/


Testing
-------

This is currently a work in progress, (WIP)


Thanks,

Patrick Reilly