You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Jark Wu (Jira)" <ji...@apache.org> on 2020/09/25 14:43:00 UTC
[jira] [Commented] (FLINK-19409) The comment for getValue has wrong
code in class ListView
[ https://issues.apache.org/jira/browse/FLINK-19409?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17202212#comment-17202212 ]
Jark Wu commented on FLINK-19409:
---------------------------------
+1
> The comment for getValue has wrong code in class ListView
> ---------------------------------------------------------
>
> Key: FLINK-19409
> URL: https://issues.apache.org/jira/browse/FLINK-19409
> Project: Flink
> Issue Type: Improvement
> Components: Documentation, Table SQL / API
> Reporter: Liu
> Priority: Minor
>
> The comment for getValue is as following currently:
> {code:java}
> * @Override
> * public Long getValue(MyAccumulator accumulator) {
> * accumulator.list.add(id);
> * ... ...
> * accumulator.list.get()
> * ... ...
> * return accumulator.count;
> * }
> {code}
> Users may be confused with the code "accumulator.list.add(id); ". It should be removed.
>
--
This message was sent by Atlassian Jira
(v8.3.4#803005)