You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "David Brinegar (JIRA)" <ji...@apache.org> on 2017/06/27 01:46:00 UTC
[jira] [Commented] (FLINK-6464) Metric name is not stable
[ https://issues.apache.org/jira/browse/FLINK-6464?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16064097#comment-16064097 ]
David Brinegar commented on FLINK-6464:
---------------------------------------
nice find! FLINK-7009 tries to address this by removing the instance ids, then using a hash of the remaining stable part of the string as a compressed metric name. So the above would convert into something like "TriggerWin_abcdef12" which is at least the same every time you run the job, and short so metric systems can handle it without truncation or conversion problems, but in the end only a shorter more stable default name, not particularly readable in itself. Thoughts?
> Metric name is not stable
> -------------------------
>
> Key: FLINK-6464
> URL: https://issues.apache.org/jira/browse/FLINK-6464
> Project: Flink
> Issue Type: Bug
> Components: DataStream API, Metrics
> Affects Versions: 1.2.0
> Reporter: Andrey
>
> Currently according to the documentation (https://ci.apache.org/projects/flink/flink-docs-release-1.2/monitoring/metrics.html) operator metrics constructed using the following pattern:
> <operator_name>, <subtask_index>
> For some operators, "operator_name" could contain default implementation of toString method. For example:
> {code}
> TriggerWindow(TumblingProcessingTimeWindows(3000), ListStateDescriptor{serializer=org.apache.flink.api.java.typeutils.runtime.kryo.KryoSerializer@c65792d4}, xxx.Trigger@665fe457, WindowedStream.apply(WindowedStream.java:521)) -> Sink: Unnamed
> {code}
> The part "@c65792d4" will be changed every time job is restarted/cancelled.
> As a consequence it's not possible to store metrics for a long time.
> Expected:
> * ensure all operators return human readable, non-default names OR
> * change the way TriggerWindow generates it's name.
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)