You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Eric Gilmore (JIRA)" <ji...@apache.org> on 2011/08/05 19:45:27 UTC

[jira] [Created] (CASSANDRA-2997) Enhance human-readability of snapshot names created by drop column family

Enhance human-readability of snapshot names created by drop column family
-------------------------------------------------------------------------

                 Key: CASSANDRA-2997
                 URL: https://issues.apache.org/jira/browse/CASSANDRA-2997
             Project: Cassandra
          Issue Type: Improvement
          Components: Tools
    Affects Versions: 0.8.2
            Reporter: Eric Gilmore
            Priority: Minor


Currently when you drop a column family, a snapshot is automatically created in a directory named with the timestamp of the drop.  

Clever folk will find a way to understand the timestamps and locate particular snapshots, but it is not as effortless as it could be if part or all of the CF name was included in the snapshot name.

Any strategy to make the snapshot name more user-friendly and easy to find would be helpful.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (CASSANDRA-2997) Enhance human-readability of snapshot names created by drop column family

Posted by "Yuki Morishita (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CASSANDRA-2997?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Yuki Morishita updated CASSANDRA-2997:
--------------------------------------

    Attachment: 0001-Add-CF-name-to-snapshot-dir-when-dropping.patch

Simple patch for 0.8 branch which creates snapshot with column family name (`timestamp`-`cf name`) when dropping column family.
                
> Enhance human-readability of snapshot names created by drop column family
> -------------------------------------------------------------------------
>
>                 Key: CASSANDRA-2997
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-2997
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>    Affects Versions: 0.8.2
>            Reporter: Eric Gilmore
>            Assignee: Yuki Morishita
>            Priority: Minor
>         Attachments: 0001-Add-CF-name-to-snapshot-dir-when-dropping.patch
>
>
> Currently when you drop a column family, a snapshot is automatically created in a directory named with the timestamp of the drop.  
> Clever folk will find a way to understand the timestamps and locate particular snapshots, but it is not as effortless as it could be if part or all of the CF name was included in the snapshot name.
> Any strategy to make the snapshot name more user-friendly and easy to find would be helpful.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Assigned] (CASSANDRA-2997) Enhance human-readability of snapshot names created by drop column family

Posted by "Jonathan Ellis (Assigned) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CASSANDRA-2997?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jonathan Ellis reassigned CASSANDRA-2997:
-----------------------------------------

    Assignee: Yuki Morishita

Eric's suggestion to include the CF name in single-CF snapshots is a good one.
                
> Enhance human-readability of snapshot names created by drop column family
> -------------------------------------------------------------------------
>
>                 Key: CASSANDRA-2997
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-2997
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>    Affects Versions: 0.8.2
>            Reporter: Eric Gilmore
>            Assignee: Yuki Morishita
>            Priority: Minor
>
> Currently when you drop a column family, a snapshot is automatically created in a directory named with the timestamp of the drop.  
> Clever folk will find a way to understand the timestamps and locate particular snapshots, but it is not as effortless as it could be if part or all of the CF name was included in the snapshot name.
> Any strategy to make the snapshot name more user-friendly and easy to find would be helpful.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (CASSANDRA-2997) Enhance human-readability of snapshot names created by drop column family

Posted by "Jonathan Ellis (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CASSANDRA-2997?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jonathan Ellis updated CASSANDRA-2997:
--------------------------------------

             Reviewer: jbellis
    Affects Version/s:     (was: 0.8.2)
                       0.7.0
        Fix Version/s: 1.0.1

(v2 is against 1.0 branch)
                
> Enhance human-readability of snapshot names created by drop column family
> -------------------------------------------------------------------------
>
>                 Key: CASSANDRA-2997
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-2997
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>    Affects Versions: 0.7.0
>            Reporter: Eric Gilmore
>            Assignee: Yuki Morishita
>            Priority: Minor
>             Fix For: 1.0.1
>
>         Attachments: 0001-Add-CF-name-to-snapshot-dir-when-dropping.patch, 2997-v2.txt
>
>
> Currently when you drop a column family, a snapshot is automatically created in a directory named with the timestamp of the drop.  
> Clever folk will find a way to understand the timestamps and locate particular snapshots, but it is not as effortless as it could be if part or all of the CF name was included in the snapshot name.
> Any strategy to make the snapshot name more user-friendly and easy to find would be helpful.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (CASSANDRA-2997) Enhance human-readability of snapshot names created by drop column family

Posted by "Jonathan Ellis (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CASSANDRA-2997?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jonathan Ellis updated CASSANDRA-2997:
--------------------------------------

    Attachment: 2997-v2.txt

v2 also adds names to CF truncate and KS drop snapshots.
                
> Enhance human-readability of snapshot names created by drop column family
> -------------------------------------------------------------------------
>
>                 Key: CASSANDRA-2997
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-2997
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>    Affects Versions: 0.7.0
>            Reporter: Eric Gilmore
>            Assignee: Yuki Morishita
>            Priority: Minor
>             Fix For: 1.0.1
>
>         Attachments: 0001-Add-CF-name-to-snapshot-dir-when-dropping.patch, 2997-v2.txt
>
>
> Currently when you drop a column family, a snapshot is automatically created in a directory named with the timestamp of the drop.  
> Clever folk will find a way to understand the timestamps and locate particular snapshots, but it is not as effortless as it could be if part or all of the CF name was included in the snapshot name.
> Any strategy to make the snapshot name more user-friendly and easy to find would be helpful.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CASSANDRA-2997) Enhance human-readability of snapshot names created by drop column family

Posted by "Yuki Morishita (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CASSANDRA-2997?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13133541#comment-13133541 ] 

Yuki Morishita commented on CASSANDRA-2997:
-------------------------------------------

+1 on v2
                
> Enhance human-readability of snapshot names created by drop column family
> -------------------------------------------------------------------------
>
>                 Key: CASSANDRA-2997
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-2997
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>    Affects Versions: 0.7.0
>            Reporter: Eric Gilmore
>            Assignee: Yuki Morishita
>            Priority: Minor
>             Fix For: 1.0.1
>
>         Attachments: 0001-Add-CF-name-to-snapshot-dir-when-dropping.patch, 2997-v2.txt
>
>
> Currently when you drop a column family, a snapshot is automatically created in a directory named with the timestamp of the drop.  
> Clever folk will find a way to understand the timestamps and locate particular snapshots, but it is not as effortless as it could be if part or all of the CF name was included in the snapshot name.
> Any strategy to make the snapshot name more user-friendly and easy to find would be helpful.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira