You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Yufei Gu (JIRA)" <ji...@apache.org> on 2019/04/01 01:48:00 UTC

[jira] [Commented] (YARN-9214) Add AbstractYarnScheduler#getValidQueues method to resolve duplicate code

    [ https://issues.apache.org/jira/browse/YARN-9214?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16806325#comment-16806325 ] 

Yufei Gu commented on YARN-9214:
--------------------------------

Thank [~jiwq] for working on this. 
{code}
      LOG.warn(errMsg);
      throw new YarnException(errMsg);
{code}
It doesn't make sense to LOG.warn since we've thrown a exception here. Suggest to remove it though it isn't introduced by your patch.

> Add AbstractYarnScheduler#getValidQueues method to resolve duplicate code 
> --------------------------------------------------------------------------
>
>                 Key: YARN-9214
>                 URL: https://issues.apache.org/jira/browse/YARN-9214
>             Project: Hadoop YARN
>          Issue Type: Improvement
>    Affects Versions: 3.1.0, 3.2.0, 2.9.2, 3.0.3, 2.8.5
>            Reporter: Wanqiang Ji
>            Assignee: Wanqiang Ji
>            Priority: Major
>             Fix For: 3.3.0
>
>         Attachments: YARN-9214.001.patch, YARN-9214.002.patch, YARN-9214.003.patch
>
>
> *AbstractYarnScheduler#moveAllApps* and *AbstractYarnScheduler#killAllAppsInQueue* had the same code segment. So I think we need a method to handle it named *AbstractYarnScheduler#getValidQueues*. Apart from this we need add the doc comment to expound why exists.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org