You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@cxf.apache.org by "Steven E. Harris (JIRA)" <ji...@apache.org> on 2007/05/02 21:48:15 UTC

[jira] Created: (CXF-627) WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations

WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations
-----------------------------------------------------------------------------------------

                 Key: CXF-627
                 URL: https://issues.apache.org/jira/browse/CXF-627
             Project: CXF
          Issue Type: Bug
          Components: Tooling
    Affects Versions: 2.0-RC
         Environment: NA
            Reporter: Steven E. Harris


Per the discussing on the cxf-user mailing list in the thread entitled

  JAX-WS enableAsyncMapping directive not respected
  http://www.nabble.com/Re%3A-JAX-WS-enableAsyncMapping-directive-not-respected-p10292965.html

the class org.apache.cxf.tools.wsdlto.frontend.jaxws.processor.internal.OperationProcessor uses a method called isAddedAsyMethod() to determine whether it has already defined an asynchronous method for a given operation name. Its detection heuristic fails for operation names that don't conform to the Java naming conventions.

For example, an operation name "some-op" will get munged into the Java name "someOp". The isAddedAsyMethod() heuristic looks to see if there are two methods in an interface that share the same operation name, but differ from the operation name in method name -- when dropped to lowercase. My example here meets that criteria, but does not constitute an "extra" asynchronous method being present. It's just tripping on the mistaken assumption that an operation name and method name will be the same save for case.

We need a better collision detection heuristic here -- perhaps one that takes the operation name-to-Java name munging into account.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (CXF-627) WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations

Posted by "Steven E. Harris (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CXF-627?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12501974 ] 

Steven E. Harris commented on CXF-627:
--------------------------------------

The change arrived in this morning's Maven snapshot update, and it works as expected. Thanks for fixing this problem.

> WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations
> -----------------------------------------------------------------------------------------
>
>                 Key: CXF-627
>                 URL: https://issues.apache.org/jira/browse/CXF-627
>             Project: CXF
>          Issue Type: Bug
>          Components: Tooling
>    Affects Versions: 2.0-RC
>         Environment: NA
>            Reporter: Steven E. Harris
>            Assignee: jimma
>             Fix For: 2.0
>
>
> Per the discussing on the cxf-user mailing list in the thread entitled
>   JAX-WS enableAsyncMapping directive not respected
>   http://www.nabble.com/Re%3A-JAX-WS-enableAsyncMapping-directive-not-respected-p10292965.html
> the class org.apache.cxf.tools.wsdlto.frontend.jaxws.processor.internal.OperationProcessor uses a method called isAddedAsyMethod() to determine whether it has already defined an asynchronous method for a given operation name. Its detection heuristic fails for operation names that don't conform to the Java naming conventions.
> For example, an operation name "some-op" will get munged into the Java name "someOp". The isAddedAsyMethod() heuristic looks to see if there are two methods in an interface that share the same operation name, but differ from the operation name in method name -- when dropped to lowercase. My example here meets that criteria, but does not constitute an "extra" asynchronous method being present. It's just tripping on the mistaken assumption that an operation name and method name will be the same save for case.
> We need a better collision detection heuristic here -- perhaps one that takes the operation name-to-Java name munging into account.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Assigned: (CXF-627) WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations

Posted by "Bozhong Lin (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CXF-627?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Bozhong Lin reassigned CXF-627:
-------------------------------

    Assignee: jimma  (was: maomaode)

> WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations
> -----------------------------------------------------------------------------------------
>
>                 Key: CXF-627
>                 URL: https://issues.apache.org/jira/browse/CXF-627
>             Project: CXF
>          Issue Type: Bug
>          Components: Tooling
>    Affects Versions: 2.0-RC
>         Environment: NA
>            Reporter: Steven E. Harris
>            Assignee: jimma
>             Fix For: 2.0
>
>
> Per the discussing on the cxf-user mailing list in the thread entitled
>   JAX-WS enableAsyncMapping directive not respected
>   http://www.nabble.com/Re%3A-JAX-WS-enableAsyncMapping-directive-not-respected-p10292965.html
> the class org.apache.cxf.tools.wsdlto.frontend.jaxws.processor.internal.OperationProcessor uses a method called isAddedAsyMethod() to determine whether it has already defined an asynchronous method for a given operation name. Its detection heuristic fails for operation names that don't conform to the Java naming conventions.
> For example, an operation name "some-op" will get munged into the Java name "someOp". The isAddedAsyMethod() heuristic looks to see if there are two methods in an interface that share the same operation name, but differ from the operation name in method name -- when dropped to lowercase. My example here meets that criteria, but does not constitute an "extra" asynchronous method being present. It's just tripping on the mistaken assumption that an operation name and method name will be the same save for case.
> We need a better collision detection heuristic here -- perhaps one that takes the operation name-to-Java name munging into account.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Assigned: (CXF-627) WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations

Posted by "Bozhong Lin (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CXF-627?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Bozhong Lin reassigned CXF-627:
-------------------------------

    Assignee: maomaode  (was: jimma)

> WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations
> -----------------------------------------------------------------------------------------
>
>                 Key: CXF-627
>                 URL: https://issues.apache.org/jira/browse/CXF-627
>             Project: CXF
>          Issue Type: Bug
>          Components: Tooling
>    Affects Versions: 2.0-RC
>         Environment: NA
>            Reporter: Steven E. Harris
>            Assignee: maomaode
>             Fix For: 2.0
>
>
> Per the discussing on the cxf-user mailing list in the thread entitled
>   JAX-WS enableAsyncMapping directive not respected
>   http://www.nabble.com/Re%3A-JAX-WS-enableAsyncMapping-directive-not-respected-p10292965.html
> the class org.apache.cxf.tools.wsdlto.frontend.jaxws.processor.internal.OperationProcessor uses a method called isAddedAsyMethod() to determine whether it has already defined an asynchronous method for a given operation name. Its detection heuristic fails for operation names that don't conform to the Java naming conventions.
> For example, an operation name "some-op" will get munged into the Java name "someOp". The isAddedAsyMethod() heuristic looks to see if there are two methods in an interface that share the same operation name, but differ from the operation name in method name -- when dropped to lowercase. My example here meets that criteria, but does not constitute an "extra" asynchronous method being present. It's just tripping on the mistaken assumption that an operation name and method name will be the same save for case.
> We need a better collision detection heuristic here -- perhaps one that takes the operation name-to-Java name munging into account.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (CXF-627) WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations

Posted by "jimma (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CXF-627?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

jimma resolved CXF-627.
-----------------------

    Resolution: Fixed

> WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations
> -----------------------------------------------------------------------------------------
>
>                 Key: CXF-627
>                 URL: https://issues.apache.org/jira/browse/CXF-627
>             Project: CXF
>          Issue Type: Bug
>          Components: Tooling
>    Affects Versions: 2.0-RC
>         Environment: NA
>            Reporter: Steven E. Harris
>            Assignee: jimma
>             Fix For: 2.0
>
>
> Per the discussing on the cxf-user mailing list in the thread entitled
>   JAX-WS enableAsyncMapping directive not respected
>   http://www.nabble.com/Re%3A-JAX-WS-enableAsyncMapping-directive-not-respected-p10292965.html
> the class org.apache.cxf.tools.wsdlto.frontend.jaxws.processor.internal.OperationProcessor uses a method called isAddedAsyMethod() to determine whether it has already defined an asynchronous method for a given operation name. Its detection heuristic fails for operation names that don't conform to the Java naming conventions.
> For example, an operation name "some-op" will get munged into the Java name "someOp". The isAddedAsyMethod() heuristic looks to see if there are two methods in an interface that share the same operation name, but differ from the operation name in method name -- when dropped to lowercase. My example here meets that criteria, but does not constitute an "extra" asynchronous method being present. It's just tripping on the mistaken assumption that an operation name and method name will be the same save for case.
> We need a better collision detection heuristic here -- perhaps one that takes the operation name-to-Java name munging into account.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (CXF-627) WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations

Posted by "Bozhong Lin (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CXF-627?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Bozhong Lin updated CXF-627:
----------------------------

    Fix Version/s: 2.0
         Assignee: jimma

> WSDL2Java JAXWS frontend does not handle enableAsyncMapping for non-Java-named operations
> -----------------------------------------------------------------------------------------
>
>                 Key: CXF-627
>                 URL: https://issues.apache.org/jira/browse/CXF-627
>             Project: CXF
>          Issue Type: Bug
>          Components: Tooling
>    Affects Versions: 2.0-RC
>         Environment: NA
>            Reporter: Steven E. Harris
>         Assigned To: jimma
>             Fix For: 2.0
>
>
> Per the discussing on the cxf-user mailing list in the thread entitled
>   JAX-WS enableAsyncMapping directive not respected
>   http://www.nabble.com/Re%3A-JAX-WS-enableAsyncMapping-directive-not-respected-p10292965.html
> the class org.apache.cxf.tools.wsdlto.frontend.jaxws.processor.internal.OperationProcessor uses a method called isAddedAsyMethod() to determine whether it has already defined an asynchronous method for a given operation name. Its detection heuristic fails for operation names that don't conform to the Java naming conventions.
> For example, an operation name "some-op" will get munged into the Java name "someOp". The isAddedAsyMethod() heuristic looks to see if there are two methods in an interface that share the same operation name, but differ from the operation name in method name -- when dropped to lowercase. My example here meets that criteria, but does not constitute an "extra" asynchronous method being present. It's just tripping on the mistaken assumption that an operation name and method name will be the same save for case.
> We need a better collision detection heuristic here -- perhaps one that takes the operation name-to-Java name munging into account.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.