You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@netbeans.apache.org by "Matthias Bläsing (JIRA)" <ji...@apache.org> on 2018/01/16 19:01:00 UTC

[jira] [Commented] (NETBEANS-283) private_key in libs.git module should be renamed

    [ https://issues.apache.org/jira/browse/NETBEANS-283?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16327591#comment-16327591 ] 

Matthias Bläsing commented on NETBEANS-283:
-------------------------------------------

I disagree - the private key is located in a directory: *test/unit/data*. Of course the filename can also be adjusted, but IMHO that is over the top. From the directory it is quite clear, that the private key has a purpose there.

> private_key in libs.git module should be renamed
> ------------------------------------------------
>
>                 Key: NETBEANS-283
>                 URL: https://issues.apache.org/jira/browse/NETBEANS-283
>             Project: NetBeans
>          Issue Type: Bug
>            Reporter: Geertjan Wielenga
>            Priority: Major
>
> In  /libs.git/test/unit/src/org/netbeans/libs/git/jgit/ConnectionTest.java, a private_key is referenced. That reference and the name of the private_key should be changed to private_key_for_testing_only, so that it is clear what it is for, i.e., it is not actually a private_key, which would be a problem to include in a release, but a file used for test purposes only and, to avoid confusion, should be named and referenced as such. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@netbeans.apache.org
For additional commands, e-mail: commits-help@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists