You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Tsz Wo (Nicholas), SZE (JIRA)" <ji...@apache.org> on 2009/05/16 02:15:45 UTC

[jira] Created: (HADOOP-5857) Refactor hdfs jsp codes

Refactor hdfs jsp codes
-----------------------

                 Key: HADOOP-5857
                 URL: https://issues.apache.org/jira/browse/HADOOP-5857
             Project: Hadoop Core
          Issue Type: Improvement
          Components: dfs
            Reporter: Tsz Wo (Nicholas), SZE
            Assignee: Tsz Wo (Nicholas), SZE


There are some normal java methods defiend in .jsp files.  It would be easier if these methods are moved to normal .java files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5857) Refactor hdfs jsp codes

Posted by "Suresh Srinivas (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12710804#action_12710804 ] 

Suresh Srinivas commented on HADOOP-5857:
-----------------------------------------

This is good refactoring. Some comments:
# {{DatanodeJspHelper.generateFileDetails()}} - while forming downloadURL there is an extra +
# {{NodeListJsp.counterReset()}} does not set {{colNum}} to zero?
# {{NodeListJsp.generateNodeData}} initial comments could be more readable if the bullets are in separate line
# Not sure where the code related some of the methods from {{...namenode.JspHelper}} is?


> Refactor hdfs jsp codes
> -----------------------
>
>                 Key: HADOOP-5857
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5857
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 5857_20090518.patch
>
>
> There are some normal java methods defiend in .jsp files.  It would be easier if these methods are moved to normal .java files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5857) Refactor hdfs jsp codes

Posted by "Suresh Srinivas (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12710923#action_12710923 ] 

Suresh Srinivas commented on HADOOP-5857:
-----------------------------------------

Patch looks good +1

> Refactor hdfs jsp codes
> -----------------------
>
>                 Key: HADOOP-5857
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5857
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 5857_20090518.patch, 5857_20090519.patch
>
>
> There are some normal java methods defiend in .jsp files.  It would be easier if these methods are moved to normal .java files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5857) Refactor hdfs jsp codes

Posted by "Tsz Wo (Nicholas), SZE (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5857?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Tsz Wo (Nicholas), SZE updated HADOOP-5857:
-------------------------------------------

    Attachment: 5857_20090519.patch

5857_20090519.patch:
# removed the extra +
# colNum was removed since it was not used
# reformat the comments also reformat some codes for better readability.

Suresh, thanks for the comments.

> Refactor hdfs jsp codes
> -----------------------
>
>                 Key: HADOOP-5857
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5857
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 5857_20090518.patch, 5857_20090519.patch
>
>
> There are some normal java methods defiend in .jsp files.  It would be easier if these methods are moved to normal .java files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5857) Refactor hdfs jsp codes

Posted by "Tsz Wo (Nicholas), SZE (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12710831#action_12710831 ] 

Tsz Wo (Nicholas), SZE commented on HADOOP-5857:
------------------------------------------------

Note that, before applying the patch, run

svn mv src/hdfs/org/apache/hadoop/hdfs/server/namenode/JspHelper.java   src/hdfs/org/apache/hadoop/hdfs/server/common/JspHelper.java
cp src/hdfs/org/apache/hadoop/hdfs/server/common/JspHelper.java src/hdfs/org/apache/hadoop/hdfs/server/namenode/JspHelper.java

After applied the patch, do svn add and svn rm.

{noformat}
     [exec] -1 overall.  
     [exec] 
     [exec]     +1 @author.  The patch does not contain any @author tags.
     [exec] 
     [exec]     -1 tests included.  The patch doesn't appear to include any new or modified tests.
     [exec]                         Please justify why no tests are needed for this patch.
     [exec] 
     [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
     [exec] 
     [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
     [exec] 
     [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
     [exec] 
     [exec]     +1 Eclipse classpath. The patch retains Eclipse classpath integrity.
     [exec] 
     [exec]     +1 release audit.  The applied patch does not increase the total number of release audit warnings.
{noformat}
This is a code refactoring.  No new tests added.

> Refactor hdfs jsp codes
> -----------------------
>
>                 Key: HADOOP-5857
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5857
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 5857_20090518.patch, 5857_20090519.patch
>
>
> There are some normal java methods defiend in .jsp files.  It would be easier if these methods are moved to normal .java files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (HADOOP-5857) Refactor hdfs jsp codes

Posted by "Tsz Wo (Nicholas), SZE (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5857?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Tsz Wo (Nicholas), SZE resolved HADOOP-5857.
--------------------------------------------

       Resolution: Fixed
    Fix Version/s: 0.21.0
     Hadoop Flags: [Reviewed]

I have committed this.

> Refactor hdfs jsp codes
> -----------------------
>
>                 Key: HADOOP-5857
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5857
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>             Fix For: 0.21.0
>
>         Attachments: 5857_20090518.patch, 5857_20090519.patch
>
>
> There are some normal java methods defiend in .jsp files.  It would be easier if these methods are moved to normal .java files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5857) Refactor hdfs jsp codes

Posted by "Tsz Wo (Nicholas), SZE (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12710927#action_12710927 ] 

Tsz Wo (Nicholas), SZE commented on HADOOP-5857:
------------------------------------------------

I checked the web pages manually.  Everything works fine.

> Refactor hdfs jsp codes
> -----------------------
>
>                 Key: HADOOP-5857
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5857
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 5857_20090518.patch, 5857_20090519.patch
>
>
> There are some normal java methods defiend in .jsp files.  It would be easier if these methods are moved to normal .java files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Issue Comment Edited: (HADOOP-5857) Refactor hdfs jsp codes

Posted by "Tsz Wo (Nicholas), SZE (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12710819#action_12710819 ] 

Tsz Wo (Nicholas), SZE edited comment on HADOOP-5857 at 5/19/09 11:20 AM:
--------------------------------------------------------------------------

5857_20090519.patch:
# removed the extra +
# colNum was removed since it was not used
# reformatted the comments.  Also reformatted some codes for better readability.

Suresh, thanks for the comments.

      was (Author: szetszwo):
    5857_20090519.patch:
# removed the extra +
# colNum was removed since it was not used
# reformat the comments also reformat some codes for better readability.

Suresh, thanks for the comments.
  
> Refactor hdfs jsp codes
> -----------------------
>
>                 Key: HADOOP-5857
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5857
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 5857_20090518.patch, 5857_20090519.patch
>
>
> There are some normal java methods defiend in .jsp files.  It would be easier if these methods are moved to normal .java files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5857) Refactor hdfs jsp codes

Posted by "Tsz Wo (Nicholas), SZE (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5857?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Tsz Wo (Nicholas), SZE updated HADOOP-5857:
-------------------------------------------

    Attachment: 5857_20090518.patch

5857_20090518.patch:
- moved namenode.JspHelper to common.JspHelper
- moved namenode jsp codes to a new class namenode.NamenodeJspHelper
- moved datanode jsp codes to a new class datanode.DatanodeJspHelper

> Refactor hdfs jsp codes
> -----------------------
>
>                 Key: HADOOP-5857
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5857
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 5857_20090518.patch
>
>
> There are some normal java methods defiend in .jsp files.  It would be easier if these methods are moved to normal .java files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5857) Refactor hdfs jsp codes

Posted by "Suresh Srinivas (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12710805#action_12710805 ] 

Suresh Srinivas commented on HADOOP-5857:
-----------------------------------------

Ignore my comment (4)...

> Refactor hdfs jsp codes
> -----------------------
>
>                 Key: HADOOP-5857
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5857
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 5857_20090518.patch
>
>
> There are some normal java methods defiend in .jsp files.  It would be easier if these methods are moved to normal .java files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.