You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@cxf.apache.org by "Andriy Redko (Jira)" <ji...@apache.org> on 2020/09/22 01:36:00 UTC

[jira] [Comment Edited] (CXF-8337) wsdl2java generates exceptions which do not follow naming convention

    [ https://issues.apache.org/jira/browse/CXF-8337?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17199730#comment-17199730 ] 

Andriy Redko edited comment on CXF-8337 at 9/22/20, 1:35 AM:
-------------------------------------------------------------

Got it, [~xardasos] , yes, indeed the setter is not present which makes generated XxxFault classes inconvenient for getter / setter deserialization, would changing visibility configuration solve your problem?
{noformat}
ObjectMapper mapper = new ObjectMapper();
mapper.setVisibility(PropertyAccessor.FIELD, Visibility.ANY);  {noformat}

(instructs Jackson to use fields directly)


was (Author: reta):
Got it, [~xardasos] , yes, indeed the setter is not present which makes generated XxxFault classes inconvenient for getter / setter deserialization, would changing visibility configuration solve your problem?
ObjectMapper mapper  = new ObjectMapper();
mapper.setVisibility(PropertyAccessor.FIELD, Visibility.ANY);
(instructs Jackson to use fields directly)

> wsdl2java generates exceptions which do not follow naming convention
> --------------------------------------------------------------------
>
>                 Key: CXF-8337
>                 URL: https://issues.apache.org/jira/browse/CXF-8337
>             Project: CXF
>          Issue Type: Bug
>          Components: JAXB Databinding
>    Affects Versions: 3.3.3
>            Reporter: Tomasz Zorawik
>            Priority: Major
>
> wsdl2java generates wrapper exception class for _fault bean._ The generated exception has method getFaultInfo(). This method name is correct according to JAX-WS specification. However this method returns _fault bean_ stored in a field called _"name of fault bean"._ The name of the field and getter do not follow the naming convention. Why this field is not called "faultInfo"?
> I believe a template responsible for generating exceptions is here:
> excxf-tools-wsdlto-frontend-jaxws-3.3.3.jar!\org\apache\cxf\tools\wsdlto\frontend\jaxws\template\fault.vm
> {color:#172b4d}public $field.ClassName getFaultInfo() {{color}
>  {color:#172b4d} return this.$paraName;{color}
>  } 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)