You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Zhijie Shen (JIRA)" <ji...@apache.org> on 2013/11/05 08:36:17 UTC

[jira] [Commented] (YARN-987) Adding History Service to use Store and converting Historydata to Report

    [ https://issues.apache.org/jira/browse/YARN-987?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13813721#comment-13813721 ] 

Zhijie Shen commented on YARN-987:
----------------------------------

bq. As we discussed offline, Yes thats similar to JHS design and as we decided to go for Cache implementation I think that makes sense to have clear sepration between these two.

As we're going to have cache, the abstraction of ApplicationHistoryContext may be necessary. However, one more question here: webUI and services are going to use ApplicationHistoryContext as well, right? if they are, returning report PB is actually not necessary for web. If they're not, webUI and services need a duplicate abstraction of combining cache and store, which is concise in terms of coding.

Some detailed comments on the patch:

* Add the config to yarn-default.xml as well. Btw, is "store.class" a bit better, as we have XXXApplicationHistoryStore, not XXXApplicationHistoryStorage?
{code}
+  /** AHS STORAGE CLASS */
+  public static final String AHS_STORAGE = AHS_PREFIX + "storage.class";
{code}

* The methods in ApplicationHistoryContext need to be annotated as well.

* Unnecessary code. ApplicationHistoryStore must be a service
{code}
+    if (historyStore instanceof Service) {
+      ((Service) historyStore).init(conf);
+    }
{code}

* Is it better to rename getFinalXXXX to convertToXXXXReport?

* For ApplicationReport, you may want to get the history data of its last application attempt to fill the empty fields bellow.
{code}
+    return ApplicationReport.newInstance(appHistory.getApplicationId(), null,
+      appHistory.getUser(), appHistory.getQueue(), appHistory
+        .getApplicationName(), "", 0, null, null, "", "", appHistory
+        .getStartTime(), appHistory.getFinishTime(), appHistory
+        .getFinalApplicationStatus(), null, "", 100, appHistory
+        .getApplicationType(), null);
{code}

> Adding History Service to use Store and converting Historydata to Report
> ------------------------------------------------------------------------
>
>                 Key: YARN-987
>                 URL: https://issues.apache.org/jira/browse/YARN-987
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Mayank Bansal
>            Assignee: Mayank Bansal
>         Attachments: YARN-987-1.patch, YARN-987-2.patch, YARN-987-3.patch, YARN-987-4.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.1#6144)