You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tinkerpop.apache.org by "Matt Frantz (JIRA)" <ji...@apache.org> on 2015/08/01 18:03:05 UTC
[jira] [Created] (TINKERPOP3-792) select at start of match
traversal on Map can fail
Matt Frantz created TINKERPOP3-792:
--------------------------------------
Summary: select at start of match traversal on Map can fail
Key: TINKERPOP3-792
URL: https://issues.apache.org/jira/browse/TINKERPOP3-792
Project: TinkerPop 3
Issue Type: Bug
Components: process
Affects Versions: 3.0.0-incubating
Reporter: Matt Frantz
Assignee: Marko A. Rodriguez
{noformat}
g.V().valueMap()
.match(__.as('a').select('name').as('name'))
.select('name')
The provided match pattern is unsolvable: [[MatchStartStep(a), SelectOneStep(name), MatchEndStep(name)]]
{noformat}
What I think it happening is that the {{select}} inside the {{match}} is using {{Scope.GLOBAL}}. The workaround is to insert {{identity}}, but I'm not sure why this works, as identity steps appear to be removed by strategy.
{noformat}
g.V().valueMap()
.match(__.as('a').identity().select('name').as('name'))
.select('name')
==>[marko]
==>[vadas]
==>[lop]
==>[josh]
==>[ripple]
==>[peter]
{noformat}
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)