You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tapestry.apache.org by "Paul Ferraro (JIRA)" <ta...@jakarta.apache.org> on 2005/07/11 08:18:09 UTC
[jira] Created: (TAPESTRY-395) Rename framework javascript functions to avoid potential name collisions
Rename framework javascript functions to avoid potential name collisions
------------------------------------------------------------------------
Key: TAPESTRY-395
URL: http://issues.apache.org/jira/browse/TAPESTRY-395
Project: Tapestry
Type: Improvement
Components: Framework
Versions: 4.0
Reporter: Paul Ferraro
Priority: Minor
All javascript functions defined by the framework (e.g. trim(...), focus(...), etc.) be named using a common prefix so that there is little chance of a name collision.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: tapestry-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tapestry-dev-help@jakarta.apache.org
[jira] Closed: (TAPESTRY-395) Rename framework javascript functions to avoid potential name collisions
Posted by "Howard M. Lewis Ship (JIRA)" <ta...@jakarta.apache.org>.
[ http://issues.apache.org/jira/browse/TAPESTRY-395?page=all ]
Howard M. Lewis Ship closed TAPESTRY-395:
-----------------------------------------
Fix Version: 4.0
Resolution: Fixed
Created a Tapestry object, and put all the validation functions into it.
> Rename framework javascript functions to avoid potential name collisions
> ------------------------------------------------------------------------
>
> Key: TAPESTRY-395
> URL: http://issues.apache.org/jira/browse/TAPESTRY-395
> Project: Tapestry
> Type: Improvement
> Components: Framework
> Versions: 4.0
> Reporter: Paul Ferraro
> Assignee: Howard M. Lewis Ship
> Priority: Minor
> Fix For: 4.0
>
> All javascript functions defined by the framework (e.g. trim(...), focus(...), etc.) be named using a common prefix so that there is little chance of a name collision.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: tapestry-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tapestry-dev-help@jakarta.apache.org
[jira] Assigned: (TAPESTRY-395) Rename framework javascript functions to avoid potential name collisions
Posted by "Howard M. Lewis Ship (JIRA)" <ta...@jakarta.apache.org>.
[ http://issues.apache.org/jira/browse/TAPESTRY-395?page=all ]
Howard M. Lewis Ship reassigned TAPESTRY-395:
---------------------------------------------
Assign To: Howard M. Lewis Ship
> Rename framework javascript functions to avoid potential name collisions
> ------------------------------------------------------------------------
>
> Key: TAPESTRY-395
> URL: http://issues.apache.org/jira/browse/TAPESTRY-395
> Project: Tapestry
> Type: Improvement
> Components: Framework
> Versions: 4.0
> Reporter: Paul Ferraro
> Assignee: Howard M. Lewis Ship
> Priority: Minor
>
> All javascript functions defined by the framework (e.g. trim(...), focus(...), etc.) be named using a common prefix so that there is little chance of a name collision.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: tapestry-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tapestry-dev-help@jakarta.apache.org
[jira] Commented: (TAPESTRY-395) Rename framework javascript functions to avoid potential name collisions
Posted by "Norbert Sándor (JIRA)" <ta...@jakarta.apache.org>.
[ http://issues.apache.org/jira/browse/TAPESTRY-395?page=comments#action_12316348 ]
Norbert Sándor commented on TAPESTRY-395:
-----------------------------------------
Personally I would prefer the usage of namespace objects like
Tapestry.FormEventManager
Br,
Norbi
> Rename framework javascript functions to avoid potential name collisions
> ------------------------------------------------------------------------
>
> Key: TAPESTRY-395
> URL: http://issues.apache.org/jira/browse/TAPESTRY-395
> Project: Tapestry
> Type: Improvement
> Components: Framework
> Versions: 4.0
> Reporter: Paul Ferraro
> Priority: Minor
>
> All javascript functions defined by the framework (e.g. trim(...), focus(...), etc.) be named using a common prefix so that there is little chance of a name collision.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: tapestry-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tapestry-dev-help@jakarta.apache.org