You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@arrow.apache.org by "Antoine Pitrou (Jira)" <ji...@apache.org> on 2022/11/23 16:49:00 UTC

[jira] [Commented] (ARROW-18395) [C++] Move select-k implementation into separate module

    [ https://issues.apache.org/jira/browse/ARROW-18395?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17637869#comment-17637869 ] 

Antoine Pitrou commented on ARROW-18395:
----------------------------------------

cc [~benpharkins] if/when you have time for a reasonably small task.

> [C++] Move select-k implementation into separate module
> -------------------------------------------------------
>
>                 Key: ARROW-18395
>                 URL: https://issues.apache.org/jira/browse/ARROW-18395
>             Project: Apache Arrow
>          Issue Type: Task
>          Components: C++
>            Reporter: Antoine Pitrou
>            Priority: Minor
>
> The select-k kernel implementations are currently in {{vector_sort.cc}}, amongst other things.
> To make the code more readable and faster to compiler, we should move them into their own file.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)