You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Uwe Schindler (JIRA)" <ji...@apache.org> on 2012/05/12 04:21:48 UTC

[jira] [Issue Comment Edited] (LUCENE-3489) Refactor test classes that use assumeFalse(codec != SimpleText, Memory) to use new annotation and move the expensive methods to separate classes

    [ https://issues.apache.org/jira/browse/LUCENE-3489?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13273812#comment-13273812 ] 

Uwe Schindler edited comment on LUCENE-3489 at 5/12/12 2:21 AM:
----------------------------------------------------------------

It's easy, just rename codecs to "String[] value" and you are done. After that you can use @AvoidCodecs("SimpleText") or @AvoidCodecs({"SimpleText","Lucene3x"})

See: http://docs.oracle.com/javase/1.5.0/docs/api/java/lang/SuppressWarnings.html
                
      was (Author: thetaphi):
    It's easy, just rename codecs to "String[] value" and you are done. After that you can use @AvoidCodecs("SimpleText") or @AvoidCodecs({"SimpleText","Lucene3x"})
                  
> Refactor test classes that use assumeFalse(codec != SimpleText, Memory) to use new annotation and move the expensive methods to separate classes
> ------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-3489
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3489
>             Project: Lucene - Java
>          Issue Type: Test
>          Components: general/test
>    Affects Versions: 4.0
>            Reporter: Uwe Schindler
>             Fix For: 4.1
>
>         Attachments: LUCENE-3489.patch
>
>
> Folloup for LUCENE-3463.
> TODO:
> - Move test-methods that need the new @UseNoMemoryExpensiveCodec annotation to separate classes
> - Eliminate the assumeFalse-calls that check the current codec and disable the test if SimpleText or Memory is used

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org