You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Jerome Boulon (JIRA)" <ji...@apache.org> on 2009/03/24 19:56:50 UTC

[jira] Created: (HADOOP-5565) The job instrumentation API needs to have a method for finalizeJob,

The job instrumentation API needs to have a method for finalizeJob,
-------------------------------------------------------------------

                 Key: HADOOP-5565
                 URL: https://issues.apache.org/jira/browse/HADOOP-5565
             Project: Hadoop Core
          Issue Type: Bug
            Reporter: Jerome Boulon
            Assignee: Jerome Boulon


The job instrumentation API needs to have a method for finalizeJob, and this function should be called in JobTracker
finalizeJob. 
Currently the jobComplete's method on the job instrumentation class is called only for Job that succeed. 
 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5565) The job instrumentation API needs to have a method for finalizeJob,

Posted by "Jerome Boulon (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5565?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jerome Boulon updated HADOOP-5565:
----------------------------------

    Attachment: HADOOP-5565.patch

Add finalizeJob & terminateJob methods to JobTrackerInstrumentation class

> The job instrumentation API needs to have a method for finalizeJob,
> -------------------------------------------------------------------
>
>                 Key: HADOOP-5565
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5565
>             Project: Hadoop Core
>          Issue Type: Bug
>            Reporter: Jerome Boulon
>            Assignee: Jerome Boulon
>         Attachments: HADOOP-5565.patch
>
>
> The job instrumentation API needs to have a method for finalizeJob, and this function should be called in JobTracker
> finalizeJob. 
> Currently the jobComplete's method on the job instrumentation class is called only for Job that succeed. 
>  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5565) The job instrumentation API needs to have a method for finalizeJob,

Posted by "Eric Yang (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5565?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12688941#action_12688941 ] 

Eric Yang commented on HADOOP-5565:
-----------------------------------

+1 good patch.

> The job instrumentation API needs to have a method for finalizeJob,
> -------------------------------------------------------------------
>
>                 Key: HADOOP-5565
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5565
>             Project: Hadoop Core
>          Issue Type: Bug
>            Reporter: Jerome Boulon
>            Assignee: Jerome Boulon
>         Attachments: HADOOP-5565.patch
>
>
> The job instrumentation API needs to have a method for finalizeJob, and this function should be called in JobTracker
> finalizeJob. 
> Currently the jobComplete's method on the job instrumentation class is called only for Job that succeed. 
>  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5565) The job instrumentation API needs to have a method for finalizeJob,

Posted by "Hadoop QA (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5565?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12689009#action_12689009 ] 

Hadoop QA commented on HADOOP-5565:
-----------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12403548/HADOOP-5565.patch
  against trunk revision 758086.

    +1 @author.  The patch does not contain any @author tags.

    -1 tests included.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no tests are needed for this patch.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 findbugs.  The patch does not introduce any new Findbugs warnings.

    +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

    +1 release audit.  The applied patch does not increase the total number of release audit warnings.

    +1 core tests.  The patch passed core unit tests.

    -1 contrib tests.  The patch failed contrib unit tests.

Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/134/testReport/
Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/134/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/134/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/134/console

This message is automatically generated.

> The job instrumentation API needs to have a method for finalizeJob,
> -------------------------------------------------------------------
>
>                 Key: HADOOP-5565
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5565
>             Project: Hadoop Core
>          Issue Type: Bug
>            Reporter: Jerome Boulon
>            Assignee: Jerome Boulon
>         Attachments: HADOOP-5565.patch
>
>
> The job instrumentation API needs to have a method for finalizeJob, and this function should be called in JobTracker
> finalizeJob. 
> Currently the jobComplete's method on the job instrumentation class is called only for Job that succeed. 
>  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5565) The job instrumentation API needs to have a method for finalizeJob,

Posted by "Hudson (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5565?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12695425#action_12695425 ] 

Hudson commented on HADOOP-5565:
--------------------------------

Integrated in Hadoop-trunk #796 (See [http://hudson.zones.apache.org/hudson/job/Hadoop-trunk/796/])
    

> The job instrumentation API needs to have a method for finalizeJob,
> -------------------------------------------------------------------
>
>                 Key: HADOOP-5565
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5565
>             Project: Hadoop Core
>          Issue Type: Bug
>            Reporter: Jerome Boulon
>            Assignee: Jerome Boulon
>             Fix For: 0.20.0
>
>         Attachments: HADOOP-5565.patch
>
>
> The job instrumentation API needs to have a method for finalizeJob, and this function should be called in JobTracker
> finalizeJob. 
> Currently the jobComplete's method on the job instrumentation class is called only for Job that succeed. 
>  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5565) The job instrumentation API needs to have a method for finalizeJob,

Posted by "Chris Douglas (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5565?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Chris Douglas updated HADOOP-5565:
----------------------------------

       Resolution: Fixed
    Fix Version/s: 0.20.0
     Hadoop Flags: [Reviewed]
           Status: Resolved  (was: Patch Available)

+1

I committed this. Thanks, Jerome

> The job instrumentation API needs to have a method for finalizeJob,
> -------------------------------------------------------------------
>
>                 Key: HADOOP-5565
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5565
>             Project: Hadoop Core
>          Issue Type: Bug
>            Reporter: Jerome Boulon
>            Assignee: Jerome Boulon
>             Fix For: 0.20.0
>
>         Attachments: HADOOP-5565.patch
>
>
> The job instrumentation API needs to have a method for finalizeJob, and this function should be called in JobTracker
> finalizeJob. 
> Currently the jobComplete's method on the job instrumentation class is called only for Job that succeed. 
>  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5565) The job instrumentation API needs to have a method for finalizeJob,

Posted by "Jerome Boulon (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5565?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jerome Boulon updated HADOOP-5565:
----------------------------------

    Release Note: Add finalizeJob & terminateJob methods to JobTrackerInstrumentation class
          Status: Patch Available  (was: Open)

> The job instrumentation API needs to have a method for finalizeJob,
> -------------------------------------------------------------------
>
>                 Key: HADOOP-5565
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5565
>             Project: Hadoop Core
>          Issue Type: Bug
>            Reporter: Jerome Boulon
>            Assignee: Jerome Boulon
>         Attachments: HADOOP-5565.patch
>
>
> The job instrumentation API needs to have a method for finalizeJob, and this function should be called in JobTracker
> finalizeJob. 
> Currently the jobComplete's method on the job instrumentation class is called only for Job that succeed. 
>  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.