You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Junping Du (JIRA)" <ji...@apache.org> on 2015/05/06 12:50:00 UTC
[jira] [Updated] (YARN-3276) Refactor and fix null casting in some
map cast for TimelineEntity (old and new)
[ https://issues.apache.org/jira/browse/YARN-3276?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Junping Du updated YARN-3276:
-----------------------------
Attachment: YARN-3276-v3.patch
Thanks [~gtCarrera9] for review and reminding.
I just rebase it against latest branch YARN-2928. Also, rename TimelineUtils to TimelineServiceUtils and mark it as private according to offline discussion with [~zjshen].
> Refactor and fix null casting in some map cast for TimelineEntity (old and new)
> -------------------------------------------------------------------------------
>
> Key: YARN-3276
> URL: https://issues.apache.org/jira/browse/YARN-3276
> Project: Hadoop YARN
> Issue Type: Sub-task
> Components: timelineserver
> Reporter: Junping Du
> Assignee: Junping Du
> Attachments: YARN-3276-v2.patch, YARN-3276-v3.patch, YARN-3276.patch
>
>
> Per discussion in YARN-3087, we need to refactor some similar logic to cast map to hashmap and get rid of NPE issue.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)