You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Livia Zhu (Jira)" <ji...@apache.org> on 2024/09/24 21:36:00 UTC

[jira] [Created] (SPARK-49772) Simplify and clarify dbOptions for RocksDB

Livia Zhu created SPARK-49772:
---------------------------------

             Summary: Simplify and clarify dbOptions for RocksDB
                 Key: SPARK-49772
                 URL: https://issues.apache.org/jira/browse/SPARK-49772
             Project: Spark
          Issue Type: Task
          Components: Structured Streaming
    Affects Versions: 3.4.3
            Reporter: Livia Zhu


RocksDB.scala has 2 sets of options: columnFamilyOptions and dbOptions. columnFamilyOptions is vestigial (it is not used anywhere else in the code other than the creation of dbOptions). To simplify the code, we should remove this and set configs in dbOptions directly. Furthermore, we should rename dbOptions to rocksDbOptions for clarity. 



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org