You are viewing a plain text version of this content. The canonical link for it is here.
Posted to user@ant.apache.org by "Shackelford, John-Mason" <Sh...@ncs.com> on 2002/08/15 22:17:08 UTC

custom data type name collision

In writing a custom task that has a custom data type are name collisions to
be avoided at all costs?

More specifically, I am writing a new set of tasks for PVCS. To make it more
flexible I have a top level tag called PCLI (the command line controller for
Version Manager) and then a data type AbstractCommand which I extend for
individual commands. One of the most commonly used PCLI command is "Get."
Can I get away with using "Get" for my subclass even though it's the name of
a core task or do I need to be content with PLCIGet or something equally
nasty?

I realize after writing the above that the class names are of secondary
importance as the mapping from class name to tag is done with ant directive
or property file. Are task names and data types case sensitive? 



John-Mason Shackelford

Software Developer
NCS Pearson - Measurement Services
2510 North Dodge St.
Iowa City, IA 52245
319-354-9200x6214
shacjo@ncs.com

**************************************************************************** 
This email may contain confidential material. 
If you were not an intended recipient, 
Please notify the sender and delete all copies. 
We may monitor email to and from our network. 
****************************************************************************

--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: custom data type name collision

Posted by Erik Hatcher <ja...@ehatchersolutions.com>.
I don't think there is any reason to worry about a collision in your 
case.  The mapping for a nested element to a custom task is done through 
your Java codes naming conventions for your addXXX or createXXX or 
addConfiguredXXX methods - not through a property file.

I hope I'm understanding what you're talking about and answering the 
right question, but if not let me know.

	Erik


Shackelford, John-Mason wrote:
> In writing a custom task that has a custom data type are name collisions to
> be avoided at all costs?
> 
> More specifically, I am writing a new set of tasks for PVCS. To make it more
> flexible I have a top level tag called PCLI (the command line controller for
> Version Manager) and then a data type AbstractCommand which I extend for
> individual commands. One of the most commonly used PCLI command is "Get."
> Can I get away with using "Get" for my subclass even though it's the name of
> a core task or do I need to be content with PLCIGet or something equally
> nasty?
> 
> I realize after writing the above that the class names are of secondary
> importance as the mapping from class name to tag is done with ant directive
> or property file. Are task names and data types case sensitive? 
> 
> 
> 
> John-Mason Shackelford
> 
> Software Developer
> NCS Pearson - Measurement Services
> 2510 North Dodge St.
> Iowa City, IA 52245
> 319-354-9200x6214
> shacjo@ncs.com
> 
> **************************************************************************** 
> This email may contain confidential material. 
> If you were not an intended recipient, 
> Please notify the sender and delete all copies. 
> We may monitor email to and from our network. 
> ****************************************************************************
> 
> --
> To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
> For additional commands, e-mail: <ma...@jakarta.apache.org>
> 
> 
> 



--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>