You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Arun Suresh (JIRA)" <ji...@apache.org> on 2016/07/31 19:14:20 UTC

[jira] [Created] (YARN-5457) Refactor DistributedScheduling framework to pull out common functionality

Arun Suresh created YARN-5457:
---------------------------------

             Summary: Refactor DistributedScheduling framework to pull out common functionality
                 Key: YARN-5457
                 URL: https://issues.apache.org/jira/browse/YARN-5457
             Project: Hadoop YARN
          Issue Type: Sub-task
            Reporter: Arun Suresh


Opening this JIRA to track the following refactoring missed in YARN-5113:

* Move {{OpportunisticContainerAllocator}} to yarn-server-common
** Fix the constructor to just pass in the appropriate TokenSecretManager instead of the NodeStatusUpdater.
* Move the {{DistributedScheduler}} class to yarn-server-common and probably move all the app specific bookkeeping to the SchedulerNode.
* Rename {{DistributedSchedulingAMService}} to {{OpportunisticSchedulingAMService}}
** modify the {{getServer}} method to enable the new protocol only if DistributedScheduling is enabled.
** modify the allocate method to intercept all OPPORTUNISTIC requests and use the {{OpportunisticContainerAllocator}} to allocate and create the containers.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org