You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Vladimir Ozerov (JIRA)" <ji...@apache.org> on 2016/08/04 05:15:21 UTC

[jira] [Created] (IGNITE-3625) IGFS: Use common naming for IGFS meta and data caches.

Vladimir Ozerov created IGNITE-3625:
---------------------------------------

             Summary: IGFS: Use common naming for IGFS meta and data caches.
                 Key: IGNITE-3625
                 URL: https://issues.apache.org/jira/browse/IGNITE-3625
             Project: Ignite
          Issue Type: Task
          Components: IGFS
    Affects Versions: 1.6
            Reporter: Vladimir Ozerov
            Assignee: Taras Ledkov
             Fix For: 1.8


Currently IGFS is configured by passing names of two caches: meta and data. See {{FileSystemConfiguration.metaCacheName}} and {{FileSystemConfiguration.dataCacheName}}.

These two caches are considered internal then and are not accessible for the user.

We need to do the following during node startup:

1) If certain cache is configured as meta or data cache for multiple IGFS-es, or if it is configured as both meta and data cache for a single IGFS, then throw an exception.
Relevant code pieces:
{{IgfsProcessor.validateLocalIgfsConfigurations}}
{{IgfsProcessorSelfTest}}.

2) During node startup change the name of this cache to {{igfs-[IGFS_NAME]-meta}} or {{igfs-[IGFS_NAME]-data}}. Change must be performed both inside IGFS config and cache config.
Relevant code pieces:
{{CacheConfiguration.name}}
{{FileSystemConfiguration.metaCacheName}}
{{FileSystemConfiguration.dataCacheName}}
{{IgfsUtils.prepareCacheConfiguration}} - where change will be done.

3) If any of new names clashes with any other cache name, an exception should be thrown. The most simple way: throw an exception if user-configured cache name starts with "{{gfs-}} and ends with {{-meta}} or {{-data}}.
Relevant code pieces:
{{IgniteNamedInstance.initializeDefaultCacheConfiguration}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)