You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "luigi malpeli (JIRA)" <ji...@codehaus.org> on 2007/11/28 15:20:57 UTC

[jira] Commented: (MECLIPSE-358) plugin installed via eclipse:install-plugins have the wrong name

    [ http://jira.codehaus.org/browse/MECLIPSE-358?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_115241 ] 

luigi malpeli commented on MECLIPSE-358:
----------------------------------------

Thanks Carlos,
 the patch goes in the proper direction about the file name problem I reported before and is for sure complete to solve all the naming problem but has a new problem as it adds an extra ".jar" extension to file and to folders too in 2.4 plugin version. 
ex. 
org.eclipse.core.commands_3.2.0.I20060605_1400.jar.jar 
that is a jar file and should be named org.eclipse.core.commands_3.2.0.I20060605_1400.jar 

and 
org.eclipse.pde.build_3.2.1.r321_v20060823.jar that is a folder and should be named org.eclipse.pde.build_3.2.1.r321_v20060823 
without the jar extension 

I'm not sure that this is the problem but DefaultMaven2OsgiConverter adds the extension. 

public String getBundleFileName(Artifact artifact) 
    { 
        return getBundleSymbolicName(artifact) + "_" + getVersion(artifact.getVersion()) + ".jar"; 
    }




> plugin installed via eclipse:install-plugins have the wrong name
> ----------------------------------------------------------------
>
>                 Key: MECLIPSE-358
>                 URL: http://jira.codehaus.org/browse/MECLIPSE-358
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Bug
>    Affects Versions: 2.4, 2.5
>         Environment: jdk 1.5.0_12 eclipse 3.2.x maven 2.0.7 win xp professional
>            Reporter: luigi malpeli
>            Assignee: Carlos Sanchez
>         Attachments: eclipse-create.zip, eclipse-plugin-patch.txt, eclipse.patch
>
>
> when processing eclipse:install-plugins the plugins are installed using just the artifactId as name. This gives problems at least in the following cases:
> 1) when trying to modify/construct from scratch an original eclipse installation;
> 2) when trying to install different plugins with the same artifactId and version but different groupId, the first installed atrifact or the latter wins depending on the overwrite=false/true parameter setting;
> In my opinion the name should be a concat of the groupid a dot and the current proposed name.
> I'll attach a proposed patch and some test files ASAP.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira