You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hc.apache.org by Torsten Rendelmann <to...@economed.de> on 2020/04/17 15:54:23 UTC

Feature request: URIBuilder to support RFC 6068 (mailto: URLs)

Hello,

Just want to know if this was yet dicussed (is there no "search" 
available via HTTP mail archive(s)??) or approved:
I like to have the URIBuilder supports https://tools.ietf.org/html/rfc6068

Currently the tested version 5.0 has a strange behavior, not preserving 
the (private) field "encodedSchemeSpecificPart", if e.g. .setParameter() 
calls used to build a "mailto:my@email.com?subject=xyz&body=mailbody" URLs:

     new URIBuilder("mailto:my@email.server") only works, but
     new URIBuilder("mailto:my@email.server").setParameter("subject", 
"mail subject") .setParameter("body", "mail body") fails

Also there are no setter/getter for the field 
"encodedSchemeSpecificPart" to add the e-mail address;
that might help to get around the current missing support.

Thanks, Torsten


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Re: Feature request: URIBuilder to support RFC 6068 (mailto: URLs)

Posted by Michael Osipov <mi...@apache.org>.
Am 2020-04-17 um 22:50 schrieb Oleg Kalnichevski:
> On Fri, 2020-04-17 at 21:46 +0200, Michael Osipov wrote:
>> Am 2020-04-17 um 17:54 schrieb Torsten Rendelmann:
>>> Hello,
>>>
>>> Just want to know if this was yet dicussed (is there no "search"
>>> available via HTTP mail archive(s)??)
> 
> Markmail has a pretty decent search functionality
> 
> https://markmail.org/search/?q=order%3Adate-backward+list%3Aorg.apache.hc
> 
> So does Pony Mail
> 
> https://lists.apache.org/list.html?dev@hc.apache.org
> 
>>>   or approved:
>>> I like to have the URIBuilder supports
>>> https://tools.ietf.org/html/rfc6068
>>>
>>> Currently the tested version 5.0 has a strange behavior, not
>>> preserving
>>> the (private) field "encodedSchemeSpecificPart", if e.g.
>>> .setParameter()
>>> calls used to build a "mailto:my@email.com?subject=xyz&body=mailbod
>>> y" URLs:
>>>
>>>       new URIBuilder("mailto:my@email.server") only works, but
>>>       new URIBuilder("mailto:my@email.server").setParameter("subject
>>> ",
>>> "mail subject") .setParameter("body", "mail body") fails
>>>
>>> Also there are no setter/getter for the field
>>> "encodedSchemeSpecificPart" to add the e-mail address;
>>> that might help to get around the current missing support.
>>
>> You should open a JIRA issue for this. Otherwise this will get
>> lost...
>>
> 
> Please note that java.net.URI conforms to RFC 2396 only. Therefore I
> reviewed URIBuilder for compliance with RFC 2396 up to this point.
> 
> Please provide a unit test demonstrating what you see as incorrect
> behavior of URIBuilder with failing asserts. If the actual behavior of
> URIBuilder violates RFC 2396 we will fix it. We can also consider
> making URIBuilder compliant with newer specs as a feature request.

I would highly favorize RFC 3986, URI is a horrible source of errors.
Maybe for 5.1?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Re: Feature request: URIBuilder to support RFC 6068 (mailto: URLs)

Posted by Oleg Kalnichevski <ol...@apache.org>.
On Fri, 2020-04-17 at 21:46 +0200, Michael Osipov wrote:
> Am 2020-04-17 um 17:54 schrieb Torsten Rendelmann:
> > Hello,
> > 
> > Just want to know if this was yet dicussed (is there no "search" 
> > available via HTTP mail archive(s)??)

Markmail has a pretty decent search functionality

https://markmail.org/search/?q=order%3Adate-backward+list%3Aorg.apache.hc

So does Pony Mail

https://lists.apache.org/list.html?dev@hc.apache.org

> >  or approved:
> > I like to have the URIBuilder supports 
> > https://tools.ietf.org/html/rfc6068
> > 
> > Currently the tested version 5.0 has a strange behavior, not
> > preserving 
> > the (private) field "encodedSchemeSpecificPart", if e.g.
> > .setParameter() 
> > calls used to build a "mailto:my@email.com?subject=xyz&body=mailbod
> > y" URLs:
> > 
> >      new URIBuilder("mailto:my@email.server") only works, but
> >      new URIBuilder("mailto:my@email.server").setParameter("subject
> > ", 
> > "mail subject") .setParameter("body", "mail body") fails
> > 
> > Also there are no setter/getter for the field 
> > "encodedSchemeSpecificPart" to add the e-mail address;
> > that might help to get around the current missing support.
> 
> You should open a JIRA issue for this. Otherwise this will get
> lost...
> 

Please note that java.net.URI conforms to RFC 2396 only. Therefore I
reviewed URIBuilder for compliance with RFC 2396 up to this point.

Please provide a unit test demonstrating what you see as incorrect
behavior of URIBuilder with failing asserts. If the actual behavior of 
URIBuilder violates RFC 2396 we will fix it. We can also consider
making URIBuilder compliant with newer specs as a feature request.

Oleg



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Re: Feature request: URIBuilder to support RFC 6068 (mailto: URLs)

Posted by Michael Osipov <mi...@apache.org>.
Am 2020-04-17 um 17:54 schrieb Torsten Rendelmann:
> Hello,
> 
> Just want to know if this was yet dicussed (is there no "search" 
> available via HTTP mail archive(s)??) or approved:
> I like to have the URIBuilder supports https://tools.ietf.org/html/rfc6068
> 
> Currently the tested version 5.0 has a strange behavior, not preserving 
> the (private) field "encodedSchemeSpecificPart", if e.g. .setParameter() 
> calls used to build a "mailto:my@email.com?subject=xyz&body=mailbody" URLs:
> 
>      new URIBuilder("mailto:my@email.server") only works, but
>      new URIBuilder("mailto:my@email.server").setParameter("subject", 
> "mail subject") .setParameter("body", "mail body") fails
> 
> Also there are no setter/getter for the field 
> "encodedSchemeSpecificPart" to add the e-mail address;
> that might help to get around the current missing support.

You should open a JIRA issue for this. Otherwise this will get lost...


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org